PDA

View Full Version : cold weather problems



lil_white_cavy
01-28-2007, 03:13 AM
just wondering if anybody can help me out on this...........

seems like everytime it turns somewhat cold weather my car acts up.........

its a 98 cavalier 2.2, if i let it sit and idle it will idle fine, when i try and give it gas it tries to stall out and die..........but if you keep on the gas it seems like it blows it out and runs fine............

i've done a lot of trial and error within the past year, everything helps for a little while and it goes back again...........

tried plugs and wires, both o2 sensors, new batt. and alt, several fuel filters, fuel injectors, air intake sensor, replaced the TPC about 2years ago, "could it be going out again?"

sometimes its a PITA and sometimes its fine, seems like it always straightens back out in spring and summer and back down again in fall and winter.......

thanks

joshs98runner
01-28-2007, 11:57 AM
Is it all stock? I would recommend cleaning the MAF, cleaning your TPS and seeing how that does, what kind of 02 sensors did you put in the car? I have heard of a lot of people having trouble with the bosch and other aftermarket brand 02's because they relay information to the computer much slower than the factory 02 sensors. If you have access to a dyno shop or know of one it might be very beneficial for you to hook up a wideband sensor to the exhaust and have the tunner data log the car when it does that if you can't figure out the problem on your own. Also if you have a cold air intake with a bend in it before the MAF it could be messing with the turbulence in the intake path and causing your MAF to read funny.

lil_white_cavy
01-28-2007, 02:00 PM
i put a ram air intake on it, but there's only 1 sensor that goes into it, the air itake temperature sensor..........

next dumb question, how can i clean those sensors?????

thanks

lowrollin70gmc
02-01-2007, 11:59 PM
Electrical contact cleaner will clean the sensors.

My Tacoma had one go out from a K&N intake. But it was too late for me and I had to drop coin on a new MAF sensor.

Good luck.

neonrt
02-14-2007, 04:50 PM
egr valve? does a 2.2 cav have one of them?

Coolwazabi
02-16-2007, 07:01 PM
maybe its the catalyic converter... i doubt it since it isn't very old... but having a bad one defiently shut your car down..

lil_white_cavy
02-19-2007, 01:35 AM
yup, the cavy 2.2 has an egr valve.......

some other people have also suggested the cat. being bad........i swapped the stock one 4 another 1 and its not been the best ever, seems like i've had problems ever since i switched em.........

i'm planning on buying a magnaflow cat. 53004, yeah its a universal but i think it would work

audiobahnuser18
02-19-2007, 01:37 AM
Egr Valve.

lil_white_cavy
03-07-2007, 02:39 AM
well, i took it in for some servicing about 2 weeks ago and they thought my head gasket was shot but ended up being the water pump...........but i know that wont cause my cold weather problems