PDA

View Full Version : Excelon X890 flashes "waiting" on screen.



tab10
12-20-2006, 09:05 AM
I purchased the XM Direct kit XMD1000 I believe for my Kenwood Excelon X890. I got it all hooked up and working correctly, but there is one little quirk that keeps bugging me.

On the headunit, I have the display set to show Channel name, artist name, followed by song name. Well, it keeps flashing "Waiting", then shows the channel name.. then flashes "Waiting" then the artist name" and then the song name just flashes. It has continued to keep doing this and I cannot figure how to make it stop. Am I SOL and going to have to choose another display setting?

MBrock4u
12-20-2006, 08:11 PM
How does it sound? Thinking about getting XM for my Excelon. As far as it flashing, it does that on mine when I put a CD in , but only for a few and then we are in business. Seems like only a minor incoveinence for me. Its probably something simple, but these Excelons and be a bit tricky.

tab10
12-21-2006, 09:48 AM
How does it sound? Thinking about getting XM for my Excelon. As far as it flashing, it does that on mine when I put a CD in , but only for a few and then we are in business. Seems like only a minor incoveinence for me. Its probably something simple, but these Excelons and be a bit tricky.

Well, it sounds great and all...except for that the display keeps flashing "Waiting" when XM is turned on. It is enough of an annoyance for me to mention it. :furious: I really wish I could figure out how to get rid of it.

MBrock4u
12-22-2006, 04:34 AM
I will have time to look into it more deeply over the holiday weekend. If I find something out I will let you know. Life is very busy right now.