PDA

View Full Version : idle problem



Mat Dope
12-13-2006, 09:42 PM
iv got a 94 mazda 626 2.0

anyway it used to idle fine, now when i sit at idle the rpms often dip and rise. then steady out for a second.

now when im idling it will be fine and then dip quick and stall.

maybe it could be a vacuum hose or dirty injector heads, any ideas???

rtillaree
12-13-2006, 09:46 PM
there can be many factors to an idle issue, believe it or not 626's are notorious for idle problems, all models after the 80's...it could be your pcv vavle or even an exhaust issue...if i were you i would join mazda626.net and check around there, just make sure to keep strict posting etiquette over there or you wont stand a chance...

bumpinne0n
12-13-2006, 10:09 PM
iv got a 94 mazda 626 2.0

anyway it used to idle fine, now when i sit at idle the rpms often dip and rise. then steady out for a second.

now when im idling it will be fine and then dip quick and stall.

maybe it could be a vacuum hose or dirty injector heads, any ideas???

My car was doing that. Whenever I'd get off the interstate and push the clutch in, the car would stall out. I needed to clean the mass air flow sensor, which ended up ruining it, so I picked up another one and it runs great again.

There's a lot of things it could be. Without a Check Engine Light or anything like that coming on, it's probably going to be a pain to pinpoint. Look around the internet and see what other people did with the same problem.

DeViOuSoNe
12-13-2006, 10:13 PM
Get a spray bottle with water, And spray Vacuum Lines, Thats the first thing i would do, Either that or Carb cleaner, When it hits the leak it will idle up

sentra95
12-14-2006, 04:06 PM
I could be due to many thigs but i would check your TPS sensor.

Mat Dope
12-16-2006, 11:52 AM
ok thanks guys i will do all of the above. my check engine light only comes on sometimes and luckly i know a guy who has a diagnositc computer to hook it up to so hopefully ill be able to do that.

killahbean
12-16-2006, 07:07 PM
yes could be anything but it sounds like the TPS (throttle position sensor)

Mat Dope
12-16-2006, 11:30 PM
that forum link really helped me out thanks rtillaree

i cleaned the MAF and IAC and it helped stabalize the idle but only when the a/c is off.

tommorrow im going to change the fuel filter, pcv vale, sparkplugs, and the air filter so hopefully that will help me out.

from what i have read in bad cases the problem could be the cat. converter

also i need to take apart my distro cap and probly replace the rotor

rtillaree
12-16-2006, 11:38 PM
yea with the Mazda 626's it can be anything man, ive been in the automotive industry forever, i've got tons of i-car and similar type certs, as well as many years under the hood, but i tell you when it comes to the idle problem on these cars, its a lot of trial and error and work, i've got a 2002 626, and i've had the problem 3 times, first time was the CC, 2nd time it the was pcv and the 3rd time it was the actual control sensor...

frustrating for sure...

good luck man

audiobahnuser18
01-19-2007, 02:38 AM
I just recently had that problem i sprayed some carb cleaner in the carb and used the throttle body a couple times while spraying it in the carb cleaned it right up runs good now:).

Curel
01-19-2007, 07:26 PM
It is most likely your idle air control valve.