PDA

View Full Version : 95 ford escort reverse lights



Bspeltback
12-04-2006, 07:04 PM
When I put my car into reverse the lights don't come on. I tried replacing the switch on the side of the tranny and still no luck.....the bulbs aren't blown so is there a fuse? the manual says nothing about this.

phantom240
12-04-2006, 09:00 PM
maybe a fuse. Take a dmm and check to make sure you have continuity and rule out any broken wires.

HannaS10
12-04-2006, 09:02 PM
same thing happens on my truck. when i put it into reverse the lights flash and then turn off.

Bspeltback
12-04-2006, 10:19 PM
Wheres the fuse for it? the book doesn't say anything about reverse, crappy book. another thing, its got nothing to do with cars, but does anyone know where I can get tickets to a sold out show. I wanna see Killswtich Engage but out there is sold out.

phantom240
12-04-2006, 10:57 PM
eBay?

Bspeltback
12-05-2006, 07:54 PM
Nop tried it, so back to the task at hand, Does anyone know where the fuse is?

Silver
12-07-2006, 10:06 PM
Look under the dash or hood. The fuse panel should have all labels on back. Pull one by one and replace anything blown.

Also look in the owners manual.

Must be a short in the wiring system. Check from the fuse to the switch. Check the switch even though you just replaced it, get someone to put the car in reverse as u check it. Check from the switch back to the bulb.

Search on a escort forum also and see if you can round up a schematic on the reverse light system or exterior lights system. I can help you out better that way.

heyman421
12-07-2006, 10:08 PM
find a ford escort forum

* not flaming, i'm dead serious

Louisiana_CRX
12-07-2006, 10:13 PM
Yeah they have forums on nearly everything...as far as the reverse lights not working...I've had problems with my 96 Mustang since new...They will work sometimes and sometimes they don't...

heyman421
12-07-2006, 10:15 PM
the microswitch probably needs adjusted