PDA

View Full Version : My crossover exploded, why?



freddie1
11-30-2006, 12:46 AM
i was driving home from school and after about 40 minutes of driving i heard a really loud "knock" from the right side of my car. it sounded like a big rock hit my windshield and then it smelled like a burnt speaker. one of the yellow things inside blew up. why did this happen? i have a set of cdt cl-61a/tw24 comps and i was givin them 260w. is this defective or shorted out somewhere? i set my gains correctly and i did not abuse them.

it's the yellow part that's in the smaller circle:
http://i65.photobucket.com/albums/h234/waggs182/xover.jpg

thanks in advance.

ntense702
11-30-2006, 12:48 AM
wow that's crazy, never heard of such a thing happening, maybe some kind of freak thing like a short or something, or possibly a defective product.

Rich B
11-30-2006, 12:49 AM
You blew a capacitor, but the photo is too bad to tell if anything more is gone.

pwnt by pat
11-30-2006, 12:49 AM
faulty component
too much power

Notwerk
11-30-2006, 01:11 AM
Not to talk trash, but that's the third or fourth "my CDT crossover exploded!" post I've read over the years.

ultimate157
11-30-2006, 01:14 AM
*edited* read incorrectly.

Weird.

freddie1
11-30-2006, 01:17 AM
i thought that it was 130w each side? is that what i ****ed up on?

ultimate157
11-30-2006, 01:20 AM
Yes you're correct, I read it as if you were giving them 260 to each side.

Sounds like a bad capacitor to me. How old are they? Still have warranty?

Makes me weary to put 150w to each side that I am now ...

freddie1
11-30-2006, 01:26 AM
oh sorry about that. i just got them like a month and a half ago so they are basically new and still have the warranty. nothing else seems to be damaged and the speakers still work but i'm too afraid to turn it past 5/40 cause i don't wanna mess up anything else...

ultimate157
11-30-2006, 01:36 AM
Call the place you bought them from and see if you can get a warranty claim.

jmanpc
11-30-2006, 01:38 AM
i had a crossover explode on me.... just sent it back to quart and got new ones

freddie1
11-30-2006, 01:49 AM
i had a crossover explode on me.... just sent it back to quart and got new ones
what's quart?

DJ Kontakt
11-30-2006, 02:56 AM
faulty component
too much power


+1 thats the problem

jmanpc
11-30-2006, 03:00 AM
what's quart?

MB Quart

Naxis2k1
11-30-2006, 08:29 AM
not new to me at all. cdt speakers/products have blown up on me countless times. iam done with that company.

elementxero
11-30-2006, 08:56 AM
not new to me at all. cdt speakers/products have blown up on me countless times. iam done with that company.

lol, I'm not saying you're lying, I'm just saying it sounds hilariously exaggerated to say that their products have blown up countless times


:laugh: :laugh: :laugh:

BassAddictJ
11-30-2006, 01:54 PM
get them warranty''d


i once noticed condonsation inside mine...eventually one of them died :( maybe condensation + electricity pwn'd urs like it did mine ... :p

alteraudiousa
11-30-2006, 02:07 PM
I don't understand, were you giving it 260 or 130rms. if giving 260rms per side thats way too much power and thats more than likely your problem. If its 130rms, well could be a bad part, could be it got bumped in installation, got be alot of things. if you got them from a dealer just send it back in and you'll be fine.

freddie1
11-30-2006, 03:09 PM
i was giving them 130w each side. i've heard of people putting 150w to them but i didn't want to go that high cause i don't want stuff breaking. but it did anyway so i'll just return the crossover and get a new one:)

freddie1
11-30-2006, 03:15 PM
get them warranty''d


i once noticed condonsation inside mine...eventually one of them died :( maybe condensation + electricity pwn'd urs like it did mine ... :p

mine were inside my car so it wouldn't get wet and everything appeared to be good so i guess it was a defective part. and that piece popped really loud for being a little ****er:crap:

pwnt by pat
11-30-2006, 05:55 PM
they usually explode - and yes, they are loud.