PDA

View Full Version : bass skips head unit, what do i do?



Lil Poot
11-01-2006, 11:28 AM
i mounted my HU as securely as i could in my explorer, but when i play really punchy bass, like korn, or if i play steady bass songs like trap house, bme click, late night tip, it will skip after 15 seconds or so when the skip protection memory can't keep up.

only thing thats coming to mind is disassembling my dash and wrapping the thing in foam or ensolite or something. thats a lot of work though, what do you guys do to keep your decks from skipping?

the727kid
11-01-2006, 12:11 PM
Mine has never skipped. A better HU maybe?

Lil Poot
11-01-2006, 12:12 PM
700 dollar top of the line clarion not good enough?

Lil Poot
11-01-2006, 12:17 PM
you're also using 12's, i'm using 15's in a big ported box and an suv, with more power. im assuming you're sealed in a trunked car?

reneeb7363
11-01-2006, 12:21 PM
DONT WRAP IT!!! you will overheat the deck! :eek:

I went to the plumbing supply store and found some rubber bushings (usually wrapped around copper pipe to prevent noise and damage to the pipe at the 'hangers'). Where my HU mounts, and where it sat partially on the plastic console, I installed these bushings and supported the bottom of the unit...
also make sure it is a VERY secure mounting all around. Most dashes and/or consoles are flimsy and actually make the vibrations on the hu worse. Sure it takes some time to re-install all this, but as far as the cost of my sanity... we saved it just in time! LOL!

Lil Poot
11-01-2006, 12:25 PM
bah... maybe i'll just get sirius...

Lil Poot
11-01-2006, 12:37 PM
hows the sound quality on xm/sirius? my dad has sirius, but its a stock stereo and the sirius uses one of those fm transmitter things to get the signal to the deck, so it doesnt really sound any different than anything else in his truck.

i dont really want to buy a 50 dollar antenna and set up a subscription to hook it up to a high end deck and components and have it sound like ***.

Lil Poot
11-01-2006, 12:41 PM
how did you reinforce it, and did it make the problem go away? i haven't even put in my alternator OR done the big 3 yet, im going to be getting quite a bit louder... which doesn't do me much good if i can't turn it up.

KARLEON
11-01-2006, 03:11 PM
you're also using 12's, i'm using 15's in a big ported box and an suv, with more power. im assuming you're sealed in a trunked car?

im using two 15s in a huge ported box in an explorer with a pioneer 880prs headunit. Havent had a skipping problem yet. and my 20.1 amp is wired down to .5ohms on my death penaltys