PDA

View Full Version : neon help please.... its tickn me off



chinxtaboi
12-17-2002, 10:38 PM
iight guys i got 2 6" neon tubes in the front and one 36" one under the back seat.... all of it is ran through a distribution block to a switch.....

problem is one of the tubes keeps dimming, turning on and off....... its jus so irritating

:mad: :mad: :mad: :mad: :banghead: :banghead: :furious: :banghead: :confused: :(

Q45guy
12-19-2002, 11:46 PM
What tube is dimming? Is it a 6" neon tube or the 36" tube? It may be just a bad transformer. Whats the manufacturer of those neon tubes? I have LOTS of neon in my car, so I have lots of experiance with installing/wiring them up.

chinxtaboi
12-20-2002, 12:43 PM
its liteglow... only one of the 6" tube is dimming the other ones are jus fine.

please help
thanks for any help

:)

fantomas
12-22-2002, 04:12 PM
make sure you check the ground. If the contacts are not connecting properly...you probably have a bad ground. or theres just something wrong with the neon -scott

chinxtaboi
12-27-2002, 05:18 PM
so should i jus change the ground location?

:confused:

fantomas
12-27-2002, 06:07 PM
Originally posted by chinxtaboi
so should i jus change the ground location?

:confused:

well...it might be a possibility..but if there is something wrong with the transformer...a new ground location will not help. if there is no warranty...just take a peek at the circuitry. if it looks like something is toasted...thats your problem...are all the neons grounded at the same place? if they are..the ground is not the problem....if not..switch out the two 6" neons and see if that helps. -scott