PDA

View Full Version : Tweeters problem....



gramus_666
08-28-2006, 07:46 PM
Hi

Im not very expirienced with tweeters so i decide not to invest lots of money in the one i bought. What came out is that the build in croosover they have in makingmy midllerange a tweeter in serial connection (both tweeter and speaker are 4 Ohm so thats the only possible way as im not using any amps to power the speakers just Cd deck) i donno how to solve that problem because its pointless to connect them like that + the tweeter is actually making more noise than clear sound, i donno if thats the quality ove here or quality of the connection but system is way clearer without those tweeters and im powering old (13y/o) stock speakers in my car ( ive tried all posible speakers on the market and stock once works best i donno y).

Cheers Luke.

6spdcoupe
08-28-2006, 10:19 PM
Huh?

azbass
08-28-2006, 11:08 PM
what?

smd4life
08-28-2006, 11:10 PM
Hi

Im not very expirienced with tweeters so i decide not to invest lots of money in the one i bought. What came out is that the build in croosover they have in makingmy midllerange a tweeter in serial connection (both tweeter and speaker are 4 Ohm so thats the only possible way as im not using any amps to power the speakers just Cd deck) i donno how to solve that problem because its pointless to connect them like that + the tweeter is actually making more noise than clear sound, i donno if thats the quality ove here or quality of the connection but system is way clearer without those tweeters and im powering old (13y/o) stock speakers in my car ( ive tried all posible speakers on the market and stock once works best i donno y).

Cheers Luke.

wow your a baddass

but seriously whats the problem?

mikeyboc
08-28-2006, 11:13 PM
:chicken:

phantom240
08-28-2006, 11:16 PM
Hi

Im not very expirienced with tweeters so i decide not to invest lots of money in the one i bought. What came out is that the build in croosover they have in makingmy midllerange a tweeter in serial connection (both tweeter and speaker are 4 Ohm so thats the only possible way as im not using any amps to power the speakers just Cd deck) i donno how to solve that problem because its pointless to connect them like that + the tweeter is actually making more noise than clear sound, i donno if thats the quality ove here or quality of the connection but system is way clearer without those tweeters and im powering old (13y/o) stock speakers in my car ( ive tried all posible speakers on the market and stock once works best i donno y).

Cheers Luke.

ya know... even though we guys hate periods (as us with gfs know already) they can come in handy... like when youre trying to say something meaningful. Just a thought though...




























and btw Grammar > u

gramus_666
08-28-2006, 11:59 PM
The problem is that the tweeter is making my middle range speaker pick up only freequency from built in crossover in the tweeter (serial connection).

Sry for the last post. When i reread it now i cannot understand it myself :]

azbass
08-29-2006, 12:00 AM
is the mid and tweet wired to a passive crossover?

phantom240
08-29-2006, 01:02 AM
Its because youre retarded. Did you wire the tweet BEFORE or AFTER the midrange? Also, as I think about this, wiring it in series is what your problem is. Its acting like those gay *** "bass blockers" wire it in parallel, and if you toast the HU, it must have ****** or u bought ****** tweeters.

heyman421
08-29-2006, 01:04 AM
holy ****, that was hard to read

can someone let me know if it's worth it?

gramus_666
08-29-2006, 01:18 AM
the crossover is build in inside the tweeters and i have no info bout it what so ever. and im not retarded u moron before u put an insult u can ask, well i wired them both ways (BEFORE and After,, ive tried everything beside wiring them in parralel cuz that can fry my Cd deck)

so far only azbass is ok, the rest is just smartmouth ********* that dont have a life and spend their time on posting stupid posts ( ill recomend some worning and bans for those ppl)

6spdcoupe
08-29-2006, 01:57 AM
maybe if you provided us with what Kind of drivers they are we could be helpful ! Even pics maybe? You do have a camera no?

LoudCrownVic
08-29-2006, 02:00 AM
Trying to understand this scrambled logic makes me want to pee myself.

gramus_666
08-29-2006, 11:16 AM
no offence but for **** sackes i was just talking bout pointless posts and here they are again. go and pee yourself if that turns you on,

Anyway the tweeters are cheap very cheap without the brand name ( i didnt want to invest lots of money cuz im just trying to see if tweeters make some significant difference to the system, so far the quality is poor (lots of noise) prob cuz they are cheap)

And the question is :

Is there a way to connect those tweeters to the system so it will work like they should work??

im runing Pioneer Premier DEH-P8MP, stock speakers (explanation in 1st post), Visonik Digital Amp VXD709 800W, 12" Visonic Competition Sub 1000W if that can help

If thats complicated next time ill include manual.

phantom240
08-29-2006, 05:25 PM
Im pretty sure its because youre running in series.

gramus_666
08-30-2006, 12:18 AM
Well than how i can solve that prob.? is there any way beside hooking up an extra amplifier?? (pararel is not an option)

Cheers

phantom240
08-30-2006, 12:21 AM
Are you SURE that the tweets are 4 ohm? cuz most all of em are like 15 ohm and stuff... hell the street edge tweets i have are run in parallel... mind you they are electrostatic tweets and are a bit harsh.. but the point is, ive seen very few4 ohm tweets.

What brand and model # are they?

6spdcoupe
08-30-2006, 02:30 AM
Are you SURE that the tweets are 4 ohm? cuz most all of em are like 15 ohm and stuff... hell the street edge tweets i have are run in parallel... mind you they are electrostatic tweets and are a bit harsh.. but the point is, ive seen very few4 ohm tweets.

What brand and model # are they?

WHAT?!?!?!

gramus_666
08-31-2006, 01:15 AM
1st thing. what the hell is bout those stupid posts, where is admin or mod?? sleeping?? for that kina stuff its a worning and ban later on, on most forums. please stop its getting pathetic and annoying

There are axactly the same tweeters just i bought 1 pair

http://cgi.ebay.ca/3-PAIR-AMERICAN-PRO-300W-TWEETER-TWEETERS-CROSSOVER-BI_W0QQitemZ270023770522QQihZ017QQcategoryZ3292QQs sPageNameZWDVWQQrdZ1QQcmdZViewItem

cheers

P.S> sory for spelling english is my 2nd language.

phantom240
08-31-2006, 03:17 AM
well not to be a ****, but 3 dollar tweets ftl.