PDA

View Full Version : got a new set of morels, need some help. . .



pik
08-01-2006, 01:02 AM
Well, Don got me a nice price for a set of Morel Dotech MkII's 6.5 set, and i;m having some probs settin them up. I'm running actively through an Eclipse CD-7000.

I got this set to replace a classic set of Arc ACS265's---loved this set but, i had a problem with a mid (don't ask). My settings with the arcs were:

mids: 80Hz 18db slope-1.25Khz 12db slope
tweets: 3Khz 18db slope
the specs on this set were a frequency range from 60hz-20Khz

everything was peachy, nice midbass (not huge but nice, realism)

now today i tossed in the new set, made a new set of rings, added some clay, added more raamat to the doors (hey the panel were off, why not), kept the same x-over points. keep in mind morel lists this set down to 40Hz much lower than the Arc's.

the mids are playing terribly, tons of distortion, I had to change the bottom x-over point to 160Hz just to keep the distortion out of them.

what the heck is wrong here??? I'm really confused. I love the morel tweet it plays down pretty low. these are my new settings:

Mids: 160hz (yuk) at 24 db slope to 800 hz 12db slope
tweets: 1.25Khz 18db slope

everything about this set is really killer I love the sound, i just don't know what's wrong with the low end?

anyone want to help? I couldn't really have gotten 2 bad mids right?

thanks

jp

6spdcoupe
08-01-2006, 01:36 AM
JP feel free to gimme a call tomorrow, we can discuss a bit. 2am for me...Im sleepy. ;)

pik
08-01-2006, 10:50 PM
no one has any ideas????

squeak9798
08-01-2006, 11:10 PM
How much power are you running?

pik
08-01-2006, 11:39 PM
active on a Memphis MCA-3004, underrated at 75x4

http://www.memphiscaraudio.com/products/details.asp?id=13