PDA

View Full Version : Car stereo wont work unless door open!



chatman56
07-10-2006, 10:34 PM
I have a 99 chevy venture van, and my stereo wont work unless the passenger door is open. This is an odd problem and i was wondering whats wrong! All four speakers dont work unless i open the passenger door, and when i do they fade in and work perfectly,but as soon as i close the door they all stop working. Sometimes they will keep working even after the door is closed, but when i hit a bump they stop again. Can anyone help? Thanks!!

Calikid
07-10-2006, 10:36 PM
what turns off, speakers, stereo or both?

wlmrs
07-10-2006, 10:38 PM
loose or pinched wires maybe

revrider1
07-10-2006, 10:40 PM
Sounds like maybe a pinched wire somewhere.

neonrt
07-10-2006, 10:40 PM
what turns off, speakers, stereo or both?
exactly. if just speakers, prob a wire in your door, or going to your door. if stereo, possibly bad ground somewhere near your door?

ItalynStylion
07-10-2006, 11:01 PM
But he said that ALL the speakers go off. If it was a pinched wire then it would be only the speaker in that door that didnt work.

Silver
07-10-2006, 11:03 PM
Did you or anyone mess with any wiring?

Railrocker
07-10-2006, 11:04 PM
remote lead hooked up to the same fuse as the dome light :laugh:


Nah seriously I dont know thats weird :crap:

Kickerkitty
07-10-2006, 11:06 PM
Do you have any wires run through the door hinge area?

mokedaddy
07-10-2006, 11:06 PM
On most decks Ive installed, if you short out one speaker they all cut out, so I would suggest the same as above and check the harness going into the door for a pinched or grounded wire.

Calikid
07-10-2006, 11:07 PM
thats what i think it is too

Prowler573
07-10-2006, 11:08 PM
It cannot be the remote line being attached to the dome light fuse if, as he posted, sometimes it still works after the door gets closed until he hits a bump...

Calikid
07-10-2006, 11:10 PM
i will say he should re-route all his wires.

chatman56
07-11-2006, 01:57 AM
Thanks so much for being so quick guys. This is the stock stereo so im not sure what has changed from when I first got it.. Like, I know pretty much nothing about wiring anything and I've never unscrewed anything in my car. I've checked all of the fuses and everything seems fine, so if someone could give me detailed steps as to what I have to do that would be unreal. Thanks!

chatman56
07-11-2006, 01:59 AM
Oh yeah, I forgot to add, when I open the door ALL FOUR speakers work perfectly, and when I close it, ALL FOUR turn off. And it's not just when I turn on the inside lights either, cause I've tried that with the doors closed. I also disable the inside lights for when I open the door, and still it turns back on.

azbass
07-11-2006, 02:00 AM
On most decks Ive installed, if you short out one speaker they all cut out, so I would suggest the same as above and check the harness going into the door for a pinched or grounded wire.
x2

Beat_Dominator
07-11-2006, 02:01 AM
I identified your problem. GM product :(


J/K that's a weird thing to have happen. The entire stereo is stock? I'm stumped :confused:

ItalynStylion
07-11-2006, 07:24 AM
I identified your problem. GM product :(


:laugh:x234

Ignatowski
07-11-2006, 07:43 AM
:eyebrow:

prolly a speaker wire in the door grounding out....

squeak9798
07-11-2006, 10:58 AM
I agree with all that has been mentioned before.....definitely sounds like a wire shorting out.

Pop off the passenger side door panel, remove and disconnect the speaker and then trace the wires back and see where they are getting pinched and/or if the insulation on the wire is damaged somewhere exposing the copper wire.

GordonW
07-11-2006, 12:42 PM
Check inside the door in question, near where the wires go into the door. Sounds suspiciously like the wire harness for the speaker is tangled up in the door-stop slider (the thing that prevents the door from opening too far).

Otherwise, it could be anywhere in the grommet/flex tube that carries the wires from the door to the car body... wires shorting together, OR to ground...

Regards,
Gordon.

Railrocker
07-11-2006, 12:48 PM
Do you know if this particular vehicle has a factory amplifier. These are sometimes mounted in the kick panel by the passenger door if there is some kindo of harness attached to the amp it may have come loose. Is your stereo still on/working when the speakers cut out?

iamamp3pimp
07-11-2006, 02:26 PM
But he said that ALL the speakers go off. If it was a pinched wire then it would be only the speaker in that door that didnt work.


not true.

if there is a pinched wire, the internal amp is probably going into protect

chatman56
07-12-2006, 05:08 AM
The stereo is still completely functional when the speakers cut out; It still displays the time, and tells me when the track on a CD has changed and so on. I can still tune the radio and everything, just no sound unless the passenger door is open.

theelfkeeper
07-12-2006, 10:17 AM
your lucky if its grounding out somewhere and you haven't fried the unit. every time i've ever grounded out a speaker on a HU, its fried the internal amp...but that does sound like your problem to me.

squeak9798
07-12-2006, 11:26 AM
The stereo is still completely functional when the speakers cut out; It still displays the time, and tells me when the track on a CD has changed and so on. I can still tune the radio and everything, just no sound unless the passenger door is open.

Have you done anything we have suggested yet?

chatman56
07-14-2006, 04:54 AM
Hey, so i opened the door, and where the doors hinge is theres a thick black rubber cable.. which felt like it contained some more wires. I gave the cable a tug and shook it around just as a dumb attempt, and everything works now. Guess it was getting pintched or something? Thanks soo much for all your help!!!