PDA

View Full Version : A/C Question?



GRANDV
06-27-2006, 02:23 PM
I had a new A/C condensor fan and motor installed in my Grand Vitara. It was checked by the mechanic that it was not leaking freon. So, picked it up and notice on the 3rd day after that the a/c was not working. So, before I went back, I replaced the fuse and still nothing. They check it again and said that they replaced the freon and bam it was working. Then after a week of not using it and then on Saturday, turned it on and hot air again. Does anybody know if there might be something else going on. I wanted to know before I took it back and had them check it again for the 3rd time. Thank you.

Russ Raymer
06-28-2006, 12:08 AM
What it sounds like to me is that all of the refrigerant is leaking out. When you get below a certain level of refrigerant, (usually a little under a pound) the a/c wont work. What happens is that it notices that you are low on refrigerant and it doesnt let the compressor kick on. If I were you I would check to see if the compressor is engaging. If it isnt and they add refrigerant to it and it works then that means that you have a leak. If you go there again and they add refrigerant and it works and they send you on your way and it quits again, I would go somewhere else and have it checked out.

GRANDV
06-28-2006, 01:38 PM
Thanks.

GRANDV
06-28-2006, 01:39 PM
I am hoping that if it is a leak that the repair cost to fix the leak is not to expensive.

Russ Raymer
06-28-2006, 07:08 PM
If it is a leak and it is where they did the work then it should be free.