PDA

View Full Version : Clutch/tranny problem? 99 avenger



SwaveY
03-18-2006, 10:29 AM
Hey, i have a 99 dodge avenger 2.0 dohc 5 speed. I dont usually post on any other forum except for car audio and s10 forum. Nobody there even posted so here i am. If this is in the wrong section please move it for me- i thought this was the best place to post.

I got into my car early thismorning to go to the hospital 15 minutes away. On the way there as i shifted through gears it felt hard to physically push my shifter into gear. I thought i was just tired and didnt think anything of it until i came home. Its very very hard to put the car into 1st gear. I have to slam it into 1st, then when i shift to second it pretty much forces me to grind gears. It used to be so easy to shift i barely had to even hold onto it, i could just flick it and it would go into gear.

My clutch now feels like for the first 3 inches or so ( it might just feel like 3 inches) it will just fall down when i touch it. It doesnt seem to get any pressure until i get near the bottom of it. I checked my clutch fluid and it was to the top where its supose to be, and that little resevoir thing didnt have any in it. I filled it up to the line and pumped the clutch a bunch of times. It seems to have pressure now and is easier to shift, but is still very hard. What should i do? The guy at the autoparts place said my seals might be leaking on my master or slave cyl to take it to a shop and have it looked at. I really dont have the money to be taking it to a shop and them tell me i just needed something stupid and i gotta pay em $60 for calling me an idiot for an hour of work. Any help would be awesome.

Side note: i dont think it is my clutch, but i might be wrong. I have 65,000 on this car and its run perfect until today. I blew the clutch out on my s10 when i had it and it would shift to gears just fine, only it would blow smoke and not move. Its hard as hell to get it into gear on this car, but when i get it in there it moves just fine.

Thanks for any help!

SwaveY
03-18-2006, 06:00 PM
okay thanks