View Full Version : Jeep Grand Cherokee Carputer Help

03-10-2006, 04:48 PM
Well i have a stock Carputer it whatever its called in my car.Its all messed up like it flashes the doors on the screens saying there open when they are closed and like idk its just all screwed up.

.Has anyone else had this problem if so how do i fix it?

Any help would be greatly Apperciated Thanks


03-10-2006, 04:57 PM
Haha, my ex's car did the exact same thing. Just left it alone.


03-10-2006, 07:29 PM
haha Thanks for the reply

03-12-2006, 03:45 AM

03-12-2006, 03:54 AM
you mean your electrical is messed up? happened on my moms old van which was a plymouth, which is owned by daimler-chrysler who also owns jeep. it got ****in annoying after a while cuz the car would say the door was open and it would try to lock all the doors automatically when they where already shut and it was loud as hell. you just have to slam all the doors really hard and sometimes that might help.

03-15-2006, 08:19 PM
What year is it?

03-15-2006, 10:59 PM

03-15-2006, 11:29 PM
just find the fuse that contros it and pull it

03-15-2006, 11:32 PM
More likely than not, it is the door switches. They wear out and will ground themselves out causing an open circuit. Does it happen to 1 or 2 specific doors? Or do all of them do it?

03-15-2006, 11:34 PM
My 95 Jeep says rear door ajar when the hatch it shut and like said above I just pulled the fuse out cuz it beeped all the time and got annoying. I dont have interior lights either, 93-98 Jeeps **** when it comes to electrical.

03-15-2006, 11:35 PM
i hate my jeep im gonan make it a project car :( thanks for everyones help i guess ill pull the fuse..

Its like all the doors.. and says the lights are out? and blinks over andover again

03-15-2006, 11:38 PM
Don't pull the fuse. It may not just control that. When you say lights are out, do you mean interior door lights? If this is the case, and those lights work, have the vanity mirror lights checked. When I was a tech at a Chrystler dealership, the vanity lights caused more problems than they are worth. Just a few ideas for you.

03-16-2006, 12:07 AM
twisted for teh win!

03-16-2006, 01:54 AM
I have a 97 grand cherokee limited, as I agree I hate the little computer and display.Love the vehicle (AT TIMES), hate the electrical.

Every now and then I'll press on the brakes and it says rear lamp failure but all the bulbs are fine.

Oh, and a new problem, the brake light (that lets you know when the e-brake is on) is now stuck on.I gotta admit I hate the electrical system in this POS and the firewall.Other than that I love it but it gives me new problems every ****ing week.

03-16-2006, 01:57 AM
haha yah My brake light is always on and my E brake isnt on and its gay!

03-16-2006, 04:29 AM
lol, yep......same problem for me :( I think it's something simple, I put on the e-brake one day and when I took it off, the **** light is on.

If this thing didn't totally crush my 98 mountaineer that I had before in acceleration, top end speed, luxury, and gas mileage I would be selling the **** thing.

03-16-2006, 08:25 AM
2 main things on the e-brake light. #1 check and make sure the fluid level is correct, #2 the micro switch has either been jossled loose/ or hanging up and not fully releasing. Check the switch if the fluid is good and see if it just needs to be adjusted or it may need to be replaced. The fluid level is a trick I learned from when we had a 96 Tacoma. Had it in the shop 4 times for the **** light, and they never got it fixed. Called a guy I use to work with at the dealership, and that's when he told me about the fluid level. They can be down as little as a 1/2 in. and still throw the light.

03-16-2006, 06:42 PM
Checked the fluid level and it seems fine, haven't ****ed with any switches yet.