PDA

View Full Version : Clarion VRX935VD Issue



Nikolaos44
12-02-2005, 12:03 AM
I have the HU and I had it installed in my ford Explorer and it worked just fine. Well, I just picked up a 2000 Escalade and now my volume buttons don't work and the screen won't come out. I tried 2 different harnesses with the same results... I just had the unit sent out, fixed, and returned from Clarion for a Laser issue. What issue am I having now? Anyone else have this problem? I feel like throwing it again't the wall. It's only 2 years old. :mad: :mad: :mad: :mad:

XxXTransAmXxX
12-03-2005, 02:37 PM
Some of the newer GM units require an interface in the system, otherwise it'll fry the components...Even the new Cavaliers have them. Is the unit powering up?

Shelbrain
12-03-2005, 07:53 PM
In order to remove the factory headunit in my 05 Impala, it was necessary to purchase Peripheral's GMCO harness. It worked like a charm for my needs. I have OnStar, but did not care about losing it.
http://www.cardomain.com/item/PERGMCO
I bought it on ebay for $60 after shipping

Nikolaos44
12-05-2005, 11:13 AM
I bought the bose adapter with the onstar. But still.

Nikolaos44
12-05-2005, 11:14 AM
Some of the newer GM units require an interface in the system, otherwise it'll fry the components...Even the new Cavaliers have them. Is the unit powering up?



The unit does power up and there is music from coming from all speakers...I just can't adjust volume or make the screen come out. And the funny thing is, the remote changeds the volume! Must be the top screen face or something.