PDA

View Full Version : Pioneer p80mp wont eject



turnstylez18
09-01-2005, 02:19 PM
i went to the mall today..and after that when i got home the deck wouldn't eject or come out..i kept trying to press the eject but it wouldnt come out..its a motorized face plate...does neone have this problem? what should i do?

swoosh
09-01-2005, 03:05 PM
I have had that problem with every pioneer I have ever had... Even my 6700 is starting to do it :(

It ejects part way? If so push down on it with your fingernail as you push eject right before it gets stuck, then it should come out enough for you to grab it.

JAZN
09-01-2005, 04:00 PM
try to slide the face plate off even though it's closed (u might have to use a small flathead/knife to push the release button in the back). after you get it off, spray wd-40 on the gears, make sure u get the gears in the back that u cant really see. should work fine after that.

turnstylez18
09-01-2005, 04:01 PM
its weird...i tried to disconnect the deck and reset it but i when i took out the mounting kit it ejected..now it works again...i think pioneer decks are sensitive to heat and cold...cuz i left the face this time..and thats when it stopped working..ahh well...i guess its fine for now..

SBLAZER
09-01-2005, 04:02 PM
i have the same problem, wha solves it is 2 press the eject button and give the faceplates a lil pop wit ya hand, thats wha i tol everyone that has had a prob like we have and it works, try it and see.

turnstylez18
09-01-2005, 04:04 PM
i have the same problem, wha solves it is 2 press the eject button and give the faceplates a lil pop wit ya hand, thats wha i tol everyone that has had a prob like we have and it works, try it and see.

yeah i think thats what i did by aaccident..when i pull the mounting kit out it caused a bump..and thats how it actually ejected..
are pioneers known to do this?

anthongy817
09-01-2005, 05:44 PM
i just got my p860mp today...eject on it doesn't work either...=[

i can hear it trying to eject but the face doesnt even move. anybody have any recommendations?

3.5Max6spd
09-01-2005, 05:48 PM
wow I'm so glad I talked my brother out of that unit....he works at best buy and went with an Alpine 9855 instead

what's with all these bugs pioneer?

seth350
09-01-2005, 05:48 PM
Eject dont work on my pioneer avh-6400cd indash.....

wtf is up with pioneers?

anthongy817
09-01-2005, 05:48 PM
i've seen people with the 9855 having eject problems as well...

3.5Max6spd
09-01-2005, 05:54 PM
i've seen people with the 9855 having eject problems as well...

yup told'm that too...but he got the extended 'no questions asked if returned, get same price current unit' warranty...lol

turnstylez18
09-01-2005, 06:33 PM
yeah all my pioneer decks messes up somehow..but they're good decks...
next time ill get an alpine...but i love the service plan at bestbuy..helped me out a lot

TwistedMovistar
09-02-2005, 09:44 AM
if i didn't have my pioneer 860mp i would have the alpine 9855. this is the second time that someone has memtioned something about the mounting kit(last post is a mounting screw) mabye something is lose before we get them???

Flipx99
09-02-2005, 09:51 AM
My face just blinks in and out. Never had a problem with discs not ejecting but since I got XM, I don't use CD much anymore.

SBLAZER
09-02-2005, 09:52 AM
i still love it, great hu, i can deal with it, cuz its an awesome HU, if it was some lower line pioneer, i would sell it in a hurry. but i juss love this HU and a lil problem like that isnt gonna kill me.

turnstylez18
09-02-2005, 11:53 AM
yeah pioneer decks get defected for like one day for me..and the next day its all fine...one time the knob on the p80 stopped working..so i just reattatched the face
and its fine..

SmokeyNChris
09-03-2005, 04:17 AM
my p80 is doing grreat, had it since it first came out.