PDA

View Full Version : Components not working?



Rome85CT
08-22-2005, 10:49 AM
alrite so this past weekend i was drivin with the music in my car up pretty high. i have beyma 5.25 components in the front and 5.25 midranges in the back. im runnin them off a memphis 1000d. all of a sudden the music turned off at high volume, then came back on. however the midrange on the passenger side no long plays anything and at high volumes again the tweeters crackle and all the music turns off in the entire car and then turns on again. do you guys think that there might be a short? crossover blown? amp going into protect? i have no idea. thanks.

Mackenzie
08-22-2005, 12:18 PM
It may be all the above. Did you set your gains with a dmm. Chances are you may have ruined the speakers. It sounds like you have a gain problem though. It sounds to late for your speakers though.

tRiGgEr
08-22-2005, 12:32 PM
You're running 4 stereo speakers on a mono channel amp???

First why would you want to do that? Second What are the model numbers of your speakers? Third what ohm load did you have them wired to?

Mackenzie
08-22-2005, 01:09 PM
You're running 4 stereo speakers on a mono channel amp???

First why would you want to do that? Second What are the model numbers of your speakers? Third what ohm load did you have them wired to?

Nope in his signature it says he has a memphis belle amp, which is a hybrid amp that can run your subs, and coaxes.

Memphis Belle-1100x1 and 75x4

Rome85CT
08-22-2005, 03:16 PM
i mean the speakers still play to a certain extent, except for the one mid in the front, the rears are fine. this definitely *****.

Mackenzie
08-22-2005, 03:39 PM
i mean the speakers still play to a certain extent, except for the one mid in the front, the rears are fine. this definitely *****.

sounds like you have a gain problem. Set your gains with a dmm. Chances are if one of your mids is messing up, then the others are soon to go soon. YOu live and learn.

Rome85CT
08-23-2005, 11:32 AM
yeah i suppose so, is there any way to test the speakers to see if they are blown or not? and is there any reason why at high volumes the speakers would all stop working and then turn on again?>

Rome85CT
08-24-2005, 09:45 AM
bump