PDA

View Full Version : Kenwood KDCX817 issue



Deathby240
08-13-2005, 02:30 AM
Up until now I have had no problems with my Kenwood KDCX814 (link- http://shop.store.yahoo.com/discave/kdkecarcdplf.html )

But yesterday the deck shut itself off. The faceplate folds 180 degress around to expose the black flat "mask"

I turned it back on and it was working fine for a while. Now when I turn the car on, the face flips down (same as when you eject as CD) so that you can remove the faceplate. It will stay like that until you remove the faceplate. Once you take the faceplate off, the deck folds back to normal. I can put the faceplate back on, but then it just folds down again and waits for me to turn it off.

The screen is not lighting up at all and I am getting no sound. There is a CD inside. I tried pushing the reset button but it did nothing.

Any idea whats going on with the deck?

stones
08-13-2005, 05:35 PM
The older Kenwood HU's with the motorized flip down down face have a high rate of failure due to some design flaws. Kenwood corrected these problems in their new 2005 models.
Your options are-
Try pressing the reset pin on the HU and see if that works.
Take the HU to an authorized repair shop, a mechanical sensor inside may need cleaned or replaced.
Upgrade to a an '05 model

scrappy
08-14-2005, 02:49 PM
Mine had the same problem. It is the ribbon that connects the to the face. I think of the actual name for it. I just bought a new one but an authorized repair shop said they would look at it for $50. My new one still is a mask unit I bought an 04 model the new 05 models you should have no problems with

headknocker
08-15-2005, 01:25 PM
Yes, it's the ribbon cable. The same thing happened to my X717. I replaced the cable by following the directions that was provided in an online tutorial. However, the thread was removed several months ago so you're kinda stuck. I did a bonehead trick(don't ask :) ) several months after I fixed the HU and I ruined it for good.

My suggestion is to do what I did...get the Excelon X589 from Locust Audio(on ebay) for around $160 shipped. The '05 units are better in two very important areas....SQ and Kenwood's decision to FINALLY drop the stupid and troublesome D-Mask feature. The new units have a motorized face.

I went with the 589 since it had the same features as the 717 but the 789 and 889 are very sweet-looking HU's as well. They're also a little more money. It's your call...Good Luck.