PDA

View Full Version : What is a good Head Unit that won't skip?



Anonymous
08-11-2005, 06:16 PM
Right now i have a JVC KDLH2000 and on certain tracks that have real hard continuous bass it skips bad. I am going to take it back to the shop to have it looked at but if that does not work i was wondering what head units can take a lot of pressure and not skip. Because i have 4 Orion P Series 15's on 2 Viper 1200's and when i turn it up it skips like crazy.

Thanx

DIPayton
08-11-2005, 06:26 PM
Right now i have a JVC KDLH2000 and on certain tracks that have real hard continuous bass it skips bad. I am going to take it back to the shop to have it looked at but if that does not work i was wondering what head units can take a lot of pressure and not skip. Because i have 4 Orion P Series 15's on 2 Viper 1200's and when i turn it up it skips like crazy.

Thanx

not sure if it's a JVC thing or what but I had 2 JVC head units basicly do the same thing. Skip on long hard bass hits. But I currently have a very cheap low model JVC HU that came with my car and no problems with that one lol.

I dont know for sure, but I am switching to Pioneer. Not because of this problem but I know I had 2 past JVC problems like that. Not a knock on JVC though, they make good HU's.

tRiGgEr
08-11-2005, 06:29 PM
Higher end sony HU's, Kenwood, Alpine, Fosgate, Pioneer

Just make sure it has the antiskip feature.

Slaugh
08-11-2005, 06:43 PM
ill talk about my experience with headunits on ****** asphalts (read as brazilian roads)

Pioneers are almost like bulletproof...

Sonys are waaaay ******... Alpines also skip a lot, but tollerable i think

never heard a JVC thou, but based on the brand solo, it seems like it should skip more than an Alpine for example

i also heard panasonics dont skip a lot, but i could be wrong

JLCivic
08-11-2005, 07:14 PM
I really haven't had any skipping issues with any deck I have owned. The BEST I have used have been Eclipses(hit railroad tracks at 40mph in a civic without skipping, for example). If your current deck skips, have you tried backstrapping to give it more support?

bimma85
08-11-2005, 07:16 PM
Have ya tried securing the cd player even more or putting some dynamat(or something of that nature) on the deck?

Anonymous
08-11-2005, 07:22 PM
No. Because i have never had problems with any other deck but this one so i figured it was something with this deck

Alpine2005
08-11-2005, 07:40 PM
Pioneers are very good

i have a deh-p860mp on my truck. and when i went to mex this summer it never skiped, you guys know how the roads are over there.

or you can get an Ipod it will never skip and keep your jvc

netherland24
08-11-2005, 07:44 PM
dude no way JENSEN, PIONEER, PANASONIC, high end SONY, roadmasters. OWN THE USA ROADS.

Slaugh
08-11-2005, 09:17 PM
what hu is this roadmaster you talking about? wouldnt it be Roadstar by any chance?

Eugenics
08-11-2005, 09:20 PM
i love my sony specialty series HU, its done awesome, its never skipped once! not even when i used to race when it was in my other car... my pioneer used to always skip (was still a good hu though)

HiAmplidude
08-11-2005, 09:41 PM
Some decks that have a working buffer are awesome. I'm still absolutely amazed at the Alpine decks that I've owned with no electronic buffer, yet they don't skip... I mean ever.

A couple examples... Several of my vehicles were extreme off-roaders (as in monster trucks that I'd launch off the dirt ramps and "whoopdeedoos" at a place we call 9-mile Hill")... This was over a decade ago and the suspension of the Alpine decks was so advanced that the music never skipped a beat, even after bending the hell out of my front lift twice from bad landings. Another time, even earlier, I was driving a little Toyota MR2, and a driver beside me didn't see me and literally ran me off the road changing lanes. I crashed into a median and caught air. The front end was pretty well ripped up but all I was thinking was "it didn't skip". All Alpine. I've skipped one of my Alpine decks one time, that I remember, and that was on some beyond crazy constant jarring in the road on a dirty disk. I have to say, without buffer, the Alpine decks absolutely freak me out how well they keep a track!

travd27
08-11-2005, 11:15 PM
my eclipse cd8454 never skips had it for a year and it hasn't skipped once. My previous model Clarion dxz945 would not even play some of the scratched cds i have but the eclipse plays them without any problem.

jimmclrk1
08-12-2005, 05:03 AM
My JVC KD-LHX500 works fine no matter how hard the bass hits. I got mine for $140 shipped. The touchscreen is nice.

3.5Max6spd
08-12-2005, 09:50 AM
Neither of my Eclipse's have ever skipped....a big reason other than sq i continue to use them. My brother had a cd3434 a dropped celica that jittered up and down every pebble on the road and never once skipped either. He now has that same deck in a 98 4runner that has a very rough, truckish suspension with its solid beam axle and still the deck manages to be unaffected. Great dampened player mechanism in these decks...

Slaugh
08-12-2005, 10:37 AM
i remember hearing Eclipse being called E-skips due to it's constant skipping levels, but now im being told the otherwise.. who holds the truth?

locotony
08-12-2005, 10:53 AM
Many of the older eclipses had skipping issues.

Anonymous
08-12-2005, 11:16 AM
How is a Pioneer Premier DEHP670MP?

JLCivic
08-12-2005, 11:17 AM
Many of the older eclipses had skipping issues.
2 model years from what I recall, and those issues were resolved at least 5 years ago.

3.5Max6spd
08-12-2005, 03:25 PM
i remember hearing Eclipse being called E-skips due to it's constant skipping levels, but now im being told the otherwise.. who holds the truth?

weird... my last 3 decks before Eclipses-alpine 7949/7998 and my kenwood x911 were skip monsters.....nothing more agravating

yeah some of the older eclipses had skipping issues

JLCivic
08-12-2005, 03:29 PM
weird... my last 3 decks before Eclipses-alpine 7949/7998 and my kenwood x911 were skip monsters.....nothing more agravating

yeah some of the older eclipses had skipping issues
The past skipping issues with eclipse(98-99 or so) models had nothing to do with vibration, however. It had to do with software/computer chip issues. Any Eclipse I have ever had(especially the 8051 and 8053) have been virtually bomb proof.

Slaugh
08-12-2005, 03:50 PM
weird... my last 3 decks before Eclipses-alpine 7949/7998 and my kenwood x911 were skip monsters.....nothing more agravating

yeah some of the older eclipses had skipping issues
by skip monsters you mean they skipped a lot or that they never skipped? :crazy:

S0CalS0L
08-14-2005, 03:27 AM
I also have an Eclipse CD3434, have had it for over a year now and it hasn't skipped onced. Real great head unit.

Ignatowski
08-14-2005, 07:30 AM
I have never owned a HU that skipped

3.5Max6spd
08-15-2005, 05:43 PM
by skip monsters you mean they skipped a lot or that they never skipped? :crazy:

Skipped all the time, from the day i bought it, getting progressively worse over time.

Just one of the many gripes I had with this HU considering the price I payed at the time.