Closed Thread
Results 1 to 5 of 5

Reload Thread: How long for warranty work on JBL amps?

  1. #1
    F150Matt's Avatar
    F150Matt is offline Senior VIP Member



    Join Date
    Jul 2002
    Location
    Houston, TX
    Age
    29
    Posts
    484
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    3 Post(s)

    How long for warranty work on JBL amps?

    Has anyone ever sent in a JBL amp for warranty work? How long should it normally take? I sent in my 1200.1 almost 4 weeks ago and haven't got it returned yet. When my solo baric went out it only took kicker 3 weeks. Has anyone had any experience with JBL and warranty service?



    Matt Sibley
    Dad, Electrical Engineer, MBA

    Used to do these:
    Team S.P.E.A.D. Captain
    Team Kicker
    Team Maxxsonics
    USACi Pro Stock 5001+ World Record Holder




  2. #2
    Jeff's Avatar
    Jeff is offline Member



    Join Date
    Mar 2002
    Location
    Texas
    Posts
    127
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Just out of curiosity, what happened to your amp? The big orange light under the JBL logo burned out on my 600.1 about two weeks after I installed it, but I'm not going to pull it and mail it off for that.



    1999 GMC reg. cab. Sierra
    Factory HU and tweeters
    JBL p80.4
    JBL bp600.1
    CDT Cambria 6.5"
    (2) JL 10W0-4's

  3. #3
    F150Matt's Avatar
    F150Matt is offline Senior VIP Member

    Threadstarter


    Join Date
    Jul 2002
    Location
    Houston, TX
    Age
    29
    Posts
    484
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    3 Post(s)
    I had a bad subwoofer and the voice coils melted. I believe that caused the amp to maybe short out. At least thats what my audio shop claims. The amp worked on the first sub but the coils melted(bad sub) got it replaced, bought my second sub so I'd have both and run it at 2 ohms mono for 600 watts per sub, and when they hooked the amp back up it just kept blowing the fuses and wouldn't do anything. It put out no power on the test bench either.



    Matt Sibley
    Dad, Electrical Engineer, MBA

    Used to do these:
    Team S.P.E.A.D. Captain
    Team Kicker
    Team Maxxsonics
    USACi Pro Stock 5001+ World Record Holder

  4. #4
    4jb's Avatar
    4jb
    4jb is offline Member



    Join Date
    Jul 2002
    Location
    Oak Ridge, TN
    Posts
    35
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    so do you think it was a problem with JBL??? i was thinking about getting a
    JBL BP1200.1 1200-Watt Subwoofer Amplifier but if i have to face the same troubles i dunno if i will. LOL.




  5. #5
    F150Matt's Avatar
    F150Matt is offline Senior VIP Member

    Threadstarter


    Join Date
    Jul 2002
    Location
    Houston, TX
    Age
    29
    Posts
    484
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    3 Post(s)
    Nah, I don't believe it was JBL's problem. The sub was bad and when the VC's went out it did something to the amp. Anyway, I called up the company today and my amp is shipping out today. They did fix it, by the way I bought it off the net and they did take care of it under warranty!



    Matt Sibley
    Dad, Electrical Engineer, MBA

    Used to do these:
    Team S.P.E.A.D. Captain
    Team Kicker
    Team Maxxsonics
    USACi Pro Stock 5001+ World Record Holder

Closed Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum