Closed Thread
Results 1 to 2 of 2

Reload Thread: Blown Amp?

  1. #1
    HATCHED's Avatar
    HATCHED is offline Junior Member



    Join Date
    Jan 2005
    Location
    PASADENA, CA
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Blown Amp?

    I have a KAC-7251 amp and for some reason as soon as I turn the ignition the fuses blow. I thought that it was a ground or one of the wires coming in contact with something but when I hooked up my alternative amp it works fine. Could my amp be blown? If so what do you guys think I should check or how can i fix it if possible?
    Thanks to any who input in this thread.







  2. #2
    johnecon2001's Avatar
    johnecon2001 is offline SSA/ROE Super-Møderator



    Join Date
    Aug 2004
    Location
    Phoenix, AZ
    Age
    31
    Posts
    5,137
    Post Thanks / Like
    Images
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Blown Amp?

    yeah i had that problem once. turned out the amp was fried. You may want to check the speaker line runs to make sure those arent shorting.




    Don't PM me, I'm not here. Find me on SSA or ROE
    No, I won't re-upload the Big3 pictures. Don't ask.

Closed Thread

Similar Threads

  1. Amp or NOT!
    By wrigley in forum Amplifiers
    Replies: 3
    Last Post: 12-25-2002, 01:33 AM
  2. Replies: 0
    Last Post: 07-28-2002, 06:01 AM
  3. decent amp?
    By drocca in forum Amplifiers
    Replies: 3
    Last Post: 04-19-2002, 01:55 PM
  4. Is my amp blown?
    By SiD in forum Wiring, Electrical and Installation Help
    Replies: 1
    Last Post: 01-05-2002, 11:56 PM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum