Closed Thread
Results 1 to 6 of 6

Reload Thread: Amp Question, Kenwood/Legacy

  1. #1
    Join Date
    Mar 2002
    Location
    NE
    Age
    31
    Posts
    114
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Amp Question, Kenwood/Legacy

    Basicly I have a Legacy Series 2 600 Watt 2 Channel amp. I have 2 12" Memphis Subs. The subs are under rated at 400MAX 200RMS.

    My question, my friend has a new kenwood 350 watt 2 channel amp. This is the newest model next to Excelon I think. Would that amp be better even tho its only have the watts??? Its a question about Quality vs Quanity. More watts or Better watts. Witch would you prefer? On a side note my amp hits hard but sounds ******. His amp hits ok and his old *** kenwood 10's sound pretty good.

    This is the Kenwood Amp I think:
    http://www.kenwoodusa.com/product/p...2&productId=714

    This is my amp:
    http://www.legacycaraudio.com/itempage.asp?model=LA490

    These are my subs:
    http://www.memphiscaraudio.com/P16_PB_Subwoofers.htm







  2. #2
    ramos's Avatar
    ramos is offline Still learning



    Join Date
    Dec 2001
    Location
    Virginia
    Age
    49
    Posts
    10,329
    Post Thanks / Like
    Images
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    104 Post(s)
    I would ask him to let you hook it up and give it a listen. Then if you like how it sounds versus what you already have. Go for it



    5 % equipment
    90 % install
    5% beer

  3. #3
    gibasscarguy's Avatar
    gibasscarguy is offline Member

    Threadstarter


    Join Date
    Mar 2002
    Location
    NE
    Age
    31
    Posts
    114
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Will do.. I alrdy got it hooked up I just need to get a new inline fuse from my 8 Ga. power wire and then I can hear it. I was just curious if it was possible for it to hit as hard with so much less watts.. If quality is better then quanity.




  4. #4
    ramos's Avatar
    ramos is offline Still learning



    Join Date
    Dec 2001
    Location
    Virginia
    Age
    49
    Posts
    10,329
    Post Thanks / Like
    Images
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    104 Post(s)
    It's probably not going to be all that much of a power difference between the amps



    5 % equipment
    90 % install
    5% beer

  5. #5
    gibasscarguy's Avatar
    gibasscarguy is offline Member

    Threadstarter


    Join Date
    Mar 2002
    Location
    NE
    Age
    31
    Posts
    114
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Well I listend to it tonight and the kenwood sounds better I think. It seemed to hit just as hard except with slightly better SQ. I still have a HUGE SQ problem though. The subs just dont hit right.. they are brand new and everything is installed perfectly, I cant find a single reason for them to hit so harsh and like punchy.. Its hard to discribe but the sound is not "smooth" the bass just dont sound good.

    What you think could be the problem?? Or how do you increase SQ in your subs? Would a crossover fix the problem? or is there something else I can do..




  6. #6
    n2audio's Avatar
    n2audio is offline OPTIDRIVEN



    Join Date
    Dec 2001
    Location
    Lawrence, KS
    Posts
    4,419
    Post Thanks / Like
    Images
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    76 Post(s)
    have you messed w/your x/o point? Sounds like you might have it set too high.





    '99 Taurus SHO (welded)
    • HU: Stock - Scosche SLC-4
    • Comps: Lanzar Opti6c w/Opti400x4d
    • Rear fill: Stock
    • Sub: Lanzar Opti1232D w/Opti1000.1d

Closed Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum