Closed Thread
Results 1 to 4 of 4

Reload Thread: JL 500/1 not turning on?

  1. #1
    ASpec818's Avatar
    ASpec818 is offline Member



    Join Date
    Jun 2004
    Location
    Bay Area
    Posts
    98
    Post Thanks / Like
    Mentioned
    0 Post(s)

    JL 500/1 not turning on?

    my amp stopped working today when i started my car. it was working fine yesterday. What could be the problem? I was powering a 10w7 with it. Could it be a blown fuse or something? if so where and how can i check? thanks







  2. #2
    squeak9798's Avatar
    squeak9798 is offline Banned



    Join Date
    Jun 2004
    Location
    USA
    Posts
    26,300
    Post Thanks / Like
    Images
    16
    Mentioned
    0 Post(s)

    Re: JL 500/1 not turning on?

    There should be a fuse under the hood, and a fuse on the amp. Check them both. FYI: sometimes fuses can look fine, but they really are blown.

    Also, check and make sure that all the connectsion (remote on, power & ground wires) are still tightly connected. Also, check and make sure that the ground for the amp is secure and tight.




  3. #3
    ASpec818's Avatar
    ASpec818 is offline Member

    Threadstarter


    Join Date
    Jun 2004
    Location
    Bay Area
    Posts
    98
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: JL 500/1 not turning on?

    the fuse under the hood looks fine. i mean that thing is only a few days old and it's MONSTER!! lol. how do i check the fuse for the jl 500/1? i heard it was internal? do i just unscrew the amp and pull the fuses out?

    also, all the connections seem fine. my amp just stopped getting power- the light doesn't even come on anymore.




  4. #4
    Sleeklsc's Avatar
    Sleeklsc is online now CarAudio.com Veteran



    Join Date
    Jan 2004
    Location
    il
    Posts
    6,867
    Post Thanks / Like
    Mentioned
    17 Post(s)

    Re: JL 500/1 not turning on?

    check the remote lead behind the h/u



    Ref's:1. Midwestcustoms 1.5. Desertheat 2. Mjbailey 3. Terryracing86 4. Sickmint79 5. Untouchable11 6. mattj 7. Ssweet96 8. Kool9accord 9.Kristinspapi10. Kmhogan224 11. Alpine3612 -x3- 12. Vectork39 13. Livinlife 14.Chriscivic 15. Violentraptor 16. Ricky616 17. Bassaddictj 18.orioles26 19.Khail19 20. jak3th3snak311 21. Myjaja 22. Springy101 x2 23. Ali1 24. Privatepastry 25. Plus about 10+ more..

Closed Thread

Similar Threads

  1. Jl 500/1 vs 250/1
    By Stockthunder in forum Amplifiers
    Replies: 4
    Last Post: 04-21-2006, 08:26 PM
  2. (Brahma 12" and Jl 500/1) or (Koda 10" and Jl 500/1)
    By Stockthunder in forum Subwoofers
    Replies: 2
    Last Post: 05-20-2004, 12:49 PM
  3. (JL 500/1, Jl 250/1, brahma, shiva) question
    By Stockthunder in forum Subwoofers
    Replies: 5
    Last Post: 05-18-2004, 09:35 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum