User Tag List

+ Reply to Thread
Results 1 to 12 of 12

Reload Thread: Why did my JL 300/2 burn out

  1. #1
    Konsty25's Avatar
    Konsty25 is offline Junior Member



    Join Date
    Dec 2013
    Location
    las vegas
    Posts
    11
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Why did my JL 300/2 burn out

    Set up im runnin is a JL 300/2 (old slash series amp 12 years old maybe thats why), 2014 Honda acoord oem head unit, audio control adq-61 processor, 4 infinity 2 ohm reference coax speakers (6032 model i think) front and rear. sub in on a jl 500/1

    I loved the sound coming from the speakers with that jl amp. It was a two channel amp but it still pushed the speakers really good, was loud clear and i really liked how they sounded. I had it running for about an hour and all the sudden the speakers just cut off and there was no power to the amp. And it was really hot and smelt burnt. I had an audio shop put it in locally so im assuming everything was set up right. Only thing i can maybe think of is i was messin with the prcoessor and had the input/output levels a little too high

    Any ideas? I bought a little alpine mrp f300 4 channel amp on crutchfield and just put that in and i dont like it nearly as much. Doesnt sound as clear or loud, i know its not nearly as good a amp but thought it might be ok.

    Any suggestions on what may have caused the amp to fry? And also what amp to run these speakers with?







  2. #2
    garychoffmann's Avatar
    garychoffmann is online now CarAudio.com Elite



    Join Date
    Mar 2011
    Location
    Missouri
    Posts
    909
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Why did my JL 300/2 burn out

    Personally I'd pick up a 300/4. Sounds like you were running it at 1 ohm per channel and it's rated 1.5 to 4. Which was probably fine if it was set correctly. If you started to mess with the controls you may have driven it into clipping which will cause extra current draw and have the amp heat up quickly. This is my assumption of course not knowing your power situation. But if it happened soon after messing with the controls it probably was clipping, low ohm load, not getting enough power or being able to ground that power efficiently. Many variables can lead to frying an amp




  3. #3
    Konsty25's Avatar
    Konsty25 is offline Junior Member

    Threadstarter


    Join Date
    Dec 2013
    Location
    las vegas
    Posts
    11
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Why did my JL 300/2 burn out

    Quote Originally Posted by garychoffmann View Post
    Personally I'd pick up a 300/4. Sounds like you were running it at 1 ohm per channel and it's rated 1.5 to 4. Which was probably fine if it was set correctly. If you started to mess with the controls you may have driven it into clipping which will cause extra current draw and have the amp heat up quickly. This is my assumption of course not knowing your power situation. But if it happened soon after messing with the controls it probably was clipping, low ohm load, not getting enough power or being able to ground that power efficiently. Many variables can lead to frying an amp
    Thanks for the reply, Could be because the guy who installed it said my speakers were 4 ohms and i told him no they were only 2 ohms. Lookin into a 300/4 now. What i dont like now with my 4 channel amp is the rears. They sound like an echo and im trying to tune them out. I just dont like it, with the 300/2 everything sounded great and i didnt even really mess with the tuning.




  4. #4
    garychoffmann's Avatar
    garychoffmann is online now CarAudio.com Elite



    Join Date
    Mar 2011
    Location
    Missouri
    Posts
    909
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Why did my JL 300/2 burn out

    Might have the rears set to high. Also is it the vocals and midrange being a little hollow or tingy sounding?




  5. #5
    MutantDreams's Avatar
    MutantDreams is offline Senior VIP Member



    Join Date
    Apr 2012
    Location
    Columbus, Georgia
    Posts
    260
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Why did my JL 300/2 burn out

    Try disconnecting the speakers and see if it will cut on.




  6. #6
    Konsty25's Avatar
    Konsty25 is offline Junior Member

    Threadstarter


    Join Date
    Dec 2013
    Location
    las vegas
    Posts
    11
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Why did my JL 300/2 burn out

    Thanks for all the responses

    The rears just sound like an echo im trying to tune them exactly the same as the fronts its just not working right...you can hear them and they sound different. Im considering going back to my Hertz comp set with just a two channel running them. But i really like how these infinitys sounded when i was running the 300/2 on em even more then the hertz comps.

    Might try the 300/4 first though if i can get my hands on one at the right price




  7. #7
    MutantDreams's Avatar
    MutantDreams is offline Senior VIP Member



    Join Date
    Apr 2012
    Location
    Columbus, Georgia
    Posts
    260
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Why did my JL 300/2 burn out

    Have you tried switching the rcas? Like the left with the right, one channel on the amp might be going out.




  8. #8
    Jroo's Avatar
    Jroo is offline Senior VIP Member



    Join Date
    Feb 2007
    Location
    richmond virginia
    Posts
    420
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Why did my JL 300/2 burn out

    If you had 4 speakers running off the 300/2, you were probably running 1 ohm assuming everything was wired correctly. I say this because you said the guy who installed it was not sure what ohm speakers you had, so no real telling how he wired everything. Do you know if the amp is in protect mode? JL amps have been know to go into protect mode which can be fixed vs. buying another amp




  9. #9
    Konsty25's Avatar
    Konsty25 is offline Junior Member

    Threadstarter


    Join Date
    Dec 2013
    Location
    las vegas
    Posts
    11
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Why did my JL 300/2 burn out

    Quote Originally Posted by Jroo View Post
    If you had 4 speakers running off the 300/2, you were probably running 1 ohm assuming everything was wired correctly. I say this because you said the guy who installed it was not sure what ohm speakers you had, so no real telling how he wired everything. Do you know if the amp is in protect mode? JL amps have been know to go into protect mode which can be fixed vs. buying another amp
    I dont know if it did or not how would i be able to find that out?




  10. #10
    Konsty25's Avatar
    Konsty25 is offline Junior Member

    Threadstarter


    Join Date
    Dec 2013
    Location
    las vegas
    Posts
    11
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Why did my JL 300/2 burn out

    one more question.

    Now when i talk on the phone with blue tooth the person says they hear a bad echo of themselves when they talk to me. It didnt use to do this with the other amp...any help on that?




  11. #11
    garychoffmann's Avatar
    garychoffmann is online now CarAudio.com Elite



    Join Date
    Mar 2011
    Location
    Missouri
    Posts
    909
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Why did my JL 300/2 burn out

    When amp was replaced they unhooked the battery. Lost all your old settings. Which head unit?




  12. #12
    Konsty25's Avatar
    Konsty25 is offline Junior Member

    Threadstarter


    Join Date
    Dec 2013
    Location
    las vegas
    Posts
    11
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Why did my JL 300/2 burn out

    Its the stock head unit....not sure how that would really effect it i havent touched the settings. Any idea?

    ---------- Post added at 05:09 PM ---------- Previous post was at 05:09 PM ----------

    stock head unit 2014 honda accord




+ Reply to Thread

Similar Threads

  1. why did my sub and amp go out on me after an accident
    By rookanga in forum General Discussion
    Replies: 9
    Last Post: 02-13-2012, 09:12 PM
  2. Why did my speakers blow out????
    By MercuryMilan in forum General Discussion
    Replies: 21
    Last Post: 05-18-2009, 05:28 PM
  3. Why did my sub blow (i dont want it to happen again)
    By loudfivepoint0 in forum Subwoofers
    Replies: 19
    Last Post: 01-17-2005, 01:04 AM
  4. Mods, why did my thread get bumped?
    By kjwiehoff in forum General Discussion
    Replies: 0
    Last Post: 10-27-2004, 10:21 PM
  5. Why do my JL's sound like crap in a wedge box????
    By MxRacerCam in forum Subwoofers
    Replies: 5
    Last Post: 02-25-2002, 09:41 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum