Closed Thread
Results 1 to 10 of 10

Reload Thread: I have no luck

  1. #1
    JoeK's Avatar
    JoeK is offline CarAudio.com Elite



    Join Date
    Apr 2012
    Location
    Ringtown, PA
    Age
    20
    Posts
    1,053
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    412 Post(s)

    I have no luck

    Playing at a moderate volume, voltage perfect... Next thing i noticed is that somebody has really bad brakes, until i look back and see a cloud of smoke coming back from the trunk...

    Long story short, one of my SK-1500.1s has a burned fet (still works, no protect mode, plays fine)...

    SHould i get it fixed?



    ** NEW VEHICLE AND BUILD ** 2003 Jeep Liberty Sport
    2x SPLAudio DAD BD 12s
    2x SK-1500.1s
    Box 5 cubes @ 29hz
    XS Power D3100 & D2400
    Tenney 270A
    4x PowerBass 3xl 6.5s
    Clarion CZ702




  2. #2
    skylineTT's Avatar
    skylineTT is offline bass=sekz



    Join Date
    Jun 2007
    Location
    Dallas/Raiderland
    Posts
    4,094
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    689 Post(s)

    Re: I have no luck

    I think you're going to get a lot of flame for the Skar equipment. If it still works fine, I would probably run it until it goes, then have it repaired. Idk if that will cause more harm than good though. @ampjunkielikeme ;



    Refs: Dipitydoo, appollyon, bad95gt, revrider1, jwh1598, ampjunkielikeme, deathpenalty18, ssackett, snoopysnooper, corey0928, SPLAudio, Clifff150, CL1CKCLACK, ShawnT, West + more

  3. #3
    JoeK's Avatar
    JoeK is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Apr 2012
    Location
    Ringtown, PA
    Age
    20
    Posts
    1,053
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    412 Post(s)

    Re: I have no luck

    Quote Originally Posted by skylineTT View Post
    I think you're going to get a lot of flame for the Skar equipment. If it still works fine, I would probably run it until it goes, then have it repaired. Idk if that will cause more harm than good though. @ampjunkielikeme ;
    Apollo Robb told me since the burnt fet is in the supply section it wont trip protect, but he recommends to fix it before more fets blow..



    ** NEW VEHICLE AND BUILD ** 2003 Jeep Liberty Sport
    2x SPLAudio DAD BD 12s
    2x SK-1500.1s
    Box 5 cubes @ 29hz
    XS Power D3100 & D2400
    Tenney 270A
    4x PowerBass 3xl 6.5s
    Clarion CZ702

  4. #4
    skylineTT's Avatar
    skylineTT is offline bass=sekz



    Join Date
    Jun 2007
    Location
    Dallas/Raiderland
    Posts
    4,094
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    689 Post(s)

    Re: I have no luck

    Yeah, I was gonna say that it might damage other components in the process of burning. Hopefully since it is a small problem, the repair price would be cheap. Shoot, if it is only a fet, you could probably do the work yourself.



    Refs: Dipitydoo, appollyon, bad95gt, revrider1, jwh1598, ampjunkielikeme, deathpenalty18, ssackett, snoopysnooper, corey0928, SPLAudio, Clifff150, CL1CKCLACK, ShawnT, West + more

  5. #5
    JoeK's Avatar
    JoeK is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Apr 2012
    Location
    Ringtown, PA
    Age
    20
    Posts
    1,053
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    412 Post(s)

    Re: I have no luck

    Quote Originally Posted by skylineTT View Post
    Yeah, I was gonna say that it might damage other components in the process of burning. Hopefully since it is a small problem, the repair price would be cheap. Shoot, if it is only a fet, you could probably do the work yourself.
    He said ~$50



    ** NEW VEHICLE AND BUILD ** 2003 Jeep Liberty Sport
    2x SPLAudio DAD BD 12s
    2x SK-1500.1s
    Box 5 cubes @ 29hz
    XS Power D3100 & D2400
    Tenney 270A
    4x PowerBass 3xl 6.5s
    Clarion CZ702

  6. #6
    skylineTT's Avatar
    skylineTT is offline bass=sekz



    Join Date
    Jun 2007
    Location
    Dallas/Raiderland
    Posts
    4,094
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    689 Post(s)

    Re: I have no luck

    Lol not too bad. better than the 200 I have to pay for my memphis MCD-2500



    Refs: Dipitydoo, appollyon, bad95gt, revrider1, jwh1598, ampjunkielikeme, deathpenalty18, ssackett, snoopysnooper, corey0928, SPLAudio, Clifff150, CL1CKCLACK, ShawnT, West + more

  7. #7
    audiobaun's Avatar
    audiobaun is offline Premium Member audiobaun is a Supporting Member of the forum!



    Join Date
    Jun 2011
    Location
    rockwall,Tx
    Posts
    6,580
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1408 Post(s)

    Re: I have no luck

    Quote Originally Posted by JoeK View Post
    He said ~$50
    Pretty cheap.though, Ive heard or read at one point, that its best to replace all of them,.Id ask about that@Spooney




  8. #8
    jasonbillnelson's Avatar
    jasonbillnelson is offline LEAD, FOLLOW, OR GTFO!!!



    Join Date
    Oct 2012
    Location
    La Plata, MD
    Age
    28
    Posts
    1,245
    Post Thanks / Like
    Images
    16
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    284 Post(s)

    Re: I have no luck

    @Spooney ;



    SSgt. Jason Nelson
    Andrews AFB, MD USAF

    Dealt with audiobahn, sangthing, 93 saturn sl2, basswiigee, goodstuff, HomeGrown, 06gtmike, 95BlackGA
    HU: Clarion NX501 Nav Deck
    Amps: C2 Audio Recon 1.6, Sundown SAX50.4
    Speakers: MB Quart ONX216 Components - 2 full sets
    Subwoofer: 2 C2 Audio Team 1k 12"s
    Wire/Battery: SHCA 1/0 OFC--Shuriken BT-80 / BT-35
    Alternator: Mechman 320 amp

  9. #9
    Spooney's Avatar
    Spooney is offline Premium Member Spooney is a Supporting Member of the forum!



    Join Date
    Dec 2007
    Location
    Charlotte,MI,USA
    Age
    33
    Posts
    4,103
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    706 Post(s)

    Re: I have no luck

    Quote Originally Posted by JoeK View Post
    Apollo Robb told me since the burnt fet is in the supply section it wont trip protect, but he recommends to fix it before more fets blow..
    If its a burnt PS fet you really should have the power supply serviced man. I would start by replacing all of the power supply fets as they are all in parallel and all saw the same stress that caused the one to fail. Could have been one fluke bad part but I would not chance it. The power supply will be most reliable when all the fets are matched as closely as possible. Just throwing one new fet in to replace the burnt one is just a bandaid and not a very good one at that. You also will need to verify that all the gate resistors are still within tolerance. Power supply drivers and pwm IC need to be checked as well. Gate drive signal will need to be inspected on an oscope also. If it still works you may be lucky and all your power supply drive circuitry is intact. Could be lucky enough to have it be as simple as swapping fets or it could be a bit more involved. I wouldn't use it until you can have it serviced.




  10. #10
    JoeK's Avatar
    JoeK is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Apr 2012
    Location
    Ringtown, PA
    Age
    20
    Posts
    1,053
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    412 Post(s)

    Re: I have no luck

    Quote Originally Posted by Spooney View Post
    If its a burnt PS fet you really should have the power supply serviced man. I would start by replacing all of the power supply fets as they are all in parallel and all saw the same stress that caused the one to fail. Could have been one fluke bad part but I would not chance it. The power supply will be most reliable when all the fets are matched as closely as possible. Just throwing one new fet in to replace the burnt one is just a bandaid and not a very good one at that. You also will need to verify that all the gate resistors are still within tolerance. Power supply drivers and pwm IC need to be checked as well. Gate drive signal will need to be inspected on an oscope also. If it still works you may be lucky and all your power supply drive circuitry is intact. Could be lucky enough to have it be as simple as swapping fets or it could be a bit more involved. I wouldn't use it until you can have it serviced.
    Well its being sent to Apollo Sound Products and hes known to do good work, well see what he does.



    ** NEW VEHICLE AND BUILD ** 2003 Jeep Liberty Sport
    2x SPLAudio DAD BD 12s
    2x SK-1500.1s
    Box 5 cubes @ 29hz
    XS Power D3100 & D2400
    Tenney 270A
    4x PowerBass 3xl 6.5s
    Clarion CZ702

Closed Thread

Similar Threads

  1. having absolutely no luck with pca's anymore..
    By billabongcr in forum Amplifiers
    Replies: 10
    Last Post: 02-08-2007, 12:14 PM
  2. having absolutely no luck with pca's anymore..
    By billabongcr in forum Amplifiers
    Replies: 0
    Last Post: 02-07-2007, 11:43 PM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum