Closed Thread
Results 1 to 2 of 2

Reload Thread: soundstream rubicon 1600d

  1. #1
    nategearing42's Avatar
    nategearing42 is offline Junior Member



    Join Date
    Apr 2013
    Location
    vienna illinois
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)

    soundstream rubicon 1600d

    Okay I have a sound stream Rubicon 1600d amp powering an audioque hdc3 15. whenever i turn on my truck the protection light comes on the amplifier and then after about three seconds it goes off and the amp works perfectly normal. Anybody know why its doing that? And also can that be harmful for the amp? I just hooked up the amp yesterday also and its been doing it since i hooked it up.







  2. #2
    ECA's Avatar
    ECA
    ECA is offline Junior Member



    Join Date
    Apr 2012
    Location
    EU
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: soundstream rubicon 1600d

    It's "soft start", nothing wrong.




Closed Thread

Similar Threads

  1. Arc Audio amps vs soundstream rubicon amps
    By musicman in forum Amplifiers
    Replies: 12
    Last Post: 01-09-2003, 12:13 AM
  2. Replies: 1
    Last Post: 01-03-2003, 06:23 PM
  3. Replies: 1
    Last Post: 01-03-2003, 10:00 AM
  4. Soundstream Rubicon R-10SQ/R-12SQ
    By Clarion_Guy in forum Subwoofers
    Replies: 0
    Last Post: 12-19-2002, 12:31 AM
  5. JBL 1200.1 or Soundstream Rubicon II 1002
    By quiimari in forum Amplifiers
    Replies: 3
    Last Post: 11-06-2002, 07:56 AM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum