Closed Thread
Results 1 to 4 of 4

Reload Thread: Alpine Mrp-M2000 Whine

  1. #1
    divebombvt's Avatar
    divebombvt is offline Junior Member



    Join Date
    Dec 2011
    Location
    Vermont
    Posts
    18
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Alpine Mrp-M2000 Whine

    I hooked up the alpine amp mentioned in the title and it turns on blue just fine. But I get no music, so I fiddled with all the controls on the amp just to see if I could get something, going from gain all the way down to just slightly on I get a sort of grumbling noise through the subs(not that uncommon for an amp to do anyway but I figured I would mention it). When I unplug one of the RCA's and leave the other connected it has a higher pitched whine that goes through the subs. This is the only types of noise I can get out of the amp. It isn't a matter of a connection issue outside the amp, as I have direct swapped to another amp that works twice to make sure nothing is wrong. All of the 30 amp fuses look fine, I opened up the amp and nothing looks burnt or anything like that. Nothing looks out of place or bent over, it actually is one of the better put together amps I've seen but I cant seem to figure out what is wrong with it. Any ideas no matter how far fetched is much appreciated.







  2. #2
    divebombvt's Avatar
    divebombvt is offline Junior Member

    Threadstarter


    Join Date
    Dec 2011
    Location
    Vermont
    Posts
    18
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Alpine Mrp-M2000 Whine

    More info, I just tried it in a friends truck and it worked fine. We had to have the gain all the way up to get a decent response, his bass boost was all the way up on his headunit too, but his subs handled it fine and didn't even get warm, which made me even more confused... And here is just one more wrench in the system, he was wired to 1.3 ohms, I know after box rise he would probably be above 2 ohms but the amp stayed cold the whole time... any ideas? I would really rather not send it to alpine and pay 70 bucks +shipping to get something fixed that probably has to do with something simple.




  3. #3
    pickup1's Avatar
    pickup1 is offline Audiosystem,Dynaudio...



    Join Date
    Aug 2005
    Location
    Roanoke,TX
    Age
    50
    Posts
    7,898
    Post Thanks / Like
    Images
    19
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    691 Post(s)

    Re: Alpine Mrp-M2000 Whine

    Check your ground again..or bad rca.




  4. #4
    divebombvt's Avatar
    divebombvt is offline Junior Member

    Threadstarter


    Join Date
    Dec 2011
    Location
    Vermont
    Posts
    18
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Alpine Mrp-M2000 Whine

    I found the problem, when I cracked open the amp the 4 conductor wire jumper from the "inputs" board to the "power" board has a short in it. Both ends are connected by splice connectors(not the most effective imo) but as a suggestion to anyone having a similar problem, open up the amp and adjust the jumper wire and hope it holds lol... It has shorted out of me once since(but wiggling the same set of wires fixed it again) so I may just get around to direct soldering the connections.

    And for anyone else looking at this, I am very impressed with the amp, definitely does rated and then a little more. Very efficient amp, voltage drop is like .2 on a 90amp alt and a d3400 bat. Not sure on box rise or clamped numbers but gains are set to about 1800 at 2.4ohms with a multimeter.




Closed Thread

Similar Threads

  1. Replies: 6
    Last Post: 11-24-2009, 01:19 PM
  2. Alpine MRP-M2000??
    By oldzy in forum Amplifiers
    Replies: 12
    Last Post: 09-03-2009, 07:59 PM
  3. Alpine MRP-M2000 in ebay for $599.95 shipped
    By Engine_hp in forum Amplifiers
    Replies: 7
    Last Post: 08-07-2009, 04:52 PM
  4. Replies: 4
    Last Post: 07-30-2009, 09:35 PM
  5. any info on the alpine MRP M2000 ?
    By GavinVoy in forum Amplifiers
    Replies: 0
    Last Post: 01-26-2009, 07:49 PM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum