Closed Thread
Results 1 to 13 of 13

Reload Thread: Medic for my 1000/1v2

  1. #1
    momax_powers's Avatar
    momax_powers is offline Senior VIP Member



    Join Date
    Jul 2012
    Location
    Canada
    Posts
    434
    Post Thanks / Like
    Mentioned
    2 Post(s)

    Medic for my 1000/1v2

    i tried hookin up my B2 AS12 mkii D2 to the 1000/1v2 @ 4 ohms but when i start the car both the green power led and the yellow low ohm led stay on. Theres no output (also no buzzing or hum like some people get in the same situation). Ohm light stays on even when sub is not connected. Voltage is fine, both ground and power are fine, gain is set conservatively, coils in series read 4.2. Only conclusion is maybe an internal short so i opened it up and took some pics. All the fets look fine, resistors look fine, no burning smell, although everything i know about amp circuit boards can fit in a thimble so maybe someone call take a look and point out anything that may be of concern...












  2. #2
    momax_powers's Avatar
    momax_powers is offline Senior VIP Member

    Threadstarter


    Join Date
    Jul 2012
    Location
    Canada
    Posts
    434
    Post Thanks / Like
    Mentioned
    2 Post(s)

    Re: Medic for my 1000/1v2

    cough




  3. #3
    ciaonzo's Avatar
    ciaonzo is offline TheContinental



    Join Date
    Feb 2009
    Location
    WI
    Age
    39
    Posts
    9,182
    Post Thanks / Like
    Mentioned
    32 Post(s)

    Re: Medic for my 1000/1v2

    Have you consulted the manual or looked online to see what the condition is for the LED status code?



    Quote Originally Posted by audioholic View Post
    Saying "clipping doesn't kill speakers" is a half-truth at best. Technically no, clipping itself does not hurt the speaker. But in clipping your amp, you can easily create a situation that WILL kill the speaker. Was the squared waveform the DIRECT cause of the failure? No. In the end, the answer is, always has been, and can only be... heat kills speakers. BUT, clipping increases heat generation, sometimes by a drastic amount. So to start a thread simply to state that clipping does not hurt speakers is, again, a half-truth at best.

  4. #4
    momax_powers's Avatar
    momax_powers is offline Senior VIP Member

    Threadstarter


    Join Date
    Jul 2012
    Location
    Canada
    Posts
    434
    Post Thanks / Like
    Mentioned
    2 Post(s)

    Re: Medic for my 1000/1v2

    Quote Originally Posted by ciaonzo View Post
    Have you consulted the manual or looked online to see what the condition is for the LED status code?
    Yes it says either imp is too low or there is a short in the speaker wires ... Checked and not the case.... Ive used jl amps for yrs and personally have many of them but never came across this problem before




  5. #5
    richericks's Avatar
    richericks is offline Member



    Join Date
    Jun 2012
    Location
    Oregon
    Posts
    62
    Post Thanks / Like
    Mentioned
    2 Post(s)

    Re: Medic for my 1000/1v2

    I had the same issue with my 300/2. Turned out it was a bad FET or two. Haven't had it repaired yet, but JL has will fix the Slash amps for a flat $125 if it is out of warranty.



    '12 RAV4 Limited, HAT Clarus 6.5"in door, tweeters in A-Pillar, Pioneer AVH-P8400BH, ARC PS8, ARC KS300.4, JL 500/1, ARC Black 12, KnuKonceptz power and Streetwires interconnects

  6. #6
    momax_powers's Avatar
    momax_powers is offline Senior VIP Member

    Threadstarter


    Join Date
    Jul 2012
    Location
    Canada
    Posts
    434
    Post Thanks / Like
    Mentioned
    2 Post(s)

    Re: Medic for my 1000/1v2

    Cost a bit more for us canadians




  7. #7
    raptor727's Avatar
    raptor727 is offline come get some!!



    Join Date
    Apr 2012
    Location
    pensacola FL
    Posts
    1,374
    Post Thanks / Like
    Images
    2
    Mentioned
    13 Post(s)

    Re: Medic for my 1000/1v2

    Cost was 225 after shipping for me on my v1 not too bad for a great amp imo




  8. #8
    momax_powers's Avatar
    momax_powers is offline Senior VIP Member

    Threadstarter


    Join Date
    Jul 2012
    Location
    Canada
    Posts
    434
    Post Thanks / Like
    Mentioned
    2 Post(s)

    Re: Medic for my 1000/1v2

    Quote Originally Posted by raptor727 View Post
    Cost was 225 after shipping for me on my v1 not too bad for a great amp imo
    Yea gemsen (the canadian jl distributer) said they can replace it with a refurb for 215$ but i only payed 250 for it initially coupled with the fact that i already have another 1000/1v2, hd1200/1 and an mb quart onx1600 it doesnt make sense for me to spend money on it

    Edit: unless its a small problem i can get fixed for 100$




  9. #9
    raptor727's Avatar
    raptor727 is offline come get some!!



    Join Date
    Apr 2012
    Location
    pensacola FL
    Posts
    1,374
    Post Thanks / Like
    Images
    2
    Mentioned
    13 Post(s)

    Re: Medic for my 1000/1v2

    Sell it to me then lol




  10. #10
    momax_powers's Avatar
    momax_powers is offline Senior VIP Member

    Threadstarter


    Join Date
    Jul 2012
    Location
    Canada
    Posts
    434
    Post Thanks / Like
    Mentioned
    2 Post(s)

    Re: Medic for my 1000/1v2

    Quote Originally Posted by raptor727 View Post
    Sell it to me then lol
    Haha whats ur offer




  11. #11
    raptor727's Avatar
    raptor727 is offline come get some!!



    Join Date
    Apr 2012
    Location
    pensacola FL
    Posts
    1,374
    Post Thanks / Like
    Images
    2
    Mentioned
    13 Post(s)

    Re: Medic for my 1000/1v2

    Man all i got is trades im broke




  12. #12
    momax_powers's Avatar
    momax_powers is offline Senior VIP Member

    Threadstarter


    Join Date
    Jul 2012
    Location
    Canada
    Posts
    434
    Post Thanks / Like
    Mentioned
    2 Post(s)

    Re: Medic for my 1000/1v2

    Quote Originally Posted by raptor727 View Post
    Man all i got is trades im broke
    pm what u have




  13. #13
    kds9591's Avatar
    kds9591 is offline Junior Member



    Join Date
    Feb 2013
    Location
    Bensalem, PA
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Medic for my 1000/1v2

    If you decide to get your JL Audio 1000/1 or 1000/1v2 car amp repaired see Ebay Auction #160951135557 .




Closed Thread

Similar Threads

  1. $1000 budget help me with a setup please?(most bang for my buck!)
    By daveofstrength in forum General Discussion
    Replies: 5
    Last Post: 10-28-2007, 07:11 PM
  2. Would 1000 watts be overkill for my 12" l7
    By sjedwards84 in forum General Discussion
    Replies: 7
    Last Post: 10-10-2007, 08:15 PM
  3. Amp for my new sx 18, need 1000+ rms
    By ownage9 in forum Wanting to Buy (WTB) - Car Audio
    Replies: 21
    Last Post: 06-02-2006, 11:51 AM
  4. Replies: 15
    Last Post: 01-29-2006, 06:21 PM
  5. Spend $1000 on bolt-ons for my CRX!
    By 620hpcrx in forum Car Interior/Exterior Enhancements
    Replies: 24
    Last Post: 08-08-2004, 12:42 AM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum