Closed Thread
Page 2 of 2 FirstFirst 1 2
Results 16 to 26 of 26

Reload Thread: SAZ1200d Not enough power?

  1. #16
    momax_powers's Avatar
    momax_powers is offline Senior VIP Member



    Join Date
    Jul 2012
    Location
    Canada
    Posts
    447
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    175 Post(s)

    Re: SAZ1200d Not enough power?

    amp is fine.....just upgrade box and electrical







  2. #17
    NASTY08IMPALA's Avatar
    NASTY08IMPALA is offline CarAudio.com Veteran



    Join Date
    Aug 2012
    Location
    LOUISVILLE, KENTUCKY
    Posts
    5,561
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2302 Post(s)

    Re: SAZ1200d Not enough power?

    Quote Originally Posted by RicksI30 View Post
    What is your definition of enough? They can take more than rated but that does not mean that they need more power. In a perfect world you would need to double power to hear a difference and that will get costly between getting bigger/more amps and the electrical to back them up.
    thats exactly what im talking about double the power ..i ran mine on over 1k a piece for over 2 years no problem ..thats where they shine ..on rms thy are middle of.the pack




  3. #18
    RicksI30's Avatar
    RicksI30 is offline CarAudio.com Elite



    Join Date
    May 2011
    Location
    Tucson, Az
    Age
    26
    Posts
    588
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    189 Post(s)

    Re: SAZ1200d Not enough power?

    Quote Originally Posted by NASTY08IMPALA View Post
    thats exactly what im talking about double the power ..i ran mine on over 1k a piece for over 2 years no problem ..thats where they shine ..on rms thy are middle of.the pack
    The audible difference between 1200 rms and 2000 rms (what you were sending them) would be minimal. His time and money should first be spent getting a new enclosure.



    Head unit: Kenwood Excelon KDC-X996
    Front stage: Alpine Type X PRO mids Vifa Neo 1" silk tweeters
    Front stage amp: PPI Bk800.4
    Subs: SSA XCON 12's in 4.5 cubes tuned to 34hz
    Sub amp: PPI Bk1300.1
    Sound Deadening: Second Skin Damplifier Pro, Spectrum, and Sludge


    Team SSA

  4. Likes htownrsx liked this post
  5. #19
    NASTY08IMPALA's Avatar
    NASTY08IMPALA is offline CarAudio.com Veteran



    Join Date
    Aug 2012
    Location
    LOUISVILLE, KENTUCKY
    Posts
    5,561
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2302 Post(s)

    Re: SAZ1200d Not enough power?

    yes i agree he needs a new box first and that might be enough for him ..might not ..and when i switched from 1 saz1000 to 2 it was quite a bit audibly louder ..went from 139 to 145




  6. #20
    RicksI30's Avatar
    RicksI30 is offline CarAudio.com Elite



    Join Date
    May 2011
    Location
    Tucson, Az
    Age
    26
    Posts
    588
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    189 Post(s)

    Re: SAZ1200d Not enough power?

    Quote Originally Posted by NASTY08IMPALA View Post
    yes i agree he needs a new box first and that might be enough for him ..might not ..and when i switched from 1 saz1000 to 2 it was quite a bit audibly louder ..went from 139 to 145
    That is an insane difference for only a double in power. You didn't change anything else? Were the two amps wired lower than the one?



    Head unit: Kenwood Excelon KDC-X996
    Front stage: Alpine Type X PRO mids Vifa Neo 1" silk tweeters
    Front stage amp: PPI Bk800.4
    Subs: SSA XCON 12's in 4.5 cubes tuned to 34hz
    Sub amp: PPI Bk1300.1
    Sound Deadening: Second Skin Damplifier Pro, Spectrum, and Sludge


    Team SSA

  7. #21
    NASTY08IMPALA's Avatar
    NASTY08IMPALA is offline CarAudio.com Veteran



    Join Date
    Aug 2012
    Location
    LOUISVILLE, KENTUCKY
    Posts
    5,561
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2302 Post(s)

    Re: SAZ1200d Not enough power?

    Quote Originally Posted by RicksI30 View Post
    That is an insane difference for only a double in power. You didn't change anything else? Were the two amps wired lower than the one?
    yea i kno shocked me too but the meter doesnt lie ..same everything amps were strapped @2ohms ..same box ..we did test a whole lot more with doors open closed box position and things so that might account for a few db.s




  8. #22
    NASTY08IMPALA's Avatar
    NASTY08IMPALA is offline CarAudio.com Veteran



    Join Date
    Aug 2012
    Location
    LOUISVILLE, KENTUCKY
    Posts
    5,561
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2302 Post(s)

    Re: SAZ1200d Not enough power?

    not sayin he has to double the power jus letting him know if hes still not happy with the out put after new box he has options..a nice custom enclosure will help tremendously




  9. #23
    RicksI30's Avatar
    RicksI30 is offline CarAudio.com Elite



    Join Date
    May 2011
    Location
    Tucson, Az
    Age
    26
    Posts
    588
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    189 Post(s)

    Re: SAZ1200d Not enough power?

    Quote Originally Posted by NASTY08IMPALA View Post
    not sayin he has to double the power jus letting him know if hes still not happy with the out put after new box he has options..a nice custom enclosure will help tremendously
    Well then I guess after better explaining your statement I can agree with you. I still would not say "that amp isnt enough power for 2 sa12.s to begin with.." though. I'm sure that our little conversation will help the OP decide what to do.



    Head unit: Kenwood Excelon KDC-X996
    Front stage: Alpine Type X PRO mids Vifa Neo 1" silk tweeters
    Front stage amp: PPI Bk800.4
    Subs: SSA XCON 12's in 4.5 cubes tuned to 34hz
    Sub amp: PPI Bk1300.1
    Sound Deadening: Second Skin Damplifier Pro, Spectrum, and Sludge


    Team SSA

  10. #24
    NASTY08IMPALA's Avatar
    NASTY08IMPALA is offline CarAudio.com Veteran



    Join Date
    Aug 2012
    Location
    LOUISVILLE, KENTUCKY
    Posts
    5,561
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2302 Post(s)

    Re: SAZ1200d Not enough power?

    Quote Originally Posted by RicksI30 View Post
    Well then I guess after better explaining your statement I can agree with you. I still would not say "that amp isnt enough power for 2 sa12.s to begin with.." though. I'm sure that our little conversation will help the OP decide what to do.
    sure enough..all depends on what he wants




  11. #25
    Fishpoke's Avatar
    Fishpoke is offline Junior Member

    Threadstarter


    Join Date
    Feb 2013
    Location
    Fayetteville NC
    Posts
    28
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    7 Post(s)

    Re: SAZ1200d Not enough power?

    Definitely taking care of electrical first, I need to take some time on my next day off and play with the dmm find out how much power the amp is putting out when it clips. I imagine the amp not being able to get enough power would clip for the same reason overdriving an amp would. I want to find someone somewhat local for a box so I'm not paying out the *** for shipping.




  12. #26
    Fishpoke's Avatar
    Fishpoke is offline Junior Member

    Threadstarter


    Join Date
    Feb 2013
    Location
    Fayetteville NC
    Posts
    28
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    7 Post(s)

    Re: SAZ1200d Not enough power?

    Ok so I've gotten my big three done, optima red top battery. Still running that prefab box for now, they did 141.5 @ 50hz think the box is holding it back a lot. I'm still getting a clip light from the amp though, I don't hear any clipping from the subs but the light is going crazy when I have it turned all the way up. Gain is adjusted for my 2v preouts. Also an oddity I ran into when I measure the ohms at the amp I get the correct reading of 1 ohm with the amp off. With the amp on however the reading goes crazy bouncing around from 12 to 50 very sporadically. A friend is waiting for some of his friends at sundown to get back from comps to ask them what they think, just wondering if anyone here had any ideas?
    Last edited by Fishpoke; 03-04-2013 at 03:08 AM.




Closed Thread
Page 2 of 2 FirstFirst 1 2

Similar Threads

  1. not enough power to amp
    By HYmanDR0ne in forum Wiring, Electrical and Installation Help
    Replies: 6
    Last Post: 02-25-2004, 09:48 AM
  2. not enough power to a sub?
    By greenchaos in forum Subwoofers
    Replies: 3
    Last Post: 01-23-2003, 09:29 PM
  3. XTRPRO subwoofer problem, not enough power?
    By cygnus in forum Wiring, Electrical and Installation Help
    Replies: 1
    Last Post: 05-10-2002, 03:17 AM
  4. Is there such thing as not enough power?
    By puppie_chow in forum Wiring, Electrical and Installation Help
    Replies: 9
    Last Post: 04-17-2002, 07:59 AM
  5. not enough power?
    By freddrick in forum Subwoofers
    Replies: 0
    Last Post: 02-19-2002, 11:37 PM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum