Closed Thread
Results 1 to 11 of 11

Reload Thread: pyle academy 2300 watt amp

  1. #1
    demeaningfive70's Avatar
    demeaningfive70 is offline Junior Member



    Join Date
    Feb 2013
    Location
    waterford, OH
    Posts
    4
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2 Post(s)

    pyle academy 2300 watt amp

    ok so going down the road my old amp stops working so i buy a new one, a pyle 2300 watt, and i hook it up but it wont come out of protected mode. so i took it to a professional and had him look at it and it works and he said it was my ground so i move the ground to the chassis and its still doing the same thing lights up green for a second then moves back into protected mode so i messed around with it for a bit and everything i did just caused it to do the same thing light up green for a second then back into protected mode, i even went out and bought a new wiring kit and an power cap. and ran it all over again, does any know what i can do to get my amp to work?







  2. #2
    Sub Bass Woofrz's Avatar
    Sub Bass Woofrz is offline Senior VIP Member



    Join Date
    Aug 2012
    Location
    Camas, WA
    Posts
    336
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    140 Post(s)

    Re: pyle academy 2300 watt amp

    did you sand the paint off your ground connection?




  3. #3
    av83's Avatar
    av83 is offline CarAudio.com Veteran



    Join Date
    Mar 2012
    Location
    Illinois
    Posts
    2,871
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1254 Post(s)

    Re: pyle academy 2300 watt amp

    Quote Originally Posted by demeaningfive70 View Post
    ok so going down the road my old amp stops working so i buy a new one, a pyle 2300 watt, and i hook it up but it wont come out of protected mode. so i took it to a professional and had him look at it and it works and he said it was my ground so i move the ground to the chassis and its still doing the same thing lights up green for a second then moves back into protected mode so i messed around with it for a bit and everything i did just caused it to do the same thing light up green for a second then back into protected mode, i even went out and bought a new wiring kit and an power cap. and ran it all over again, does any know what i can do to get my amp to work?
    like subbasswoofers said, check to make sure the connection is bare metal to metal. also, what to you have hooked up to it? That amp is only a 300x1 bridged at 4 ohms.



    Pioneer 80prs
    ...
    Rockford Fosgate t800.4, CDT ES-MO 6 mids, Digital Designs T2 tweets
    ...
    2 MB Quart DSC1500.1's strapped on 1 Tantric HDD 12
    Mike Singer 310 amp 6 phase
    ...
    2 runs of Monster Cable 1/0

  4. #4
    BrownVanMan's Avatar
    BrownVanMan is offline CarAudio.com Elite



    Join Date
    May 2009
    Location
    Minneapolis MN
    Posts
    1,997
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    328 Post(s)

    Re: pyle academy 2300 watt amp

    My guess is the amp is fried and who ever checked it out just looked at the board and didn't test anything




  5. #5
    demeaningfive70's Avatar
    demeaningfive70 is offline Junior Member

    Threadstarter


    Join Date
    Feb 2013
    Location
    waterford, OH
    Posts
    4
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2 Post(s)

    Re: pyle academy 2300 watt amp

    yes the connection is metal to metal, and i dont have the amp bridge, i took it to an audiopipe dealer, and he checked it hooked up the positive,remote, and negative and it stayed green, so thats when he told me he thinks it my ground so i moved it to the chassis and i did grind a 2 inch by 2 inch space just so i have enough space in one spot but it doesnt want to stay green for me... and i have two 10 inch rocksford folsgate P2 punch series 1200 watt subs. the guy i took the amp too asked me that same question and i told him, he said that this amp would push 1200 watts at 2 omhs , he also said i could do something else and i would actually get closer to the 2300 watts but i dont need that much just the 1200




  6. #6
    av83's Avatar
    av83 is offline CarAudio.com Veteran



    Join Date
    Mar 2012
    Location
    Illinois
    Posts
    2,871
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1254 Post(s)

    Re: pyle academy 2300 watt amp

    Quote Originally Posted by demeaningfive70 View Post
    yes the connection is metal to metal, and i dont have the amp bridge, i took it to an audiopipe dealer, and he checked it hooked up the positive,remote, and negative and it stayed green, so thats when he told me he thinks it my ground so i moved it to the chassis and i did grind a 2 inch by 2 inch space just so i have enough space in one spot but it doesnt want to stay green for me... and i have two 10 inch rocksford folsgate P2 punch series 1200 watt subs. the guy i took the amp too asked me that same question and i told him, he said that this amp would push 1200 watts at 2 omhs , he also said i could do something else and i would actually get closer to the 2300 watts but i dont need that much just the 1200
    that amp is nowhere near a 1200 watt amp. it's 75x2 @ 4 ohms, 150x2 @ 2ohms, 300x1 bridged @ 4 ohms. Whoever you took that amp to, lied about its abilities. Also, if you have it bridged to those subs, and they are all wired in parallel( all positives and all negatives together) than that may explain why it's going into protect. I think it's probably something else. Honestly, though, that amp is garbage. Might power a couple of door speakers, but it's not fit for sub duty.

    edit... just saw its not bridged. sorry. but anyways, are the rf's d4 or d2?



    Pioneer 80prs
    ...
    Rockford Fosgate t800.4, CDT ES-MO 6 mids, Digital Designs T2 tweets
    ...
    2 MB Quart DSC1500.1's strapped on 1 Tantric HDD 12
    Mike Singer 310 amp 6 phase
    ...
    2 runs of Monster Cable 1/0

  7. #7
    Fi-brations's Avatar
    Fi-brations is offline CarAudio.com Elite



    Join Date
    Sep 2011
    Location
    Memphis, TN
    Posts
    958
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    240 Post(s)

    Re: pyle academy 2300 watt amp

    did u wire it correctly? use a dmm to check your power and ground connections





    04' Maxima Build
    Coming Soon

    Xtant 4180c, 2100b For Sale
    Alpine MRV-1507 For Sale
    Business with: davidtemple(x2), infamous_e46, Bettrn'Reverse, splaudio, TaylorFade, Tallc, Louisiana_Crx, RidnClean, b.mena, Mike Burke, Gameovercca, Ram_Designs, Double 07

  8. #8
    demeaningfive70's Avatar
    demeaningfive70 is offline Junior Member

    Threadstarter


    Join Date
    Feb 2013
    Location
    waterford, OH
    Posts
    4
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2 Post(s)

    Re: pyle academy 2300 watt amp

    ok so ill go get a bigger amp not a big deal for me, but even at that i dont have the amp hooked up to my speakers yet, ive only had the ground, remote,and positive wires hooked up so im confused on why the amp wont go out of protected mode when i know it will cuz i watched the guy do the same thing im doing now in my car that he did in the shop negative, remote, and positive the only difference is he didnt have a remote wire from the back of a radio he used a different wire just to see if it worked so im lost, idk what it would be




  9. #9
    demeaningfive70's Avatar
    demeaningfive70 is offline Junior Member

    Threadstarter


    Join Date
    Feb 2013
    Location
    waterford, OH
    Posts
    4
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2 Post(s)

    Re: pyle academy 2300 watt amp

    yes i have it wired correctly ive done sound systems in cars for 5 to 6 years now lol and grounding to the chassis of the car is the best place to ground and amp, and i have 12.5 out of the battery




  10. #10
    Dirtrider4eva's Avatar
    Dirtrider4eva is offline √\_The CaUsE__



    Join Date
    Mar 2011
    Location
    Milwaukee, WI
    Posts
    4,289
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    840 Post(s)

    Re: pyle academy 2300 watt amp

    I'm calling your wired too low



    welcome to
    Where b-stock is the new a-stock
    TEAM WEST

  11. #11
    pro-rabbit's Avatar
    pro-rabbit is offline Moderator pro-rabbit is a Supporting Member of the forum!

    pro-rabbit is a Supporting Vendor of the forum!

    Join Date
    Jan 2004
    Location
    OKC, OK
    Age
    32
    Posts
    12,395
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2522 Post(s)

    Re: pyle academy 2300 watt amp

    If the amp is going into protect with out any subs hooked up, but worked at the shop then it is your wiring.

    Check your power wire connections and any fusing you have in your wire.

    If you have a DMM this will be far easier.




Closed Thread

Similar Threads

  1. Is A Pyramid 1800 Watt Amp Good
    By Unregistered in forum Amplifiers
    Replies: 4
    Last Post: 01-22-2002, 01:14 PM
  2. Legacy 1600 watt amp LA1490 2 channel
    By Unregistered in forum Amplifiers
    Replies: 1
    Last Post: 01-19-2002, 03:30 PM
  3. Boss Audio 800 Watt Amp
    By SehnKhan in forum Wiring, Electrical and Installation Help
    Replies: 1
    Last Post: 01-16-2002, 09:40 PM
  4. 800 watt amp for sale
    By <SuckMikeHawk> in forum General Discussion
    Replies: 1
    Last Post: 01-08-2002, 12:29 AM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum