Closed Thread
Results 1 to 6 of 6

Reload Thread: Bridging Amp to run sub or Monoblock?

  1. #1
    fearturtle03's Avatar
    fearturtle03 is offline Senior VIP Member



    Join Date
    Mar 2005
    Location
    college park
    Posts
    184
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Bridging Amp to run sub or Monoblock?

    So I have a Zapco i4100.4 laying around that I tried to sell with no luck so I was looking at re-using it in my new truck. I am looking at 2 shallow mount subs and they take right around 250-350wRMS.

    Just so happens this Zapco bridged will push 300wRMSx2 which seems to fit well for the subs. My question is, is it better/cleaner to get a straight 2 channel or mono blocks to drive subs or is there no real difference in bridging a 4 channel to push the same subs?



    Sold/Bought/Traded from : mendezm9, snakeye, Zeuslicious, jdawg90, temposs,




  2. #2
    sjv13's Avatar
    sjv13 is offline StayStrange



    Join Date
    Apr 2011
    Location
    Lansing, MI
    Posts
    685
    Post Thanks / Like
    Mentioned
    2 Post(s)

    Re: Bridging Amp to run sub or Monoblock?

    I think it's alright. Just not very common for a few reasons:
    1) the desired ohm load isn't always available
    2) 2 channel and 4 channel amps bridged don't usually put out the type of power people always want
    3) more expensive for the options and power they put out




  3. #3
    fearturtle03's Avatar
    fearturtle03 is offline Senior VIP Member

    Threadstarter


    Join Date
    Mar 2005
    Location
    college park
    Posts
    184
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Bridging Amp to run sub or Monoblock?

    Thanks man. Yeah they all make sense. I had bought the Zapco for a 4 channel speaker but never got around to installing in my old car so now it is left over. Plus the 2 shallow mounts only have RMS around 300w anyways so it sounds liek this should work fine.



    Sold/Bought/Traded from : mendezm9, snakeye, Zeuslicious, jdawg90, temposs,

  4. #4
    sjv13's Avatar
    sjv13 is offline StayStrange



    Join Date
    Apr 2011
    Location
    Lansing, MI
    Posts
    685
    Post Thanks / Like
    Mentioned
    2 Post(s)

    Re: Bridging Amp to run sub or Monoblock?

    Quote Originally Posted by fearturtle03 View Post
    Thanks man. Yeah they all make sense. I had bought the Zapco for a 4 channel speaker but never got around to installing in my old car so now it is left over. Plus the 2 shallow mounts only have RMS around 300w anyways so it sounds liek this should work fine.
    Will it be at the right ohms though? Just make sure to check the amps specs and wire the subs accordingly




  5. #5
    Fi-brations's Avatar
    Fi-brations is offline CarAudio.com Elite



    Join Date
    Sep 2011
    Location
    Memphis, TN
    Posts
    917
    Post Thanks / Like
    Images
    3
    Mentioned
    13 Post(s)

    Re: Bridging Amp to run sub or Monoblock?

    I'm currently using my class a/b 2 channel bridged to my sub, 900w at 4 ohms




    Head Unit: Eclipse CD7000
    Front Stage: HAT Legatia L6V1, Clarus C1
    Front Stage Amplifiers: Xtant 4180c, 2100b
    Sub Stage: IA Flatlyne 18" For Sale
    Subwoofer Amplifier: Alpine MRV-1507 For Sale
    StarMountainSound Box
    Business with: davidtemple(x2), infamous_e46, Bettrn'Reverse, splaudio, TaylorFade, Tallc, Louisiana_Crx, RidnClean, b.mena, Mike Burke, Gameovercca, Ram_Designs, Double 07

  6. #6
    fearturtle03's Avatar
    fearturtle03 is offline Senior VIP Member

    Threadstarter


    Join Date
    Mar 2005
    Location
    college park
    Posts
    184
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Bridging Amp to run sub or Monoblock?

    Yeah good point. The amp bridges to 2 channel @4ohms and the subs will be 4 ohm as well.

    Thanks for the input



    Sold/Bought/Traded from : mendezm9, snakeye, Zeuslicious, jdawg90, temposs,

Closed Thread

Similar Threads

  1. Bridging amp to two subs
    By fartcan in forum Amplifiers
    Replies: 3
    Last Post: 04-10-2008, 10:20 AM
  2. Monoblock Amps to run 2 Subs
    By mystikarkitect in forum Amplifiers
    Replies: 2
    Last Post: 04-22-2007, 07:14 PM
  3. what amp to run subs
    By LGA in forum General Discussion
    Replies: 0
    Last Post: 09-17-2006, 07:44 PM
  4. WHat amp to run ????? One or more than one ????
    By watchzoo in forum General Discussion
    Replies: 2
    Last Post: 11-05-2003, 03:07 PM
  5. need amp to run sub... HELP....
    By sjsfiji in forum Amplifiers
    Replies: 5
    Last Post: 10-19-2002, 04:13 AM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum