Closed Thread
Results 1 to 7 of 7

Reload Thread: Amp may have gotten wet, Troubleshooting help?

  1. #1
    fastfive09's Avatar
    fastfive09 is offline Senior VIP Member



    Join Date
    Jul 2008
    Location
    SLidell, LA
    Posts
    152
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Amp may have gotten wet, Troubleshooting help?

    I have a Cadence TXA-3004 four channel amp which powers my Alpine Type S components in the front two channels and a Type-E subwoofer bridged in the last two channels.
    One day while driving my car, The subwoofer and front speakers kind of cut out and the speakers started sounding very scratchy and weak..barely tolerable. When I went to examine the amplifier it had some condensation on it. It wasn't soaked per say but there was a good bit of water on the face of it.
    Since then, When I turn the car on, everything sounds great for about one second that it sounds like trash for the rest of the time. Same thing happens whether the car is on or in accessory problem. There is nothing wrong with my wiring or ground, as everything was working perfectly before I noticed water.
    How can I tell if there is water damage? I can dismantle it and put a picture up here. I just have no experience with trouble shooting of this kind. Thanks in advance!

    a picture of it.







  2. #2
    ThatChevyGuy's Avatar
    ThatChevyGuy is offline NOLA Sludge



    Join Date
    Jul 2006
    Location
    Arkansas
    Posts
    12,399
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    955 Post(s)

    Re: Amp may have gotten wet, Troubleshooting help?

    find where the leak is coming from asap! sounds like it got inside your amp...



    REFS:
    Squeak9798, Kumbos310w6, BigBangTheory, Jmanpc, MillzThaYungin, WLDock, -Leister-, ThomasG, J31Rob (and a few more I have forgotten)
    Quote Originally Posted by Spider Monkey View Post
    eat my asshole you insignificant bastard child of a retarded dingleberry cunt wrinkle fuck toy
    Quote Originally Posted by subzero View Post
    her pussy better be that nicest pussy you ever ever ever had. she better suck, swallow, jack off, eat ass and snatch, make sammiwich, do yard work and fix the vehicals while nude. Because a bitch like that is definately gonna cause alot of stress in your life, even thou she keeps your wallet and your balls drained.
    Quote Originally Posted by 05fronty View Post
    bitch you better swallow and not make a mess

  3. #3
    fastfive09's Avatar
    fastfive09 is offline Senior VIP Member

    Threadstarter


    Join Date
    Jul 2008
    Location
    SLidell, LA
    Posts
    152
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Amp may have gotten wet, Troubleshooting help?

    Amp has been removed from the car and the leak has been fixed.
    Is this amp toast now or is there a way of telling which components are fried??




  4. #4
    dragnix's Avatar
    dragnix is offline LXIX



    Join Date
    Dec 2006
    Location
    Socal cuz i'm So cool
    Posts
    19,636
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    655 Post(s)

    Re: Amp may have gotten wet, Troubleshooting help?

    open it up?




  5. #5
    Trippymane's Avatar
    Trippymane is offline Senior VIP Member



    Join Date
    May 2012
    Location
    Central Illinios
    Posts
    165
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    81 Post(s)

    Re: Amp may have gotten wet, Troubleshooting help?

    Put it in a bag of rice lol




  6. #6
    fastfive09's Avatar
    fastfive09 is offline Senior VIP Member

    Threadstarter


    Join Date
    Jul 2008
    Location
    SLidell, LA
    Posts
    152
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Amp may have gotten wet, Troubleshooting help?

    Just to add some more information. My amp does turn on with a green light and does not go into protect mode. I made actually try a bag of rice haha.
    I will also open it up and post some pictures whenever that is finished




  7. #7
    Trippymane's Avatar
    Trippymane is offline Senior VIP Member



    Join Date
    May 2012
    Location
    Central Illinios
    Posts
    165
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    81 Post(s)

    Re: Amp may have gotten wet, Troubleshooting help?

    Its worth a shot.




Closed Thread

Similar Threads

  1. May have gotten screwed...
    By bball09124 in forum Amplifiers
    Replies: 23
    Last Post: 01-20-2008, 03:38 PM
  2. Help me figure out why my amp may have blew?
    By airmcnair06 in forum Amplifiers
    Replies: 26
    Last Post: 07-28-2007, 06:46 PM
  3. I have a sub/amp question for you all. Please help!
    By ybnormal70 in forum Subwoofers
    Replies: 6
    Last Post: 02-03-2006, 12:13 AM
  4. Amp Troubleshooting help!!!
    By jclark427 in forum Wiring, Electrical and Installation Help
    Replies: 2
    Last Post: 12-29-2003, 03:59 PM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum