Closed Thread
Results 1 to 3 of 3

Reload Thread: pioneer amp problemo!

  1. #1
    chrisw91's Avatar
    chrisw91 is offline Senior VIP Member



    Join Date
    Jul 2008
    Location
    phoenix, az
    Posts
    451
    Post Thanks / Like
    Mentioned
    0 Post(s)

    pioneer amp problemo!

    have a Pioneer Stage 4 PRS-D4200F 4-channel car amplifier 75 watts RMS x 4 at Crutchfield.com in my truck and having some trouble diagnosing why it is cutting out. not sure what to blame here... have only the front channel hooked up to a set of components, and have another amp set up through the pre out rca's. when subs hit, the speakers from the pioneer cut out, but the other is still going. so i thought maybe vibration damage... but even when at low volumes without subs not playing, when i take a hard turn on the road they cut out, or even when braking hard. is it possible something is so loose in it that it is that sensitive? ground? but wondering, if that amp shut down, would the pre out still feed to the other amp? want some help here as it takes 3 hours to get to the amp... thanks



    1991 dodge ram 2500 standard cab
    hu- kenwood kdc-mp438u
    front- polk momo's 6x9's
    back- diamond audio tweets
    sub- 4 RE8's in sealed enclosure wired to 2 ohms
    sub amp- memphis prd.1000
    6x9's amp- rf 250a2
    everything deadened w/raamat (besides floor and roof)

    refs: civicman07(3), probmxstyle, Slammed, us3, teen,KevinWS6,1985-stang, fo0manchu
    traded: 4OZGLOVES




  2. #2
    itsblown's Avatar
    itsblown is offline why is there smoke?



    Join Date
    Sep 2011
    Location
    Toledo OH
    Posts
    1,147
    Post Thanks / Like
    Mentioned
    15 Post(s)

    Re: pioneer amp problemo!

    Check all your wiring connections. When it cuts out is the amplifier still on lit up? if so it could be a short in the speaker wire. If it turns off when it cuts out, its either a loose power or ground wire, or a loose turn on wire.




  3. #3
    chrisw91's Avatar
    chrisw91 is offline Senior VIP Member

    Threadstarter


    Join Date
    Jul 2008
    Location
    phoenix, az
    Posts
    451
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: pioneer amp problemo!

    everything seems good! speakers are 4 ohms, ground is .3 ohms, lights stays on but after i heard them cut out i paused music real quick and i could here something in the amp clicking like its turning back on. but never saw the light turn off...



    1991 dodge ram 2500 standard cab
    hu- kenwood kdc-mp438u
    front- polk momo's 6x9's
    back- diamond audio tweets
    sub- 4 RE8's in sealed enclosure wired to 2 ohms
    sub amp- memphis prd.1000
    6x9's amp- rf 250a2
    everything deadened w/raamat (besides floor and roof)

    refs: civicman07(3), probmxstyle, Slammed, us3, teen,KevinWS6,1985-stang, fo0manchu
    traded: 4OZGLOVES

Closed Thread

Similar Threads

  1. Pioneer Amp
    By pmpdout in forum Amplifiers
    Replies: 6
    Last Post: 12-17-2002, 01:20 AM
  2. Pioneer Amp / Speaker Question
    By AkumaSG in forum Amplifiers
    Replies: 1
    Last Post: 06-21-2002, 01:28 AM
  3. Pioneer Amp wire colours
    By simgarcha in forum Wiring, Electrical and Installation Help
    Replies: 1
    Last Post: 06-20-2002, 07:40 AM
  4. Is this pioneer amp 2ohm stable?
    By adamawayfrommpa in forum Amplifiers
    Replies: 3
    Last Post: 04-19-2002, 12:16 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum