Closed Thread
Results 1 to 8 of 8

Reload Thread: Amp worries ~help needed~

  1. #1
    oldschoolboomer's Avatar
    oldschoolboomer is offline Premium Member oldschoolboomer is a Supporting Member of the forum!



    Join Date
    Jul 2007
    Location
    white house, TN
    Posts
    1,942
    Post Thanks / Like
    Images
    3
    Mentioned
    2 Post(s)

    Amp worries ~help needed~

    Just received an amp today and I opened it up to check the innards. Are any of these things a problem?



    The subsonic switch is broken and jammed in sideways, but that probably won't affect anything right?



    06 TJ Unlimited: cz702,q1-3500d.1,(2) ppi p900.4,(2)15-mc52,15-mc1a, 15-mcsq6.5, (2)hdc3 10's, 1 optima d34 under hood, (2) optima d31 out back, 220 amp alternator

    refs: RAB - louisiana_crx - fearof85 - vitveet - t00sh0rt - bigboggsy - apsabr - shinju - bender-offender - taintedplay-gln305 - dacheatham - revrider1 - JHardee - jaredspl - bigbangindodge - ridnclean - rxzilla - aztec - got-one-eight - clifff150 - and the list goes on and on.......




  2. #2
    Shinju's Avatar
    Shinju is offline CarAudio.com Veteran



    Join Date
    Aug 2008
    Location
    Seattle
    Posts
    4,821
    Post Thanks / Like
    Mentioned
    23 Post(s)

    Re: Amp worries ~help needed~

    looks like it has been repaired before, that cap looks like it is bulging out.



    List of Ref's Just ask, Shinju on all Car Audio Forums!


    Flawless Ebay Feedback User: Shadox2k2

  3. #3
    oldschoolboomer's Avatar
    oldschoolboomer is offline Premium Member oldschoolboomer is a Supporting Member of the forum!

    Threadstarter


    Join Date
    Jul 2007
    Location
    white house, TN
    Posts
    1,942
    Post Thanks / Like
    Images
    3
    Mentioned
    2 Post(s)

    Re: Amp worries ~help needed~

    Quote Originally Posted by Shinju View Post
    looks like it has been repaired before, that cap looks like it is bulging out.
    The other cap has it's "wrapping" intact and the top is coated black.



    06 TJ Unlimited: cz702,q1-3500d.1,(2) ppi p900.4,(2)15-mc52,15-mc1a, 15-mcsq6.5, (2)hdc3 10's, 1 optima d34 under hood, (2) optima d31 out back, 220 amp alternator

    refs: RAB - louisiana_crx - fearof85 - vitveet - t00sh0rt - bigboggsy - apsabr - shinju - bender-offender - taintedplay-gln305 - dacheatham - revrider1 - JHardee - jaredspl - bigbangindodge - ridnclean - rxzilla - aztec - got-one-eight - clifff150 - and the list goes on and on.......

  4. #4
    oldschoolboomer's Avatar
    oldschoolboomer is offline Premium Member oldschoolboomer is a Supporting Member of the forum!

    Threadstarter


    Join Date
    Jul 2007
    Location
    white house, TN
    Posts
    1,942
    Post Thanks / Like
    Images
    3
    Mentioned
    2 Post(s)

    Re: Amp worries ~help needed~

    Supposed to be mint



    06 TJ Unlimited: cz702,q1-3500d.1,(2) ppi p900.4,(2)15-mc52,15-mc1a, 15-mcsq6.5, (2)hdc3 10's, 1 optima d34 under hood, (2) optima d31 out back, 220 amp alternator

    refs: RAB - louisiana_crx - fearof85 - vitveet - t00sh0rt - bigboggsy - apsabr - shinju - bender-offender - taintedplay-gln305 - dacheatham - revrider1 - JHardee - jaredspl - bigbangindodge - ridnclean - rxzilla - aztec - got-one-eight - clifff150 - and the list goes on and on.......

  5. #5
    oldschoolboomer's Avatar
    oldschoolboomer is offline Premium Member oldschoolboomer is a Supporting Member of the forum!

    Threadstarter


    Join Date
    Jul 2007
    Location
    white house, TN
    Posts
    1,942
    Post Thanks / Like
    Images
    3
    Mentioned
    2 Post(s)

    Re: Amp worries ~help needed~

    Everything else on the inside looks normal as far as I can tell. Is it safe to hook up or will it flame up?



    06 TJ Unlimited: cz702,q1-3500d.1,(2) ppi p900.4,(2)15-mc52,15-mc1a, 15-mcsq6.5, (2)hdc3 10's, 1 optima d34 under hood, (2) optima d31 out back, 220 amp alternator

    refs: RAB - louisiana_crx - fearof85 - vitveet - t00sh0rt - bigboggsy - apsabr - shinju - bender-offender - taintedplay-gln305 - dacheatham - revrider1 - JHardee - jaredspl - bigbangindodge - ridnclean - rxzilla - aztec - got-one-eight - clifff150 - and the list goes on and on.......

  6. #6
    Shinju's Avatar
    Shinju is offline CarAudio.com Veteran



    Join Date
    Aug 2008
    Location
    Seattle
    Posts
    4,821
    Post Thanks / Like
    Mentioned
    23 Post(s)

    Re: Amp worries ~help needed~

    What amp is it? Hook it up!



    List of Ref's Just ask, Shinju on all Car Audio Forums!


    Flawless Ebay Feedback User: Shadox2k2

  7. #7
    oldschoolboomer's Avatar
    oldschoolboomer is offline Premium Member oldschoolboomer is a Supporting Member of the forum!

    Threadstarter


    Join Date
    Jul 2007
    Location
    white house, TN
    Posts
    1,942
    Post Thanks / Like
    Images
    3
    Mentioned
    2 Post(s)

    Re: Amp worries ~help needed~

    Too cold and dark. Mc2000d



    06 TJ Unlimited: cz702,q1-3500d.1,(2) ppi p900.4,(2)15-mc52,15-mc1a, 15-mcsq6.5, (2)hdc3 10's, 1 optima d34 under hood, (2) optima d31 out back, 220 amp alternator

    refs: RAB - louisiana_crx - fearof85 - vitveet - t00sh0rt - bigboggsy - apsabr - shinju - bender-offender - taintedplay-gln305 - dacheatham - revrider1 - JHardee - jaredspl - bigbangindodge - ridnclean - rxzilla - aztec - got-one-eight - clifff150 - and the list goes on and on.......

  8. #8
    Shinju's Avatar
    Shinju is offline CarAudio.com Veteran



    Join Date
    Aug 2008
    Location
    Seattle
    Posts
    4,821
    Post Thanks / Like
    Mentioned
    23 Post(s)

    Re: Amp worries ~help needed~

    Thought it was a Memphis.



    List of Ref's Just ask, Shinju on all Car Audio Forums!


    Flawless Ebay Feedback User: Shadox2k2

Closed Thread

Similar Threads

  1. New Sub/Amp: Design help needed
    By CentralFC in forum Enclosure Design & Construction Help
    Replies: 1
    Last Post: 06-15-2010, 11:02 AM
  2. Broke amp electrical help needed
    By DDSC in forum Wiring, Electrical and Installation Help
    Replies: 8
    Last Post: 08-22-2008, 12:17 PM
  3. Fuse on Amp Blows Help needed!!!
    By gabossboy in forum Wiring, Electrical and Installation Help
    Replies: 10
    Last Post: 05-20-2006, 09:26 PM
  4. AMP Selection HELP NEEDED!!!
    By ruffryda430 in forum Amplifiers
    Replies: 11
    Last Post: 09-26-2005, 03:12 PM
  5. Amp/Tweeter Help Needed
    By Outsider in forum Wiring, Electrical and Installation Help
    Replies: 11
    Last Post: 01-02-2005, 02:20 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum