Closed Thread
Results 1 to 7 of 7

Reload Thread: What is the problem with this amp ? crossfire vr804

  1. #1
    john691's Avatar
    john691 is offline Junior Member



    Join Date
    Dec 2012
    Location
    ca
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2 Post(s)

    What is the problem with this amp ? crossfire vr804

    hi guys , ı have crossfire vr804 , wanna ask you someting about this amp , problem started after use this amp in my home with 30 amp smps , ı noticed someting strange , give power to the amp , 1-2 second amp goes protection and 1-2 second later amp works normal , altough ı didnt wire comps , same problem occurs.....ıs there a really probelm ?







  2. #2
    myjaja's Avatar
    myjaja is offline Audioque



    Join Date
    Sep 2006
    Location
    San Antonio, Tx Posts: 143,632 _____<^>*_*<^>_____
    Posts
    3,651
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    492 Post(s)

    Re: What is the problem with this amp ? crossfire vr804

    what?

    Check your ground wire.



    Refs: sbcaprice305, mattmcss, systembumping, LeofromtheH, audiobahnuser18, stishdr, wcarson8911, jnoel, mr_kebo, 93 saturn sl2



    HU: Home stereo converted to dc
    Speakers: Stock
    Subs: 6 1/2 home sub
    Amp: off the stereo
    Wiring: extended power cord
    neon lights: Christmas lights duct taped to frame

  3. #3
    Wingman0121's Avatar
    Wingman0121 is offline CarAudio.com Veteran



    Join Date
    Mar 2010
    Location
    Wisconsin Rapids, Wisconsin
    Posts
    2,549
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    88 Post(s)

    Re: What is the problem with this amp ? crossfire vr804

    Quote Originally Posted by john691 View Post
    hi guys , ı have crossfire vr804 , wanna ask you someting about this amp , problem started after use this amp in my home with 30 amp smps , ı noticed someting strange , give power to the amp , 1-2 second amp goes protection and 1-2 second later amp works normal , altough ı didnt wire comps , same problem occurs.....ıs there a really probelm ?

    TRANSLATION:

    I'm having problem with a Crossfire vr804 amp. I'm using a 30-amp power supply in my house to run the amp and I noticed that the protection light comes on for 1-2 seconds but after 1-2 seconds it works just fine. Should I be worried?



    Sold to: Mills561, Kross6622, sleazebagger, shpatb, esmokah
    Traded: Kross6622
    Bought from: DJ Nitrous 427, 97maxima

  4. #4
    john691's Avatar
    john691 is offline Junior Member

    Threadstarter


    Join Date
    Dec 2012
    Location
    ca
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2 Post(s)

    Re: What is the problem with this amp ? crossfire vr804

    Quote Originally Posted by Wingman0121 View Post
    TRANSLATION:

    I'm having problem with a Crossfire vr804 amp. I'm using a 30-amp power supply in my house to run the amp and I noticed that the protection light comes on for 1-2 seconds but after 1-2 seconds it works just fine. Should I be worried?
    thanks man , sorry for poor english




  5. #5
    neo_styles's Avatar
    neo_styles is offline AKA Pop Twidget



    Join Date
    Sep 2012
    Location
    Porter Ranch, CA
    Age
    29
    Posts
    3,611
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1693 Post(s)

    Re: What is the problem with this amp ? crossfire vr804

    I'm guessing ground wire as well



    Deck: JVC KD-A95BT
    Speakers: PHD FB mid, JBL MS tweets
    Amps: Boston Acoustics GT-2125, Zed Minotaur III (x2)
    Sub: 10" SSA ICON, IA Death Penalty 18" (coming soon)
    Starr Mountain Sound Nuthugger #2 (I'm a #2 lol)
    dcarcustoms Nuthugger #1
    Spotify: http://open.spotify.com/user/neo_styles/playlist/6t9ru42j0wbEsuo4bXqXD8
    PROUD MEMBER OF TEAM VERTEX

  6. #6
    Shinju's Avatar
    Shinju is offline CarAudio.com Veteran



    Join Date
    Aug 2008
    Location
    Seattle
    Posts
    4,823
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    117 Post(s)

    Re: What is the problem with this amp ? crossfire vr804

    I will have to say you are not giving that amp enough current. Those are monster 4 channels that pull 80a at modest volume. If your only running a 30a MAX powersupply you are tapping it out and are going to blow your amplifier and PS if you keep it up. Do you have some sort of 12v motorcycle battery as a charge source?

    Turn the gain alway down and see what happens.



    List of Ref's Just ask, Shinju on all Car Audio Forums!


    Flawless Ebay Feedback User: Shadox2k2

  7. #7
    Timmothy Web's Avatar
    Timmothy Web is offline Senior VIP Member



    Join Date
    Jul 2011
    Location
    Memphis, Tennessee, United States
    Posts
    305
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    45 Post(s)

    Re: What is the problem with this amp ? crossfire vr804

    find u a small cap. charge it up slow and see if it stops...im using a few in a bigger power supply im building soon.




Closed Thread

Similar Threads

  1. Replies: 6
    Last Post: 05-20-2007, 03:54 PM
  2. whats the deal with this amp modding
    By lowgmc94 in forum Amplifiers
    Replies: 4
    Last Post: 09-22-2005, 05:55 PM
  3. What is the problem with my system?
    By KMS_RB_34 in forum Subwoofers
    Replies: 13
    Last Post: 06-15-2003, 07:03 PM
  4. Replies: 4
    Last Post: 08-23-2002, 05:23 PM
  5. What are the problems with bandpass?
    By CheapPyramidStuff in forum Wiring, Electrical and Installation Help
    Replies: 4
    Last Post: 12-26-2001, 02:53 AM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum