Closed Thread
Results 1 to 4 of 4

Reload Thread: Amp won't turn on after getting bumped around

  1. #1
    ckunke002's Avatar
    ckunke002 is offline Senior VIP Member



    Join Date
    Oct 2011
    Location
    Clackamas, OR
    Posts
    491
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    79 Post(s)

    Amp won't turn on after getting bumped around

    I had to pull my sub box out of my car to fix some wiring inside the box. My amps are screwed into the side of the box, but due to size restrictions only 2 corners of the sub amp are screwed in so it can rattle around if shaken. It got bounced around a bit from all of the work and now when i plugged my amps back into my system and fired it up, the other amp reluctantly started up but the bass amp won't start up at all. This is the first time it's ever done this since I bought it about a year ago.

    I don't know the first thing about amps, or what I would look for inside one. I have a few car audio stores around me including the big guys like Car Toys and Best Buy, which I usually don't like to go to..but if that's what it comes to I will.

    Any advice highly appreciated. Need some direction here.

    For the record, the amp is a Boston 500m.

    Pic here Boston Acoustics US)

    BTW the amp was bought under a non authorized dealer (ebay) and is not under warranty.







  2. #2
    gckless's Avatar
    gckless is online now CarAudio.com Veteran



    Join Date
    Aug 2011
    Location
    San Antonio
    Posts
    4,875
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2066 Post(s)

    Re: Amp won't turn on after getting bumped around

    Have you tested the voltage at the amp terminals? Is it getting power to it? Check your grounds also. Do you have the remote turn-on lead properly connected both at the amp and head unit, and is that giving sufficient voltage?



    Quote Originally Posted by benbenondatrack View Post
    stfu lesbo.why are you worried about me so much? you must want to date me ya little cookie monster but i dont even like sweets. your just a cup full of ice, dirt dead nasty azz ice...without the water.

    Dat Build Log: http://mobileaudioforum.com/forum/showthread.php?2566-1999-Chevrolet-Blazer&highlight=1999+blazer
    High resolution photos: http://www.gilbertklessphotography.com/

  3. #3
    ckunke002's Avatar
    ckunke002 is offline Senior VIP Member

    Threadstarter


    Join Date
    Oct 2011
    Location
    Clackamas, OR
    Posts
    491
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    79 Post(s)

    Re: Amp won't turn on after getting bumped around

    How much voltage is the remote lead supposed to be giving?




  4. #4
    Join Date
    Jul 2006
    Location
    Arkansas
    Posts
    12,735
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1109 Post(s)

    Re: Amp won't turn on after getting bumped around

    sounds like something came loose, but hopefully not.



    REFS:
    Squeak9798, Kumbos310w6, BigBangTheory, Jmanpc, MillzThaYungin, WLDock, -Leister-, ThomasG, J31Rob (and a few more I have forgotten)

    Quote Originally Posted by BassAndBeer View Post
    sorry man but ford will always be a ford. ford is the sony xplod of cars and trucks. you had bad experiences with chevy because your a ford guy. its what seperates the men from the boys. friend billy use to drive a ford. he drives a chevy now. they call him billy no more. hes known as bill now..

Closed Thread

Similar Threads

  1. amp won't turn on? help...
    By pw91686 in forum Amplifiers
    Replies: 13
    Last Post: 01-30-2006, 09:54 AM
  2. amp won't turn on = me sad =(
    By dannyt in forum Wiring, Electrical and Installation Help
    Replies: 25
    Last Post: 01-04-2006, 09:54 AM
  3. Amp won't turn on.
    By vsynergy in forum Wiring, Electrical and Installation Help
    Replies: 9
    Last Post: 11-28-2005, 10:02 PM
  4. Amp won't turn on?!?!?!?!?!!!!!!!
    By kickerlivinloud in forum Wiring, Electrical and Installation Help
    Replies: 10
    Last Post: 04-24-2005, 10:05 PM
  5. Amp won't turn on....
    By rpeAMP in forum Amplifiers
    Replies: 3
    Last Post: 10-03-2002, 11:20 PM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum