Closed Thread
Results 1 to 3 of 3

Reload Thread: I think There trying to slap my head.. Please help.

  1. #1
    Slaterbbx's Avatar
    Slaterbbx is offline Junior Member



    Join Date
    Nov 2012
    Location
    Florida
    Posts
    2
    Post Thanks / Like
    Mentioned
    0 Post(s)

    I think There trying to slap my head.. Please help.

    I think There trying to slap my head.. Please help.-imag0370.jpg

    The above picture is of my JBL GT5 - A604

    My system has a total of 4 amps and too many wires for me to know what im doing. (Im not very savy with installing systems etc...)

    1 day my 4 door speakers that where running off of the JBL GT5 just cut out. I quickly checked the amp / smelled around it etc.. no smell of smoke and the LED on the front was still lit up showing that it was receiving power.

    So the following day I took it into a shop to have it tested, (At this point I hadnt opened it yet)

    They took it in the back, Supposedly opened it up and looked at it / tested it and then came back. He then said that the inside was completely fried, then said if I got a new one that day he would hook me up with a good deal. I said no, took it home and opened it up..

    Inside it literally still looks brand new, No smell / look of fried anything. He also told me the reason that it was fried was because one of my door speakers was starting to go out.. and that this caused some of the power to get sent back to the amp and thats what ruined it..

    So today I come to you guys for help, Are they trying to bullshit me? Should I have it tested again somewhere else without giving them any backstory?

    What you can see in the picture is exactly how everything looks.. Not even any dust inside, The amp was also only about 4 months old at the time it cut out.

    Any help would be greatly appreciated.

    Thanks







  2. #2
    gckless's Avatar
    gckless is offline CarAudio.com Veteran



    Join Date
    Aug 2011
    Location
    San Antonio
    Posts
    4,106
    Post Thanks / Like
    Mentioned
    28 Post(s)

    Re: I think There trying to slap my head.. Please help.

    Yeah it looks like they are trying to BS you. Don't go back there. Why are you running 4 amps? Regardless, you should be able to test this yourself. Hook it up to power, and hook up a DMM to the speaker leads, see if it's giving you power. Also check your voltage at the inputs.



    Quote Originally Posted by ducatipaso View Post
    15inch subs can't play fast beats, they take more power and that taxes the vehicles electrical system. You will wake up and "hear" then see the light at the end of the tunnel and it will be 3 10's pounding so hard you wont even open your trunk or turn your system on because you 15's will sound sloppy & weak.
    Quote Originally Posted by benbenondatrack View Post
    stfu lesbo.why are you worried about me so much? you must want to date me ya little cookie monster but i dont even like sweets. your just a cup full of ice, dirt dead nasty azz ice...without the water.

    Dat Build Log: http://mobileaudioforum.com/forum/showthread.php?2566-1999-Chevrolet-Blazer&highlight=1999+blazer

  3. Thanks Slaterbbx, AxT4430 thanked for this post
    Likes Slaterbbx, Jes 42 liked this post
  4. #3
    Slaterbbx's Avatar
    Slaterbbx is offline Junior Member

    Threadstarter


    Join Date
    Nov 2012
    Location
    Florida
    Posts
    2
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: I think There trying to slap my head.. Please help.

    Thanks much for the quick response..

    The reason behind the 4 amps is: I have 3 12in 600w RMS cerwin vega subs (Before they sold out) and 3 seperate 600w RMS cerwin vega amps, 1 for each plus the 4 channel for the door speakers.

    Also I dont know much about testing etc.. (At all) What is a DMM? EDIT: duh its a multimeter lol

    Thanks again for your help, Ill report back what I find. And the name of the shop if its still working properly, just encase anyone local see's this




Closed Thread

Similar Threads

  1. need to upgrade my system...please help
    By Some DudeMan in forum Car Audio Build Logs - Cars/Trucks/SUVs
    Replies: 41
    Last Post: 07-24-2008, 09:31 PM
  2. Trying to find a head that will fit my Reatta
    By smcmoran in forum Head Units
    Replies: 2
    Last Post: 03-09-2008, 08:21 PM
  3. I want to blow my subs!!! please help.
    By bobo244 in forum General Discussion
    Replies: 36
    Last Post: 02-03-2004, 12:27 PM
  4. I think I'm in over my head with this Alpine HU!
    By Aurorav8 in forum General Discussion
    Replies: 9
    Last Post: 05-04-2003, 09:19 PM
  5. How To Tune my head unit and amp
    By haydenm in forum General Discussion
    Replies: 3
    Last Post: 09-01-2002, 10:13 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum