Closed Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 19

Reload Thread: No High-pass filter/Subsonic on JL amp.

  1. #1
    daveishome's Avatar
    daveishome is offline Member



    Join Date
    Oct 2012
    Location
    Canada
    Posts
    111
    Post Thanks / Like
    Mentioned
    0 Post(s)

    No High-pass filter/Subsonic on JL amp.

    I have one of the newer JX-1000/1d's and it has no Subsonic filter which *****.
    I build a nice ported enclosure and ordered my sub, but now I'm not sure what to do because I don't want the sub playing anything below 30hz.
    Would I be ok with out it?
    Should I get a pair of those Passive Fmod filters? (heard they **** tho)







  2. #2
    d77543020's Avatar
    d77543020 is offline CarAudio.com Veteran



    Join Date
    Dec 2005
    Location
    stockton ca
    Posts
    2,485
    Post Thanks / Like
    Mentioned
    5 Post(s)

    Re: No High-pass filter/Subsonic on JL amp.

    you will be fine most bass songs wont go below 30hz




  3. #3
    DDtC's Avatar
    DDtC is online now High Output SQ



    Join Date
    Apr 2011
    Location
    Va Beach, Va
    Age
    33
    Posts
    7,401
    Post Thanks / Like
    Mentioned
    47 Post(s)

    Re: No High-pass filter/Subsonic on JL amp.

    It has a sub sonic its just set. I would guess set at 30hz



    • 2010 Scion tC
    • Pioneer DEH-80PRS
    • JL 450/4v2 Active (Mid range, tweeters) JL 300/2v2 (Mid bass) DD M4(Subs)
    • Hertz HV 165XL
    • Hertz HT28
    • JL ZR800
    • 2 x DD 9512i
    • Singer 300 amp 15.1v bypass, 3 XS D3400s
    • Viper 5701 with Smart Start

  4. #4
    zako's Avatar
    zako is offline CarAudio.com Elite



    Join Date
    Jan 2011
    Location
    TX
    Posts
    1,347
    Post Thanks / Like
    Mentioned
    6 Post(s)

    Re: No High-pass filter/Subsonic on JL amp.

    As long as you don't hear the subwoofer bottoming out it should not be a problem. One has to have a strong penchant for playing subsonic content in order to get there. The amplifier filters do seem to be less than optimal unless there is "silent" subsonic filter built in.




  5. #5
    NASTY08IMPALA's Avatar
    NASTY08IMPALA is online now CarAudio.com Veteran



    Join Date
    Aug 2012
    Location
    LOUISVILLE, KENTUCKY
    Posts
    5,179
    Post Thanks / Like
    Mentioned
    43 Post(s)

    Re: No High-pass filter/Subsonic on JL amp.

    i only listen to songs under 30htz lol




  6. #6
    daveishome's Avatar
    daveishome is offline Member

    Threadstarter


    Join Date
    Oct 2012
    Location
    Canada
    Posts
    111
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: No High-pass filter/Subsonic on JL amp.

    Ok that's good, I'l make sure I only play songs then. Could I even play Bass I Love You?
    Idk about a silent filter though, it just says N/A. Prob phone JL see if they have any info on it.




  7. #7
    daveishome's Avatar
    daveishome is offline Member

    Threadstarter


    Join Date
    Oct 2012
    Location
    Canada
    Posts
    111
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: No High-pass filter/Subsonic on JL amp.

    It says with Frequency response from 10-150Hz
    So..Idk.




  8. #8
    NASTY08IMPALA's Avatar
    NASTY08IMPALA is online now CarAudio.com Veteran



    Join Date
    Aug 2012
    Location
    LOUISVILLE, KENTUCKY
    Posts
    5,179
    Post Thanks / Like
    Mentioned
    43 Post(s)

    Re: No High-pass filter/Subsonic on JL amp.

    amp says 10-150 u better hope its got a subsonic on it somewhere lol




  9. #9
    NASTY08IMPALA's Avatar
    NASTY08IMPALA is online now CarAudio.com Veteran



    Join Date
    Aug 2012
    Location
    LOUISVILLE, KENTUCKY
    Posts
    5,179
    Post Thanks / Like
    Mentioned
    43 Post(s)

    Re: No High-pass filter/Subsonic on JL amp.

    Quote Originally Posted by daveishome View Post
    It says with Frequency response from 10-150Hz
    So..Idk.
    amp specs read 20-150 ...which is good...i set mine at 20 usually




  10. #10
    NASTY08IMPALA's Avatar
    NASTY08IMPALA is online now CarAudio.com Veteran



    Join Date
    Aug 2012
    Location
    LOUISVILLE, KENTUCKY
    Posts
    5,179
    Post Thanks / Like
    Mentioned
    43 Post(s)

    Re: No High-pass filter/Subsonic on JL amp.

    what sub (s) are you running ? what kinda box?

    ---------- Post added at 09:30 PM ---------- Previous post was at 09:29 PM ----------

    just set it on 100 and cross it over at 80 on the hu




  11. #11
    daveishome's Avatar
    daveishome is offline Member

    Threadstarter


    Join Date
    Oct 2012
    Location
    Canada
    Posts
    111
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: No High-pass filter/Subsonic on JL amp.

    1 IA DR 15 in 4.25 cubes. With an aero port.




  12. #12
    daveishome's Avatar
    daveishome is offline Member

    Threadstarter


    Join Date
    Oct 2012
    Location
    Canada
    Posts
    111
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: No High-pass filter/Subsonic on JL amp.

    Quote Originally Posted by NASTY08IMPALA View Post
    amp says 10-150 u better hope its got a subsonic on it somewhere lol
    Yeah my bad 20hz.




  13. #13
    NASTY08IMPALA's Avatar
    NASTY08IMPALA is online now CarAudio.com Veteran



    Join Date
    Aug 2012
    Location
    LOUISVILLE, KENTUCKY
    Posts
    5,179
    Post Thanks / Like
    Mentioned
    43 Post(s)

    Re: No High-pass filter/Subsonic on JL amp.

    should be fine ..just set it around 100 on amp and cross it at 80 on hu

    ---------- Post added at 09:50 PM ---------- Previous post was at 09:50 PM ----------

    its no fun if u cant play songs in the 20.s




  14. #14
    daveishome's Avatar
    daveishome is offline Member

    Threadstarter


    Join Date
    Oct 2012
    Location
    Canada
    Posts
    111
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: No High-pass filter/Subsonic on JL amp.

    cross?




  15. #15
    NASTY08IMPALA's Avatar
    NASTY08IMPALA is online now CarAudio.com Veteran



    Join Date
    Aug 2012
    Location
    LOUISVILLE, KENTUCKY
    Posts
    5,179
    Post Thanks / Like
    Mentioned
    43 Post(s)

    Re: No High-pass filter/Subsonic on JL amp.

    low pass crossover or filter ..set it to 100 on amp and 80 on ur head unit ..if your headunit has that ability




Closed Thread
Page 1 of 2 1 2 LastLast

Similar Threads

  1. Replies: 7
    Last Post: 05-03-2012, 01:58 AM
  2. A few questions on my setup concerning high pass filter and gain
    By RoachForLife in forum Wiring, Electrical and Installation Help
    Replies: 4
    Last Post: 04-06-2012, 06:47 PM
  3. Replies: 3
    Last Post: 02-24-2010, 10:00 PM
  4. jl audio speakers were played with no high pass filter.
    By csnut18 in forum General Discussion
    Replies: 18
    Last Post: 08-20-2008, 03:57 AM
  5. Replies: 2
    Last Post: 11-18-2007, 03:43 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum