Closed Thread
Page 7 of 9 FirstFirst 1 2 3 4 5 6 7 8 9 LastLast
Results 91 to 105 of 124

Reload Thread: My SK-1500.1 is junk

  1. #91
    av83's Avatar
    av83 is online now CarAudio.com Veteran



    Join Date
    Mar 2012
    Location
    Illinois
    Posts
    2,871
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1254 Post(s)

    Re: My SK-1500.1 is junk

    Didn't op say something about using a stock ground point in a previous post? no time to look myself, atm, but those things aren't meant for much more than grounding some taillights and a rear defrost...



    Pioneer 80prs
    ...
    Rockford Fosgate t800.4, CDT ES-MO 6 mids, Digital Designs T2 tweets
    ...
    2 MB Quart DSC1500.1's strapped on 1 Tantric HDD 12
    Mike Singer 310 amp 6 phase
    ...
    2 runs of Monster Cable 1/0




  2. #92
    TheUnderFighter's Avatar
    TheUnderFighter is offline Beer Addict



    Join Date
    Mar 2011
    Location
    Murrieta, California, (SoCal)
    Age
    23
    Posts
    3,465
    Post Thanks / Like
    Images
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    855 Post(s)

    Re: My SK-1500.1 is junk

    Quote Originally Posted by av83 View Post
    Didn't op say something about using a stock ground point in a previous post? no time to look myself, atm, but those things aren't meant for much more than grounding some taillights and a rear defrost...
    He said his battery is in the rear, so that's where he grounded it.



    2009 Hyundai Elantra - Budget Sound in Progress
    HU- Kenwood eXcelon KDC-X994
    Fronts- Crescendo MP6 mids, Vifa Ring Radiator tweets on Arc KS300.4
    Subs- Single SA-10 on Mmats 2000.1 @ 1ohm
    Misc- 1/0 CCA from AT, Big 3 in Stinger HPM, and AT 60 mil deadener
    Bought from: Inferno333, select127, treesive, Kangaroux, DonH
    Sold to: coolest user, Psychodrama, MidgetClown, mr.tigger, av83

  3. #93
    av83's Avatar
    av83 is online now CarAudio.com Veteran



    Join Date
    Mar 2012
    Location
    Illinois
    Posts
    2,871
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1254 Post(s)

    Re: My SK-1500.1 is junk

    Quote Originally Posted by TheUnderFighter View Post
    He said his battery is in the rear, so that's where he grounded it.
    Ok, nm



    Pioneer 80prs
    ...
    Rockford Fosgate t800.4, CDT ES-MO 6 mids, Digital Designs T2 tweets
    ...
    2 MB Quart DSC1500.1's strapped on 1 Tantric HDD 12
    Mike Singer 310 amp 6 phase
    ...
    2 runs of Monster Cable 1/0

  4. #94
    JoeK's Avatar
    JoeK is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Apr 2012
    Location
    Ringtown, PA
    Age
    20
    Posts
    1,053
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    412 Post(s)

    Re: My SK-1500.1 is junk

    Yeah i did an inspection on the whole ground thing. Looks like i grounded the 0 gauge wire onto the battery which had a 4AWG ground to the frame. This could have possibly caused the problem. I took the 1/0AWG ground and put it right on the bolt to the frame where it should have been. During a quick test at full tilt @ 500rpm Played excellent(possibly louder?) and has not gone into protect. I do not have the clamp to check now but i may in the future. I still plan on getting a 2k+ amp so i can give 1500 clean watts to the BL.

    As of now everything appear to works, but ill find out the more i use it.



    ** NEW VEHICLE AND BUILD ** 2003 Jeep Liberty Sport
    2x SPLAudio DAD BD 12s
    2x SK-1500.1s
    Box 5 cubes @ 29hz
    XS Power D3100 & D2400
    Tenney 270A
    4x PowerBass 3xl 6.5s
    Clarion CZ702

  5. #95
    JoeK's Avatar
    JoeK is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Apr 2012
    Location
    Ringtown, PA
    Age
    20
    Posts
    1,053
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    412 Post(s)

    Re: My SK-1500.1 is junk

    Went into protect mode twice today. Once during full tilt. Right after that i turned it back on and got a green light. So i played lightly for about 3-4 minutes then it went into protect again. After that i got a green light, pounded full tilt all the way home without a problem. I cannot purposely make it go into protect mode again.

    I also turned the gains down last night and it did it again today. No wire loose, the box isnt coming into contact with the amp, the amp is very cool, i really dont know what to do. I dont want to send it in for repair because thats another $100 i could use towards a good amp.

    Both times the amp went into protect voltage was at 14.4V



    ** NEW VEHICLE AND BUILD ** 2003 Jeep Liberty Sport
    2x SPLAudio DAD BD 12s
    2x SK-1500.1s
    Box 5 cubes @ 29hz
    XS Power D3100 & D2400
    Tenney 270A
    4x PowerBass 3xl 6.5s
    Clarion CZ702

  6. #96
    cdc351jeferson's Avatar
    cdc351jeferson is offline CarAudio.com Elite



    Join Date
    Jul 2012
    Location
    austin tx
    Posts
    1,658
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    693 Post(s)

    Re: My SK-1500.1 is junk

    sell it to someone that wants to mess with getting it fixed for a fair price and buy a "NEW" "NON USED AMP" and you wont have to worry about it being abused like this one probally was when you bought it



    headunit : Sony xab-601bt
    fronts: infinity kappa 60.9's
    box : Bill Fitzmaurice Truck tuba DD 600series 10"
    amp: Kicker zx500.1
    REFS: Bradfordp2612 , Double 07 , NASTY08IMPALA , mzlady

  7. #97
    JoeK's Avatar
    JoeK is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Apr 2012
    Location
    Ringtown, PA
    Age
    20
    Posts
    1,053
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    412 Post(s)

    Re: My SK-1500.1 is junk

    Quote Originally Posted by cdc351jeferson View Post
    sell it to someone that wants to mess with getting it fixed for a fair price and buy a "NEW" "NON USED AMP" and you wont have to worry about it being abused like this one probally was when you bought it
    Eyes on an APSM 2000 or Crescendo 2000D



    ** NEW VEHICLE AND BUILD ** 2003 Jeep Liberty Sport
    2x SPLAudio DAD BD 12s
    2x SK-1500.1s
    Box 5 cubes @ 29hz
    XS Power D3100 & D2400
    Tenney 270A
    4x PowerBass 3xl 6.5s
    Clarion CZ702

  8. #98
    cdc351jeferson's Avatar
    cdc351jeferson is offline CarAudio.com Elite



    Join Date
    Jul 2012
    Location
    austin tx
    Posts
    1,658
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    693 Post(s)

    Re: My SK-1500.1 is junk

    you can almost buy a apsm 2000 for 100$ lol. thats the smartest thing if your sure you install is 100% then get rid of it and have someone else fix it thats into that kinda thing or buy a apsm 1500 for around 100$ as a beaster amp for a few months till you get enough for a good 2k ? just a thought those do rated or real real close to it ?



    headunit : Sony xab-601bt
    fronts: infinity kappa 60.9's
    box : Bill Fitzmaurice Truck tuba DD 600series 10"
    amp: Kicker zx500.1
    REFS: Bradfordp2612 , Double 07 , NASTY08IMPALA , mzlady

  9. #99
    JoeK's Avatar
    JoeK is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Apr 2012
    Location
    Ringtown, PA
    Age
    20
    Posts
    1,053
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    412 Post(s)

    Re: My SK-1500.1 is junk

    Quote Originally Posted by cdc351jeferson View Post
    you can almost buy a apsm 2000 for 100$ lol. thats the smartest thing if your sure you install is 100% then get rid of it and have someone else fix it thats into that kinda thing or buy a apsm 1500 for around 100$ as a beaster amp for a few months till you get enough for a good 2k ? just a thought those do rated or real real close to it ?
    Im sure my install is 100% now. Batteries load tested, all 1/0 gauge up to stock charging line, all connections secure and terminals sheathed. Voltages stable, i just dont get why i have to have a failing amp.



    ** NEW VEHICLE AND BUILD ** 2003 Jeep Liberty Sport
    2x SPLAudio DAD BD 12s
    2x SK-1500.1s
    Box 5 cubes @ 29hz
    XS Power D3100 & D2400
    Tenney 270A
    4x PowerBass 3xl 6.5s
    Clarion CZ702

  10. #100
    cdc351jeferson's Avatar
    cdc351jeferson is offline CarAudio.com Elite



    Join Date
    Jul 2012
    Location
    austin tx
    Posts
    1,658
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    693 Post(s)

    Re: My SK-1500.1 is junk

    because like i said it was more than likley beat and clipped to hell before you bought it . someone ran the **** outa it and sold their problem off to you.. hence why i rarely buy anything used
    Last edited by cdc351jeferson; 10-10-2012 at 05:32 PM. Reason: add info



    headunit : Sony xab-601bt
    fronts: infinity kappa 60.9's
    box : Bill Fitzmaurice Truck tuba DD 600series 10"
    amp: Kicker zx500.1
    REFS: Bradfordp2612 , Double 07 , NASTY08IMPALA , mzlady

  11. #101
    JoeK's Avatar
    JoeK is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Apr 2012
    Location
    Ringtown, PA
    Age
    20
    Posts
    1,053
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    412 Post(s)

    Re: My SK-1500.1 is junk

    Quote Originally Posted by cdc351jeferson View Post
    because like i said it was more than likley beat and clipped to hell before you bought it . someone ran the **** outa it and sold their problem off to you.. hence why i rarely buy anything used
    I thought that the first time it acted up and sent it for repair. But i wouldnt expect a repaired amplifier to have problems again



    ** NEW VEHICLE AND BUILD ** 2003 Jeep Liberty Sport
    2x SPLAudio DAD BD 12s
    2x SK-1500.1s
    Box 5 cubes @ 29hz
    XS Power D3100 & D2400
    Tenney 270A
    4x PowerBass 3xl 6.5s
    Clarion CZ702

  12. #102
    cdc351jeferson's Avatar
    cdc351jeferson is offline CarAudio.com Elite



    Join Date
    Jul 2012
    Location
    austin tx
    Posts
    1,658
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    693 Post(s)

    Re: My SK-1500.1 is junk

    never thought about trying to send it to dbr?



    headunit : Sony xab-601bt
    fronts: infinity kappa 60.9's
    box : Bill Fitzmaurice Truck tuba DD 600series 10"
    amp: Kicker zx500.1
    REFS: Bradfordp2612 , Double 07 , NASTY08IMPALA , mzlady

  13. #103
    JoeK's Avatar
    JoeK is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Apr 2012
    Location
    Ringtown, PA
    Age
    20
    Posts
    1,053
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    412 Post(s)

    Re: My SK-1500.1 is junk

    Quote Originally Posted by cdc351jeferson View Post
    never thought about trying to send it to dbr?
    Another $100+ down the drain for it to die again

    I dont even have $100 now to send it in for repair



    ** NEW VEHICLE AND BUILD ** 2003 Jeep Liberty Sport
    2x SPLAudio DAD BD 12s
    2x SK-1500.1s
    Box 5 cubes @ 29hz
    XS Power D3100 & D2400
    Tenney 270A
    4x PowerBass 3xl 6.5s
    Clarion CZ702

  14. #104
    JoeK's Avatar
    JoeK is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Apr 2012
    Location
    Ringtown, PA
    Age
    20
    Posts
    1,053
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    412 Post(s)

    Re: My SK-1500.1 is junk

    So far today no protection, played full tilt and low volume variously. Amp is warmer than when it did go into protect, but still not hot. This thing makes an *** out of me :|



    ** NEW VEHICLE AND BUILD ** 2003 Jeep Liberty Sport
    2x SPLAudio DAD BD 12s
    2x SK-1500.1s
    Box 5 cubes @ 29hz
    XS Power D3100 & D2400
    Tenney 270A
    4x PowerBass 3xl 6.5s
    Clarion CZ702

  15. #105
    cdc351jeferson's Avatar
    cdc351jeferson is offline CarAudio.com Elite



    Join Date
    Jul 2012
    Location
    austin tx
    Posts
    1,658
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    693 Post(s)

    Re: My SK-1500.1 is junk

    well good to hear yoru shizz works



    headunit : Sony xab-601bt
    fronts: infinity kappa 60.9's
    box : Bill Fitzmaurice Truck tuba DD 600series 10"
    amp: Kicker zx500.1
    REFS: Bradfordp2612 , Double 07 , NASTY08IMPALA , mzlady

Closed Thread
Page 7 of 9 FirstFirst 1 2 3 4 5 6 7 8 9 LastLast

Similar Threads

  1. My 6 month old Optima Yellowtop is junk. What to do?
    By JarvisB in forum Wiring, Electrical and Installation Help
    Replies: 12
    Last Post: 12-22-2009, 12:18 AM
  2. My Freaking Car Is Dying!!!!!!
    By Geminidj2000 in forum General Discussion
    Replies: 10
    Last Post: 12-27-2002, 02:30 PM
  3. So thats why my PM box is always full!!!
    By ifandorbuts in forum General Discussion
    Replies: 6
    Last Post: 12-20-2002, 01:46 AM
  4. My 2 channel is now 1!
    By SKMexiFry in forum Amplifiers
    Replies: 1
    Last Post: 10-23-2002, 03:09 PM
  5. Well my friends IDMAX is shot
    By Thumpin'Ram in forum Subwoofers
    Replies: 1
    Last Post: 06-26-2002, 09:07 PM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum