Closed Thread
Results 1 to 4 of 4

Reload Thread: Twilight Of The Gods

  1. #1
    Shojahan's Avatar
    Shojahan is offline Banned



    Join Date
    Apr 2012
    Location
    San Juan Capistrano
    Posts
    32
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    11 Post(s)

    Twilight Of The Gods

    Krom,

    I might have done something stupid. Yesterday, I bought a new RCA cable because it looked like a better shielded model than the RCA cable I had already. After installation, I started driving to work and put the stereo on. After a few moments I realized there was no sound coming through the left channel.

    So I pulled over to the side of the road and then without turning off the engine or the stereo, I went to check the amp in the trunk. I pulled out the RCA connections ( I use splitters to 4 channels because the HU only has one 1 X pre-out) and firmly pushed them back in again.

    Then after getting back in the car, I reached behind the console under the dash to the back of the HU ( you can do this in an '88 Prelude) and made sure the RCA jacks back there were firmly connected to the cable. Check and check, but no improvement, so I decided to just turn off the stereo and keep driving.

    The next morning, I had completely forgotten about this incident, and when I got back in the car, I simply turned on the stereo as normal. This time the amp went straight into protection mode, sort of. You see, the protect light keeps turning on and off at a steady rhythm and this is accompanied by a thumping effect from the speakers. This effect occurs even in 'stand-by mode'.

    I've since replaced the RCAs with a working pair, but it made no difference. I've checked and experimented with the ground connection but still nothing. I've checked the on-board fuses as well as the line fuse, but they are perfectly fine. I've pulled out all the speaker cables, but still it keeps blinking, blinking, blinking, blankly at me.

    As I think back to when I first opened the trunk and ventured into the amplifier's lair, it is of no doubt that something terrible happened that day, but I know not what. Perhaps leaking capacitors, perhaps transistors, who knows? My nights are filled with yearning and the days, they give me no pleasure. Voices whisper in my mind haunted by visions of Atlantean spires as I await the coming of Ragnarok. Let him be buried with his amp.







  2. #2
    akheathen's Avatar
    akheathen is offline trianoacitol contraceptiv akheathen is a Supporting Member of the forum!



    Join Date
    Jan 2011
    Location
    Anchorage AK
    Age
    33
    Posts
    2,262
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    220 Post(s)

    Re: Twilight Of The Gods

    first, pull the rcas from the amps and see if it will power up. note if the head has trouble powering on, as well. only thing i can think of is a ground problem in the amp, or head, which could have already caused damage to either..



    *IF I have forgotten to exchange feedback, please let me know*
    i buy broken amps....
    No, i will not "gift" paypal. please do not even make it awkward by asking. if the fees are an issue, I am usually inclined to add them. unless you have discount elsewhere, shipping is through usps flat rate, through usps parcel post, or through the roof..... i am in alaska. thanks
    -Heath H-

  3. Thanks Shojahan thanked for this post
  4. #3
    Shojahan's Avatar
    Shojahan is offline Banned

    Threadstarter


    Join Date
    Apr 2012
    Location
    San Juan Capistrano
    Posts
    32
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    11 Post(s)

    Re: Twilight Of The Gods

    The HU powered up and played fine, but I've installed a new one anyway. The RCAs and the speaker cables are all removed. I've cut fresh black wire and secured a new ground. Still the blinking. Is is time to infiltrate this amp and recon the caps and transistors?




  5. #4
    akheathen's Avatar
    akheathen is offline trianoacitol contraceptiv akheathen is a Supporting Member of the forum!



    Join Date
    Jan 2011
    Location
    Anchorage AK
    Age
    33
    Posts
    2,262
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    220 Post(s)

    Re: Twilight Of The Gods

    sounds like an output section, or something has failed in the amp, just unsure as to why, or what pushed it. what amp? usually caps are good for at least 10years. does it give off dc power on any speaker terminals while cycling?



    *IF I have forgotten to exchange feedback, please let me know*
    i buy broken amps....
    No, i will not "gift" paypal. please do not even make it awkward by asking. if the fees are an issue, I am usually inclined to add them. unless you have discount elsewhere, shipping is through usps flat rate, through usps parcel post, or through the roof..... i am in alaska. thanks
    -Heath H-

Closed Thread

Similar Threads

  1. Battery terminals of the gods ..... ( pics )
    By blue in forum Wiring, Electrical and Installation Help
    Replies: 33
    Last Post: 09-10-2005, 07:18 PM
  2. The God Of Subs
    By chronicblazen in forum Subwoofers
    Replies: 25
    Last Post: 02-17-2004, 04:03 AM
  3. how far from the bottom of the box should my ports be?
    By Unregistered in forum Wiring, Electrical and Installation Help
    Replies: 2
    Last Post: 01-25-2002, 10:00 PM
  4. Battle Of The Boom
    By ArcaneParadise in forum Subwoofers
    Replies: 10
    Last Post: 01-03-2002, 11:11 PM

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum