Closed Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 23

Reload Thread: Subwoofer only playing lows?

  1. #1
    stephens30228's Avatar
    stephens30228 is offline CarAudio.com Elite



    Join Date
    Feb 2012
    Location
    Union City, GA
    Posts
    550
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    160 Post(s)

    Subwoofer only playing lows?

    I am not sure of I should put this in sub, amp, or box but hopefully someone can help me. I bought a. Orion 2500d and a dd9512, I also built my own box to put it in. Now it was my first time building a box, but go some reason the dd will only play real lows. On the song "thumb through that check" by rocko it plays the lows parts real low, but the hi hits sounds like crap, my kickers sounded better. What could cause this, also how much should the speaker flex? Or will I know when it is too much?







  2. #2
    Kangaroux's Avatar
    Kangaroux is offline I put on



    Join Date
    Dec 2010
    Location
    Maine
    Posts
    9,604
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1488 Post(s)

    Re: Subwoofer only playing lows?

    Could be a combo of a box that is too small/tuned too high or your low pass filter is turned down too much. Can we get some specs on the box?




  3. #3
    jsluss17's Avatar
    jsluss17 is offline Senior VIP Member



    Join Date
    Oct 2011
    Location
    Scottsdale, AZ
    Posts
    469
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    144 Post(s)

    Re: Subwoofer only playing lows?

    your box is probably tuned really low




  4. #4
    Buck's Avatar
    Buck is offline always low Buck is a Supporting Member of the forum!



    Join Date
    May 2008
    Location
    Nashville
    Posts
    18,378
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    971 Post(s)

    Re: Subwoofer only playing lows?

    Box tuned really low, improper airspace. If it's hitting the highs and sounding like crap, it's probably the box. What is your LPF set at?

    Specs of the box?



    Alpine - ASE (local) - Batcap - C&D Tech - CT Sounds - DC - eD - Excessive Amperage - Rainbow

  5. #5
    stephens30228's Avatar
    stephens30228 is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Feb 2012
    Location
    Union City, GA
    Posts
    550
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    160 Post(s)

    Re: Subwoofer only playing lows?

    Erm I have the specs at home on the computer. I can get them tonight. I know external dimensions are 41" wide, 16" high and 18 deep I believe. The port is 3" wide, but I don't remember how long.




  6. #6
    stephens30228's Avatar
    stephens30228 is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Feb 2012
    Location
    Union City, GA
    Posts
    550
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    160 Post(s)

    Re: Subwoofer only playing lows?

    Quote Originally Posted by Buck View Post
    Box tuned really low, improper airspace. If it's hitting the highs and sounding like crap, it's probably the box. What is your LPF set at?

    Specs of the box?
    75




  7. #7
    Kangaroux's Avatar
    Kangaroux is offline I put on



    Join Date
    Dec 2010
    Location
    Maine
    Posts
    9,604
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1488 Post(s)

    Re: Subwoofer only playing lows?

    Quote Originally Posted by stephens30228 View Post
    Erm I have the specs at home on the computer. I can get them tonight. I know external dimensions are 41" wide, 16" high and 18 deep I believe. The port is 3" wide, but I don't remember how long.
    That box is roughly 5 cubes...in order to be tuned to 32hz for example the port would only need to be 1.5". Me thinks you're tuned into the low 20's or something lol




  8. #8
    stephens30228's Avatar
    stephens30228 is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Feb 2012
    Location
    Union City, GA
    Posts
    550
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    160 Post(s)

    Re: Subwoofer only playing lows?

    Quote Originally Posted by Kangaroux View Post
    That box is roughly 5 cubes...in order to be tuned to 32hz for example the port would only need to be 1.5". Me thinks you're tuned into the low 20's or something lol
    Weeelllll if someone had gotten back with me maybe I would have known that lol. Either way it was my first attempt at a box, will that damage the speaker?




  9. #9
    Kangaroux's Avatar
    Kangaroux is offline I put on



    Join Date
    Dec 2010
    Location
    Maine
    Posts
    9,604
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1488 Post(s)

    Re: Subwoofer only playing lows?

    Quote Originally Posted by stephens30228 View Post
    Weeelllll if someone had gotten back with me maybe I would have known that lol. Either way it was my first attempt at a box, will that damage the speaker?
    The box is huge so your chances of bottoming out the sub are a lot higher. Make your box 10" high instead (on the external dimension). Invest in a 4" aero port and make it around 7-8" long. That should put you at about 2.75 cubes net tuned to 32-33hz. Alternatively, use a 6" aero port and make it around 20" long.




  10. #10
    stephens30228's Avatar
    stephens30228 is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Feb 2012
    Location
    Union City, GA
    Posts
    550
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    160 Post(s)

    Re: Subwoofer only playing lows?

    Quote Originally Posted by Kangaroux View Post
    The box is huge so your chances of bottoming out the sub are a lot higher. Make your box 10" high instead (on the external dimension)
    When I get home I will send you a sketch of the box, cause I didn't think that 10" high was feasible with the speaker on top.




  11. #11
    Buck's Avatar
    Buck is offline always low Buck is a Supporting Member of the forum!



    Join Date
    May 2008
    Location
    Nashville
    Posts
    18,378
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    971 Post(s)

    Re: Subwoofer only playing lows?

    That box is massive.



    Alpine - ASE (local) - Batcap - C&D Tech - CT Sounds - DC - eD - Excessive Amperage - Rainbow

  12. #12
    stephens30228's Avatar
    stephens30228 is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Feb 2012
    Location
    Union City, GA
    Posts
    550
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    160 Post(s)

    Re: Subwoofer only playing lows?

    Well the port takes up about 7" of the width so I thought that would help on the area. Like I said let the flamin begin, but a least I did try.




  13. #13
    wickedwitt's Avatar
    wickedwitt is offline Junior Member



    Join Date
    May 2010
    Location
    Tahoka TX
    Posts
    3,011
    Post Thanks / Like
    Images
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1015 Post(s)

    Re: Subwoofer only playing lows?

    Quote Originally Posted by Kangaroux View Post
    The box is huge so your chances of bottoming out the sub are a lot higher. Make your box 10" high instead (on the external dimension). Invest in a 4" aero port and make it around 7-8" long. That should put you at about 2.75 cubes net tuned to 32-33hz. Alternatively, use a 6" aero port and make it around 20" long.
    I started a long winded speech as to why parts of this was wrong, but I give up. Bigger boxes are more efficient, they don't necessarily make it "easier to bottom out". If tuned properly, it would actually be harder to unload the subs. Keep the dimensions, just tune the box properly. You'll be amazed at the output.



    Stupid Loud.

  14. #14
    stephens30228's Avatar
    stephens30228 is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Feb 2012
    Location
    Union City, GA
    Posts
    550
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    160 Post(s)

    Re: Subwoofer only playing lows?

    Well I assumed it was either the box wrong or the amp tuned wrong because on really low songs the system is STUPID loud. But only on the low parts lol




  15. #15
    Buck's Avatar
    Buck is offline always low Buck is a Supporting Member of the forum!



    Join Date
    May 2008
    Location
    Nashville
    Posts
    18,378
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    971 Post(s)

    Re: Subwoofer only playing lows?

    2.5 cubes is what I'd do, tuned like 32-35 depending. Good range and decent lows.



    Alpine - ASE (local) - Batcap - C&D Tech - CT Sounds - DC - eD - Excessive Amperage - Rainbow

Closed Thread
Page 1 of 2 1 2 LastLast

Similar Threads

  1. 5.1 Surround only playing front channels
    By Ivoryblade in forum Home Audio/Video
    Replies: 2
    Last Post: 03-23-2006, 09:22 AM
  2. HU only plays when hot?????
    By blackMTXgold in forum Head Units
    Replies: 10
    Last Post: 07-07-2005, 09:24 PM
  3. CD/R's only play once in awhile
    By blindcornbread in forum General Discussion
    Replies: 3
    Last Post: 08-20-2004, 10:24 PM
  4. Pioneer DEH-P6400...Only plays music where it wants!!!!
    By Beau20 in forum General Discussion
    Replies: 1
    Last Post: 06-21-2004, 05:41 PM
  5. Subwoofer stops playing, howcome?
    By nofriends46 in forum General Discussion
    Replies: 12
    Last Post: 05-11-2002, 06:37 PM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum