Closed Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 28

Reload Thread: Hifonics 2010D BXI stuck in protect mode, suggestions?

  1. #1
    xmakeafistx's Avatar
    xmakeafistx is offline CarAudio.com Elite



    Join Date
    Mar 2011
    Location
    Kenosha, WI
    Age
    20
    Posts
    1,089
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    51 Post(s)

    Hifonics 2010D BXI stuck in protect mode, suggestions?

    The amplifier was being put to use on an RE8 wired at 8 ohms previously, so no abuse whatsoever..

    Anyway, I sold the RE8 a few weeks ago, and its just been sitting in my trunk. I received my DD 9515e today, and thought i'd try to free air it to see how it goes.

    When I tried I was disappointed to find out that my amp goes straight into protect mode, with the sub wired in, and without the sub wired in. When the amp starts up, it makes that popping sound it normally does, and the green light is there for a split second, then goes straight into protect.

    I am unaware of what could have caused this so suddenly, but i'm hoping its a fast fix. Has anybody ever had this problem before? The wiring is exactly how it was while it was working, so I don't really foresee that being a problem.

    I'm looking up and down the board and there are no burn marks, and nothing smells like it.

    Any help would be greatly appreciated, I was really excited to finally get another build going, and this is just kind of a downer.

    I am aware Hifonics isn't anywhere near the best brand for amplifiers, or anything for that matter. I do not need to be reminded, I just want it fixed because it is a use able piece of equipment.

    Thanks all for the help in advance, I have an o scope and a DMM if needed.



    Amp: None
    Sub: None
    HU: Parrot Asteroid Single Din
    Front Stage: Massive CK6X Component Set (one mid-woofer went out recently)
    Rear Fill: None
    Electrical Upgrades: None




  2. #2
    Infaredsinsor's Avatar
    Infaredsinsor is offline Audio addict



    Join Date
    Nov 2011
    Location
    Portsmouth, VA
    Age
    35
    Posts
    47
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    11 Post(s)

    Re: Hifonics 2010D BXI stuck in protect mode, suggestions?

    Virtually all amplifiers have some sort of active protection circuit. Most have the following types of protection circuits:

    Overview of the Most Common Circuits:
    Over-Current Protection:
    Over-current protection is typically used to shut down the amplifier if too much current flows through the output transistors. The most common circuits monitor the voltage across the emitter resistors. When the voltage becomes too high (due to high current flow), a transistor switches on and tells the amplifier to shut down.

    Thermal Protection:
    Thermal protection shuts the amplifier down when it gets too hot. Typically, only the temperature of the heatsink is monitored. If the heatsink is large, there will likely be more than one thermal sensor. In some cases, the temperature of the large filter capacitors and the temperature of the transformer are also monitored. The most common thermal sensor is an NTC thermistor. Some amplifiers use snap action thermostats but they are not too common in the newer amplifiers.

    DC Offset Protection:
    DC offset protection shuts the amplifier down when there is an unacceptable level of DC on the speaker output terminals. Generally, the feedback circuit keeps the DC offset well within acceptable levels but sometimes a component will fail which will cause the DC voltage on the output terminals of the amplifier to become high enough to destroy the speakers. Before any speakers are damaged, the DC offset protection circuit shuts the amplifier down.




  3. #3
    xmakeafistx's Avatar
    xmakeafistx is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Mar 2011
    Location
    Kenosha, WI
    Age
    20
    Posts
    1,089
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    51 Post(s)

    Re: Hifonics 2010D BXI stuck in protect mode, suggestions?

    thanks for all of that man, it could be the DC offset, it seems like the only consistent one.. I'm not running high voltage at all either.



    Amp: None
    Sub: None
    HU: Parrot Asteroid Single Din
    Front Stage: Massive CK6X Component Set (one mid-woofer went out recently)
    Rear Fill: None
    Electrical Upgrades: None

  4. #4
    xmakeafistx's Avatar
    xmakeafistx is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Mar 2011
    Location
    Kenosha, WI
    Age
    20
    Posts
    1,089
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    51 Post(s)

    Re: Hifonics 2010D BXI stuck in protect mode, suggestions?

    Just tried unplugging/plugging back in. still doesn't work.

    Bleh, leaves me sour.



    Amp: None
    Sub: None
    HU: Parrot Asteroid Single Din
    Front Stage: Massive CK6X Component Set (one mid-woofer went out recently)
    Rear Fill: None
    Electrical Upgrades: None

  5. #5
    Timmothy Web's Avatar
    Timmothy Web is offline Senior VIP Member



    Join Date
    Jul 2011
    Location
    Memphis, Tennessee, United States
    Posts
    305
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    45 Post(s)

    Re: Hifonics 2010D BXI stuck in protect mode, suggestions?

    give it to me!




  6. #6
    xmakeafistx's Avatar
    xmakeafistx is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Mar 2011
    Location
    Kenosha, WI
    Age
    20
    Posts
    1,089
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    51 Post(s)

    Re: Hifonics 2010D BXI stuck in protect mode, suggestions?

    Lol, not giving it away definitely.

    I'd pay for a repair before I'd do that.. sorry? lol.

    EDIT: Unless you mean for repair, I may have misread it, hahah.



    Amp: None
    Sub: None
    HU: Parrot Asteroid Single Din
    Front Stage: Massive CK6X Component Set (one mid-woofer went out recently)
    Rear Fill: None
    Electrical Upgrades: None

  7. #7
    Timmothy Web's Avatar
    Timmothy Web is offline Senior VIP Member



    Join Date
    Jul 2011
    Location
    Memphis, Tennessee, United States
    Posts
    305
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    45 Post(s)

    Re: Hifonics 2010D BXI stuck in protect mode, suggestions?

    i can do that too... but i love these amps!!!




  8. #8
    Timmothy Web's Avatar
    Timmothy Web is offline Senior VIP Member



    Join Date
    Jul 2011
    Location
    Memphis, Tennessee, United States
    Posts
    305
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    45 Post(s)

    Re: Hifonics 2010D BXI stuck in protect mode, suggestions?

    let me know.




  9. #9
    akheathen's Avatar
    akheathen is offline trianoacitol contraceptiv akheathen is a Supporting Member of the forum!



    Join Date
    Jan 2011
    Location
    Anchorage AK
    Age
    33
    Posts
    2,259
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    218 Post(s)

    Re: Hifonics 2010D BXI stuck in protect mode, suggestions?

    reallly, you love bxi? i love zr1000...... hmmmmm. anyways, try ohming the speaker terminals as-is. try poering it up without the speaker terminals attached. if it does, then measure for dc on the speaker terminals. last, disconnect it and let it discharge for a day, then see if it will come back to life. i have seen many amps enter protect being hooked back up, and then later power up just fine, never to have a problem again.



    *IF I have forgotten to exchange feedback, please let me know*
    i buy broken amps....
    No, i will not "gift" paypal. please do not even make it awkward by asking. if the fees are an issue, I am usually inclined to add them. unless you have discount elsewhere, shipping is through usps flat rate, through usps parcel post, or through the roof..... i am in alaska. thanks
    -Heath H-

  10. #10
    Timmothy Web's Avatar
    Timmothy Web is offline Senior VIP Member



    Join Date
    Jul 2011
    Location
    Memphis, Tennessee, United States
    Posts
    305
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    45 Post(s)

    Re: Hifonics 2010D BXI stuck in protect mode, suggestions?

    yea ive ran the ones i rebuilt under .5 ohms. and the amp is still going. its a test amp for now using different parts. i have a 1600w running two quad 1 ohm mojo 15s. and the amp has lasted 4 months now.




  11. #11
    Timmothy Web's Avatar
    Timmothy Web is offline Senior VIP Member



    Join Date
    Jul 2011
    Location
    Memphis, Tennessee, United States
    Posts
    305
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    45 Post(s)

    Re: Hifonics 2010D BXI stuck in protect mode, suggestions?

    i had a rz1000 to repair. the guy hasnt used it yet. but that amp is a beast.




  12. #12
    akheathen's Avatar
    akheathen is offline trianoacitol contraceptiv akheathen is a Supporting Member of the forum!



    Join Date
    Jan 2011
    Location
    Anchorage AK
    Age
    33
    Posts
    2,259
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    218 Post(s)

    Re: Hifonics 2010D BXI stuck in protect mode, suggestions?

    i keep missing out on any zr that came up in my price range. would actually prefer blown, so i don't feel so bad when i replace half the parts to freshen it up, lol. would really like 2 tbh.



    *IF I have forgotten to exchange feedback, please let me know*
    i buy broken amps....
    No, i will not "gift" paypal. please do not even make it awkward by asking. if the fees are an issue, I am usually inclined to add them. unless you have discount elsewhere, shipping is through usps flat rate, through usps parcel post, or through the roof..... i am in alaska. thanks
    -Heath H-

  13. #13
    Timmothy Web's Avatar
    Timmothy Web is offline Senior VIP Member



    Join Date
    Jul 2011
    Location
    Memphis, Tennessee, United States
    Posts
    305
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    45 Post(s)

    Re: Hifonics 2010D BXI stuck in protect mode, suggestions?

    i might try to get it. he doesnt know what he have. he got it for 50 bucks. he thought it was working lol.




  14. #14
    CAT MAN's Avatar
    CAT MAN is offline Banned



    Join Date
    Dec 2010
    Location
    Roanoke,VA
    Posts
    8,131
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2373 Post(s)

    Re: Hifonics 2010D BXI stuck in protect mode, suggestions?

    unplug all power and speaker connections and run a jumper on the amps pos to the neg . it will get rid of any power left in it and more than likely reset the code




  15. #15
    xmakeafistx's Avatar
    xmakeafistx is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Mar 2011
    Location
    Kenosha, WI
    Age
    20
    Posts
    1,089
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    51 Post(s)

    Re: Hifonics 2010D BXI stuck in protect mode, suggestions?

    without the speaker terminals attached? I'm really nubby, or I could just be reading this wrong lol.

    Run a jumper?

    Like I get exactly what you guys are saying, just disconnect and rid of any power so it will reset, but just the obstacle is how.

    Thanks for all your patience guys, you really are saving me here. I'm a little new to the whole fixing amp game here.

    If nothing goes well, I've decided I'll just ship out to Tim for a rebuild



    Amp: None
    Sub: None
    HU: Parrot Asteroid Single Din
    Front Stage: Massive CK6X Component Set (one mid-woofer went out recently)
    Rear Fill: None
    Electrical Upgrades: None

Closed Thread
Page 1 of 2 1 2 LastLast

Similar Threads

  1. New Amp, Stuck In protect Mode! Red Light!
    By 670eddie in forum Wiring, Electrical and Installation Help
    Replies: 34
    Last Post: 09-26-2011, 06:24 AM
  2. Amp stuck in protect mode
    By Bassbumper15 in forum Wiring, Electrical and Installation Help
    Replies: 2
    Last Post: 04-14-2010, 08:10 PM
  3. hifonics zx7500 in protect mode
    By vegaskid226 in forum Amplifiers
    Replies: 0
    Last Post: 12-22-2004, 01:32 PM
  4. amp in protect mode
    By loserpunk in forum Amplifiers
    Replies: 11
    Last Post: 05-19-2003, 05:04 PM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum