Closed Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 17

Reload Thread: Kicker zx750.1 not working.. help?

  1. #1
    ridethepony's Avatar
    ridethepony is offline Junior Member



    Join Date
    Nov 2011
    Location
    Sumter, South Carolina, United States
    Posts
    16
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Icon8 Kicker zx750.1 not working.. help?

    I recently purchased a used (my mistake..) Kicker zx750.1 mono amplifier to power my two Alpine 10s.. I wired everything myself and all was fine and well until about 2 weeks ago. It started slowly, but my subs started going in and out (going from full power to about 30% power.. they never really completely went out) every once in a while, so I rechecked all the wiring and tested the subs and they were fine. Sometimes it would magically start working 100% for a few days in a row, but then the other day they went out and stayed out. When I first wired my system, I set my amp at 80 hz, gain about a fourth the way up, and bass boost all the way down. I never really pushed them too hard for fear of blowing them. Now, the only way to get my subs to hit the way they used to at those settings is to turn the gain and the bass boost up.. but even when I do that, they only hit every few beats. I've checked and rechecked my remote wire, RCAs, hot and grounds, and my speaker wires. I've wired someone elses amp into my car and everything works fine. It's got to be the amp. So, I cracked open my amp today and I can't find ANYTHING wrong with it. Please help me???
    Last edited by ridethepony; 11-09-2011 at 11:17 AM. Reason: adding photo







  2. #2
    Timmothy Web's Avatar
    Timmothy Web is offline Senior VIP Member



    Join Date
    Jul 2011
    Location
    Memphis, Tennessee, United States
    Posts
    305
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    45 Post(s)

    Re: Kicker zx750.1 not working.. help?

    Take a look on the inside




  3. #3
    ridethepony's Avatar
    ridethepony is offline Junior Member

    Threadstarter


    Join Date
    Nov 2011
    Location
    Sumter, South Carolina, United States
    Posts
    16
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Kicker zx750.1 not working.. help?

    I did... I opened it up yesterday and I see nothing wrong with it. Anything specific I should look for thought? I checked the MOFSETs and all the other connections and I don't see anything that looks out of the ordinary.




  4. #4
    ridethepony's Avatar
    ridethepony is offline Junior Member

    Threadstarter


    Join Date
    Nov 2011
    Location
    Sumter, South Carolina, United States
    Posts
    16
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Kicker zx750.1 not working.. help?

    I did... I opened it up yesterday and I see nothing wrong with it. Anything specific I should look for though? I checked the MOFSETs and all the other connections and I don't see anything that looks out of the ordinary.




  5. #5
    Timmothy Web's Avatar
    Timmothy Web is offline Senior VIP Member



    Join Date
    Jul 2011
    Location
    Memphis, Tennessee, United States
    Posts
    305
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    45 Post(s)

    Re: Kicker zx750.1 not working.. help?

    did the amp do anything or did it just go dead?




  6. #6
    Why So Cereal?'s Avatar
    Why So Cereal? is offline Invisible Cereal



    Join Date
    Sep 2010
    Location
    Drowning in milk
    Posts
    7,403
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1555 Post(s)

    Re: Kicker zx750.1 not working.. help?

    How old is the amp? What year? When u tested the other amp in your car did you drive around with it Too?
    I had this issue before with a amp. ended up being a RCA cable going bad and whenever it moved certain ways....bass would fade away.
    Also, Did you check the impedance on your subs to make sure one isn't blown?




  7. #7
    akheathen's Avatar
    akheathen is offline trianoacitol contraceptiv akheathen is a Supporting Member of the forum!



    Join Date
    Jan 2011
    Location
    Anchorage AK
    Age
    33
    Posts
    2,259
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    218 Post(s)

    Re: Kicker zx750.1 not working.. help?

    one thing is for sure, don't keep playing like that, aside from this- take voltage reedings at the power terminals and alternate with the remote and positive. compare with the battery voltage. if it starts playing higher, then re-check. move the high/low switch, while giving it low volume signal. the switch could be worn. what ohm are your subs? how are they wiried? that amp is only 2ohm stable.



    *IF I have forgotten to exchange feedback, please let me know*
    i buy broken amps....
    No, i will not "gift" paypal. please do not even make it awkward by asking. if the fees are an issue, I am usually inclined to add them. unless you have discount elsewhere, shipping is through usps flat rate, through usps parcel post, or through the roof..... i am in alaska. thanks
    -Heath H-

  8. #8
    ridethepony's Avatar
    ridethepony is offline Junior Member

    Threadstarter


    Join Date
    Nov 2011
    Location
    Sumter, South Carolina, United States
    Posts
    16
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Kicker zx750.1 not working.. help?

    I'm not sure how old the amp is but its not very old.. they still sell the model I have. We completely switched amps - I wired his into my car and he wired mine into his car. We didn't drive around, but my subs worked perfectly with his amp and his subs did exactly what mine had been doing with my amp. To me, that eliminates any problems with my wiring (all of it, RCAs included because his amp worked perfectly when wired into my RCAs with my car..) Also, I did check the impedance and neither of my subs are blown. They are fine.

    This is what I'm running...
    (2) Apline SWE-1043 4Ohm subs RMS 250
    Class D Monoblock Kicker zx750.1 amplifier (750 watts x 1 at 2 ohms)

    I have them wired like this..
    [IMG]<a href="http://s15.photobucket.com/albums/a351/rebelchick8143/?action=view&amp;current=mysoundsetup.png" target="_blank"><img src="http://i15.photobucket.com/albums/a351/rebelchick8143/mysoundsetup.png" border="0" alt="Photobucket"></a>[/IMG]




  9. #9
    Why So Cereal?'s Avatar
    Why So Cereal? is offline Invisible Cereal



    Join Date
    Sep 2010
    Location
    Drowning in milk
    Posts
    7,403
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1555 Post(s)

    Re: Kicker zx750.1 not working.. help?

    Quote Originally Posted by ridethepony View Post
    I'm not sure how old the amp is but its not very old.. they still sell the model I have. We completely switched amps - I wired his into my car and he wired mine into his car. We didn't drive around, but my subs worked perfectly with his amp and his subs did exactly what mine had been doing with my amp. To me, that eliminates any problems with my wiring (all of it, RCAs included because his amp worked perfectly when wired into my RCAs with my car..) Also, I did check the impedance and neither of my subs are blown. They are fine.

    This is what I'm running...
    (2) Apline SWE-1043 4Ohm subs RMS 250
    Class D Monoblock Kicker zx750.1 amplifier (750 watts x 1 at 2 ohms)

    I have them wired like this..
    [IMG]<a href="http://s15.photobucket.com/albums/a351/rebelchick8143/?action=view&amp;current=mysoundsetup.png" target="_blank"><img src="http://i15.photobucket.com/albums/a351/rebelchick8143/mysoundsetup.png" border="0" alt="Photobucket"></a>[/IMG]
    hmmm, well based on what you said about the amp switch it may be a bad amp. how long ago did u get the amp from whoever? tell them about the issue. he could've abused that amp and then sold it to you. They are not bad amps by any means though. I've had 2, both that I bought used and they both still pound to this day with zero issues! I'm gonna have to blame the previous owner on this one since you bought used.




  10. #10
    ridethepony's Avatar
    ridethepony is offline Junior Member

    Threadstarter


    Join Date
    Nov 2011
    Location
    Sumter, South Carolina, United States
    Posts
    16
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Kicker zx750.1 not working.. help?

    Quote Originally Posted by princ3cmo View Post
    hmmm, well based on what you said about the amp switch it may be a bad amp. how long ago did u get the amp from whoever? tell them about the issue. he could've abused that amp and then sold it to you. They are not bad amps by any means though. I've had 2, both that I bought used and they both still pound to this day with zero issues! I'm gonna have to blame the previous owner on this one since you bought used.
    Yeah, that's the conclusion I've come to. I just wanted to start a thread and explain the situation to make sure I wasn't missing anything. I can't for the LIFE of me find anything wrong with the amp though. I'm gonna have to take it somewhere and have someone look at it I guess..




  11. #11
    Why So Cereal?'s Avatar
    Why So Cereal? is offline Invisible Cereal



    Join Date
    Sep 2010
    Location
    Drowning in milk
    Posts
    7,403
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1555 Post(s)

    Re: Kicker zx750.1 not working.. help?

    you should def do that, could be something simple




  12. #12
    Timmothy Web's Avatar
    Timmothy Web is offline Senior VIP Member



    Join Date
    Jul 2011
    Location
    Memphis, Tennessee, United States
    Posts
    305
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    45 Post(s)

    Re: Kicker zx750.1 not working.. help?

    might be a short in the output section...hard to tell with out looking at it.




  13. #13
    ridethepony's Avatar
    ridethepony is offline Junior Member

    Threadstarter


    Join Date
    Nov 2011
    Location
    Sumter, South Carolina, United States
    Posts
    16
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Kicker zx750.1 not working.. help?

    Quote Originally Posted by Timmothy Web View Post
    might be a short in the output section...hard to tell with out looking at it.
    I'm having someone look at it tonight.




  14. #14
    Timmothy Web's Avatar
    Timmothy Web is offline Senior VIP Member



    Join Date
    Jul 2011
    Location
    Memphis, Tennessee, United States
    Posts
    305
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    45 Post(s)

    Re: Kicker zx750.1 not working.. help?

    can they fix it?




  15. #15
    kramer_212's Avatar
    kramer_212 is offline CarAudio.com Veteran



    Join Date
    Jul 2011
    Location
    Minnesota
    Posts
    4,418
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    469 Post(s)

    Re: Kicker zx750.1 not working.. help?

    bench test it on a speaker to make sure.




Closed Thread
Page 1 of 2 1 2 LastLast

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum