Closed Thread
Results 1 to 8 of 8

Reload Thread: What Happened to this amp?

  1. #1
    MPI's Avatar
    MPI
    MPI is offline Junior Member



    Join Date
    Oct 2010
    Location
    Milwaukee
    Posts
    13
    Post Thanks / Like
    Images
    5
    Mentioned
    0 Post(s)

    What Happened to this amp?

    So I recently purchased a Rockford Fosgate P400-2 amp off of ebay... after installing it I turned my vehicle on and the blue amp Power indicator came on as it is supposed to, then my speakers made a few strange noises, the blue light dimmed and then smoke started pouring from the amp... (this all happened in approximately 5 seconds) and had all the gain and volume levels set as low as possible. This seller has good ratings and it was listed as being new (wasn't in the shrink wrap, but was still very clean and no signs of use) I opened it up so see what had happened in there and 4 of the MOSFETs had fried... does anyone have any ideas as to what happened? I was running it with another P400-2 and a P500-1BD (both turned on just fine) they were all wired in the same exact way.

    Any ideas would be great...

    The mosfets that got fried are marked with lightning
    [IMG][/IMG]







  2. #2
    misfit138's Avatar
    misfit138 is offline a whole new type of aids



    Join Date
    Jun 2009
    Location
    Williamson, WV
    Posts
    12,048
    Post Thanks / Like
    Mentioned
    2 Post(s)

    Re: What Happened to this amp?

    it done blowed up



    I shot out muh mom's vag with bossing papers in hand.

  3. #3
    MPI's Avatar
    MPI
    MPI is offline Junior Member

    Threadstarter


    Join Date
    Oct 2010
    Location
    Milwaukee
    Posts
    13
    Post Thanks / Like
    Images
    5
    Mentioned
    0 Post(s)

    Re: What Happened to this amp?

    I know that.... But WHY would it just die for no good reason?




  4. #4
    Brian_smith06's Avatar
    Brian_smith06 is offline I got a pan, I got a plan



    Join Date
    Apr 2007
    Location
    Overland Park, KS
    Age
    27
    Posts
    4,506
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: What Happened to this amp?

    fosgate?



    2004 Cavalier ls sport
    H/U: Alpine W200 w/H701 processor
    Mid/Highs: 2 pairs ID x65 and full body ultra horns
    Mid/High amp: 3 ID 700.2
    Sub:2x12" IDMax
    Sub amp: ID 1200.1
    ref: massiveaudiocw, SplChoice, Th3pWn3r, duece212, XaznKewLguyX, connersdad19, alex5857, 5.3bowtie, smiley2186, cf2004, Tibor, Zeuslicious, IT Hertz, 310w6,dbeez, thehardknoxlife, matthewo, pokey_159, LaserRed38, jerseyboy, Abc123Abc, James Bang

  5. #5
    misfit138's Avatar
    misfit138 is offline a whole new type of aids



    Join Date
    Jun 2009
    Location
    Williamson, WV
    Posts
    12,048
    Post Thanks / Like
    Mentioned
    2 Post(s)

    Re: What Happened to this amp?

    Quote Originally Posted by MPI View Post
    I know that.... But WHY would it just die for no good reason?
    It's not for man to question the nature of the lord thy god.



    I shot out muh mom's vag with bossing papers in hand.

  6. #6
    MPI's Avatar
    MPI
    MPI is offline Junior Member

    Threadstarter


    Join Date
    Oct 2010
    Location
    Milwaukee
    Posts
    13
    Post Thanks / Like
    Images
    5
    Mentioned
    0 Post(s)

    Re: What Happened to this amp?

    Well Its a good there going to refund my money




  7. #7
    VWBobby's Avatar
    VWBobby is offline PG and SS nuthugger



    Join Date
    Jul 2010
    Location
    Nibiru
    Age
    33
    Posts
    1,323
    Post Thanks / Like
    Mentioned
    1 Post(s)

    Re: What Happened to this amp?

    If everything was wired exactly the same way between the amps you listed - it would have to be a dud. RF and most other manufactures bench test their amps prior to packaging, so I'm surprised you would have a failure from a "new" amp. I'm guessing either the amp was tampered with, shipping damage, or some other installation error. The chances of a new amp frying like this is extremely slim, but I suppose it does happen.




  8. #8
    MPI's Avatar
    MPI
    MPI is offline Junior Member

    Threadstarter


    Join Date
    Oct 2010
    Location
    Milwaukee
    Posts
    13
    Post Thanks / Like
    Images
    5
    Mentioned
    0 Post(s)

    Re: What Happened to this amp?

    that's kinda what i was thinking




Closed Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum