Closed Thread
Results 1 to 11 of 11

Reload Thread: Amp keeps blowing subs?

  1. #1
    big nick's Avatar
    big nick is offline Senior VIP Member



    Join Date
    Jul 2009
    Location
    Long Island
    Posts
    223
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Amp keeps blowing subs?

    alright my amp is a jbl gto700.1 in 2 years ive gone through 5 subs 2 kenwood w3011's (svc rated at 400rms each) and 3 mtx ts55 (dvc rated at 600rms each) every setup has been with two subs so when i had the kenwoods together they should have been able to handle 800 rms and the mtx's should have been able to handle 1200 rms
    my amp does 700x1@2ohms and 425x1@4 ohms everytime the subs blow they are rated higher than the amp
    i realize the subs i had werent exactly the best but i still feel like they shouldnt have blown. the kenwoods were ran at 4 ohms and the mtx's were run at 2 ohms i have 4 gauge wire from the battery to the amp 4 gauge grounded less than a foot away grounded to a bolt holding the seat down with 16 gauge wire from the amp through the terminals and to the subs. Also id like to add that i never had any distortion or clipping

    does anyone have any idea on why i keep blowing my subs? i think my amp is wired fine and everything was bought brand new i plan on getting 2 kicker l5's rated at 600 rms each, i figure that they would be built a little better than everything else ive had or if anyone has another suggestion let me know i realize most of you guys are more knowledgable than me with this stuff lol







  2. #2
    mazdakid's Avatar
    mazdakid is online now CarAudio.com Veteran



    Join Date
    Oct 2004
    Location
    illnoise
    Age
    30
    Posts
    10,404
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    915 Post(s)

    Re: Amp keeps blowing subs?

    Take a picture of the side of your amp with the settings and post it.



    traded-pickup1, power-fanatic07, fbi90909
    sold to-superspank, dumple, JoeRa22, sub-FATHER, TrlcKed_OuT, rosrock, dcole18, RaiN, BassAddictJ, tommyk90, MANTI5, Micah_Jones, mrflamboynt, g6ryder, rebelfromva, n8skow

  3. #3
    Wingsfreak9's Avatar
    Wingsfreak9 is offline CarAudio.com Veteran



    Join Date
    Nov 2009
    Location
    Howell, MI
    Posts
    4,639
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    97 Post(s)

    Re: Amp keeps blowing subs?

    sounds like your clipping your subs. you probably have your gains set too high. an amplifier is pretty much putting out its rated power at half gain so in most cases anything after that is going to send a square signal and clip your subs. clipping=bad news and burnt coils and so forth



    Quote Originally Posted by AZ_G6GT_Beatin View Post
    then your a D U M B A S S can you read that shi t
    Quote Originally Posted by misfit138 View Post
    How did you manage to pack that much stupid into such a small amount of words?
    Sold to: nom nom, Trever, Spooney, dkhage1, tghersh88


    Bought from: MikeyF, Paaco1981, Thorshammer1, Sundownz, Ridinhi, Cl1ckclack, nom nom, profoundwill, vfrrider, El_Weenie, DBBOOM

  4. #4
    Horsemanwill's Avatar
    Horsemanwill is offline CarAudio.com Veteran



    Join Date
    Aug 2008
    Location
    Junction City, Kansas
    Posts
    2,975
    Post Thanks / Like
    Images
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    27 Post(s)

    Re: Amp keeps blowing subs?

    Quote Originally Posted by mazdakid View Post
    Take a picture of the side of your amp with the settings and post it.
    this and also what is the setting on ur hu and how loud do you listen to it. also what type of enclosure are you using?



    Pioneer Carrozzeria DEH P01
    Tru SB6
    Silver Flute W17RC38-08 6-1/2" Wool Cone
    Tru Steel S25
    ES Full body horns soon to come
    2x JBL W12GTI

  5. #5
    Wingman0121's Avatar
    Wingman0121 is offline CarAudio.com Veteran



    Join Date
    Mar 2010
    Location
    Wisconsin Rapids, Wisconsin
    Posts
    2,549
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    88 Post(s)

    Re: Amp keeps blowing subs?

    The title should be "I keep blowing subs"


    Turn the bass boost on the headunit and amp to zero, bass/treble to zero(you can boost the high if you want) then set the gain on the sub amp to about 3/4. 95% of the time when people blow subs is because they're turning up the bass volume higher than what the amplifier/subwoofer can handle so it isn't the amp's fault. Clipped power from your amplifier is not good for the subs either.



    Sold to: Mills561, Kross6622, sleazebagger, shpatb, esmokah
    Traded: Kross6622
    Bought from: DJ Nitrous 427, 97maxima

  6. #6
    big nick's Avatar
    big nick is offline Senior VIP Member

    Threadstarter


    Join Date
    Jul 2009
    Location
    Long Island
    Posts
    223
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Amp keeps blowing subs?

    the subs are in a vented enclosure
    the settings on my headunit are the bass is at 2 out of 8 and my normal volume is either 25 or 26 out of 35 if i want to get the bass going hard ill hit it up to 30 for a few seconds but ill never play a full song on 30
    here are the pictures





  7. #7
    rosshimself13's Avatar
    rosshimself13 is offline Senior VIP Member



    Join Date
    Nov 2009
    Location
    GC, il
    Posts
    373
    Post Thanks / Like
    Images
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    4 Post(s)

    Re: Amp keeps blowing subs?

    what kind voltage is coming from your head unit



    Quote Originally Posted by oldschoolboomer View Post
    well the 2 round twelves are pie r square and the l7's are already square so they would hit way harder especially when your amp puts out square waves which I assume is quite often


    bought from: PioneerSPL1990, galacticmonkey, Plottin4sucess, djarmy2004, michaellane, slam, k_schutte, theMessenjah44


  8. #8
    big nick's Avatar
    big nick is offline Senior VIP Member

    Threadstarter


    Join Date
    Jul 2009
    Location
    Long Island
    Posts
    223
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Amp keeps blowing subs?

    the headunit is kenwood kvt 719 so its giving 2volts




  9. #9
    smgreen20's Avatar
    smgreen20 is offline phoenixphorum-com



    Join Date
    Apr 2005
    Location
    Lafayette,IN
    Age
    38
    Posts
    1,172
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    35 Post(s)

    Re: Amp keeps blowing subs?

    Quote Originally Posted by Wingsfreak9 View Post
    an amplifier is pretty much putting out its rated power at half gain....
    Solely dependent on the HU's RCA voltage output.


    Though I will agree, it seems as if you are still somehow clipping the poor things to death. It also does appear that everything is set within reason on the amp. The only suggestion I would give is to lower the LP freq setting. You look to be in the neighborhood of ~200 Hz.




    My install
    http://phoenixphorum.com/viewtopic.php?f=10&t=16998

  10. #10
    CHEMMINS's Avatar
    CHEMMINS is offline CarAudio.com Veteran



    Join Date
    Aug 2010
    Location
    Nevernever Land
    Posts
    4,081
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    478 Post(s)

    Re: Amp keeps blowing subs?

    Yup....low pass seems to be set way high. But hard to tell, cause it is not clearly marked increments. Try to find someone with an o-scope. Only way to really tell if you are clipping them.



    References:
    kmarei, ge_off_me, AudioPipe, slim2fattycake, Louisiana_CRX, ARMed&Bangin, EXTREMECHEVYMAN, Dpc69ss, Psychoacoustics, Shinju, jonny101abc, snoopdan

    BUYING SILVER TOP TRF MOTORS



  11. #11
    w00tah's Avatar
    w00tah is offline Captain Keffa



    Join Date
    Oct 2006
    Location
    Z-Ville, OH
    Age
    30
    Posts
    1,790
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    7 Post(s)

    Re: Amp keeps blowing subs?

    What kind of enclosure?



    Kef




    1999 Exploder Sport 2 Door- Build coming soon

    OH MECA S2 competitor- New numbers this season


    Refs: thegreatestpenn (bought and sold in person) Killa Camry (sold to) TaylorFade (sold to)

Closed Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum