Closed Thread
Results 1 to 3 of 3

Reload Thread: bass knob for hifonics amp not working.

  1. #1
    kyleg94cavy's Avatar
    kyleg94cavy is offline Stan Farrey is the man!



    Join Date
    Feb 2003
    Location
    Platteville, WI
    Age
    27
    Posts
    222
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    bass knob for hifonics amp not working.

    the little knob that u put in ur car to adjust the bass for my bx1000d is not working....it was workign till i disconnected it from the amp, but now its not...the light doesnt light up on it like it should when the amp is on? what is wrong w/ it?



    g's up




  2. #2
    dflock's Avatar
    dflock is offline Member



    Join Date
    Dec 2003
    Location
    Rhode Island
    Posts
    101
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: bass knob for hifonics amp not working.

    its broken.




  3. #3
    Woodmister's Avatar
    Woodmister is offline Radford!



    Join Date
    Feb 2003
    Location
    NorthVA
    Age
    28
    Posts
    1,331
    Post Thanks / Like
    Images
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: bass knob for hifonics amp not working.

    Check the connectors on the end of the knob (the one that looks like the phone cord). If any wire is out of place you can/might be able to bend it back into place. Also open the knob up and look at the electrical, see if anything is burnt/fried. Then check the location of the wire on the amp, see if anything is messed up, or out of place there. If nothing can be fixed yourself, order a new one from HiFonics, they usually run $15-20...



    My Garage NEW PICS/WRITEUP on the fiberglass

Closed Thread

Similar Threads

  1. Bass Songs
    By flyasspimp in forum General Discussion
    Replies: 50
    Last Post: 08-22-2005, 11:54 PM
  2. Whats wrong with my amp???
    By badazzDD in forum Amplifiers
    Replies: 6
    Last Post: 09-14-2004, 09:09 PM
  3. amp shuts off at high bass hit
    By eaglemn05 in forum Wiring, Electrical and Installation Help
    Replies: 32
    Last Post: 01-02-2004, 10:57 AM
  4. Capacitor on a 300W amp?
    By Darwin in forum General Discussion
    Replies: 20
    Last Post: 12-29-2003, 04:24 PM
  5. sub amp going into protection when low notes hit
    By B|2imstone in forum Amplifiers
    Replies: 7
    Last Post: 12-08-2003, 03:12 AM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum