Closed Thread
Results 1 to 4 of 4

Reload Thread: Cold AMP Question

  1. #1
    newt3no's Avatar
    newt3no is offline Adire Guy



    Join Date
    Jan 2004
    Location
    NY
    Age
    28
    Posts
    14
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Cold AMP Question

    Lately in my area {NY} its been cold as hell out, 0-20*F and my amp {hifonics brutus 1500d} has either taken very long to power on or hasnt at all. It is behind a rockford fosgate 1 farad cap, and the other amp is powering up and sometimes the hifonics isnt. Is this common ?







  2. #2
    Forty-Ouncer's Avatar
    Forty-Ouncer is offline Senior VIP Member



    Join Date
    Feb 2003
    Location
    Georgetown, ON
    Posts
    325
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Cold AMP Question

    dunno if this will help much, but here in canada its been like -20 to -35 Celcius And Im having no problems with my fosgate or mtx amp even when its too cold for my Alpine H/U to work properly....



    Deck: Alpine IVA-C800
    Fronts: MB Quart Premium PSD216 6.5" Comps
    Rears: MB Quart Discus DSE216 6.5" Comps
    Front/Rear Amp: Alpine MRV-T420 2ch (F/S)
    Subs: 2x 12" MB Quart Premium PWE304
    Sub Amp: NOTHING!!

    Looking for ~1000rmsx1@1ohm mono amp
    Looking for ~100rmsx4@4ohm 4 ch amp

  3. #3
    Join Date
    Dec 2003
    Location
    Minnesota
    Age
    32
    Posts
    46
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Cold AMP Question

    Hrm, takes a good 2 mins to 5 mins for my Gothic 1500 series amp to fully push my sub. If i push the bass to it hard it warms up faster... but usually like 5 mins is good enough.



    ************************
    Head Unit - JVC KD-LH3100
    Front Speakers: KAPPA462.5CFP
    Back Speakers : KAPPA693.5I
    Amp - (for back speakers) Infinity 7520a
    Amp - (Front speakers) Searching
    Amp - (Sub) PA Gothic 1500-2
    Sub - Kicker Comp C15
    ************************

  4. #4
    Trixter's Avatar
    Trixter is offline Keepin it Simple



    Join Date
    Apr 2002
    Location
    Kenosha, WI
    Age
    36
    Posts
    2,608
    Post Thanks / Like
    Images
    29
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Cold AMP Question

    It is amazing how ofter a thread like this comes up during the winter. The best thing you can do to help you equipment is to play it at a low volume for like 5-10min before blasting it. Amps shouldn't be that big of a problem. The colder they are the better they operate since they generate heat. Subs, on the other hand, have moving parts that should be "warmed up" before they are pushed hard.



    2006 Jeep Liberty
    Adire Audio, Cadence, Clarion, MB Quart

    Lv = [(14630000 x R^2) / (Fb^2 x Vb)] - 1.463R
    *Vb = vol. in cu"
    **R = sq.rt. A / Pi (for square/slot port)

Closed Thread

Similar Threads

  1. question on amp racks and such
    By AScreenName in forum General Discussion
    Replies: 3
    Last Post: 12-29-2003, 02:16 PM
  2. Question about my 2 ch amp
    By liqdsm in forum Wiring, Electrical and Installation Help
    Replies: 1
    Last Post: 12-20-2003, 12:31 AM
  3. quik mono amp question
    By stangpounder in forum Wiring, Electrical and Installation Help
    Replies: 5
    Last Post: 11-16-2003, 09:08 PM
  4. Amp wiring question
    By Dookie in forum Amplifiers
    Replies: 0
    Last Post: 11-13-2003, 11:36 PM
  5. stock amp question
    By goodstuff in forum Wiring, Electrical and Installation Help
    Replies: 3
    Last Post: 10-23-2003, 06:03 PM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum