User Tag List

Closed Thread
Results 1 to 3 of 3

Reload Thread: Rockford t400-4 brigged and stable at 2 ohm?

  1. #1
    Kross6622's Avatar
    Kross6622 is offline CarAudio.com Elite



    Join Date
    Aug 2009
    Location
    SCS, MI
    Posts
    604
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Rockford t400-4 brigged and stable at 2 ohm?

    Well today i was just messing around looking up some manuals of amps i have and i looked up my rockford t400-4 amp and noticed something in the manual. Now i have the 07 version which is rated 60@4ohms x 4; 100@2ohms x 4; 200@4ohms x 2 and then it says; 2ohm Load Bridged STABLE

    So my question is, even though it doesn't rate a power at this Impedance it will still run at that low of ohms? or is this a typo?

    Heres a link to get the manual, http://www.rockfordfosgate.com/scrip...ted=1171995579

    Now im currently running it bridged at 4 ohms, and its rated 200w but the birthsheet says 250.

    So my next question is, if it is stable bridged at 2 ohms, why didn't they put a power rating, if i did run it what would i expect in terms of power.

    anyone ever clamp test this amp? i know its a multichannel and i dont see many clamped tests done for them.







  2. #2
    Macklessdaddy's Avatar
    Macklessdaddy is offline CarAudio.com Elite



    Join Date
    Jun 2006
    Location
    San Diego
    Posts
    1,762
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Rockford t400-4 brigged and stable at 2 ohm?

    they are 2ohm stable when bridged,maybe head over to the rockford forum for some numbers



    Kenwood x991
    Alpine Spx-17Ref
    Cadence Zrs 9004
    Oz Me 10" Sealed
    Cadence Zrs 6000D

    My Ebay http://feedback.ebay.com/ws/eBayISAP...ab=AllFeedback

    Refs Louisiana _Crx-Killa Camry-Traksta15-Ganesh134-sacking74



    Quote Originally Posted by jon_k View Post
    Turn the gain down? Quit running impedance at unstable?

  3. Thanks Kross6622 thanked for this post
  4. #3
    Kross6622's Avatar
    Kross6622 is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Aug 2009
    Location
    SCS, MI
    Posts
    604
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Rockford t400-4 brigged and stable at 2 ohm?

    thanks, if anyone comes across some numbers please post them.




Closed Thread

Similar Threads

  1. Rockford Fosgate T400-4 VS Hifonics zxi6410
    By C-Town in forum Amplifiers
    Replies: 1
    Last Post: 02-15-2010, 09:10 PM
  2. Rockford t400-4bd/t600-4bd?
    By bborey in forum Amplifiers
    Replies: 1
    Last Post: 09-23-2009, 02:17 PM
  3. Rockford Fosgate T400-4
    By FunkyJam in forum Amplifiers
    Replies: 1
    Last Post: 06-04-2009, 11:02 AM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum