Closed Thread
Results 1 to 9 of 9

Reload Thread: HELP WITH AMP PROBLEM !!!(please read)

  1. #1
    pioneer's Avatar
    pioneer is offline CarAudio.com Elite



    Join Date
    Mar 2002
    Location
    Trinidad & Tobago
    Age
    31
    Posts
    741
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Icon33 HELP WITH AMP PROBLEM !!!(please read)

    hi....i recently installed a PPI2120 amp in my car...it is powering a pair of 6 by 9's
    i ran the power cables ad the guys in the store recommended and i used the correct sise and type of fuse....today i noticed whilei am driving and i raise the volume to a loud level....the charge light comes on where the speedometer etc is....can someone please tell me what my problem might be ?...did i do something wrong ?
    cuz i really not too sure
    thanks



    why run with the crowd ?

    http://www.steveselectronics.biz - join the forum




  2. #2
    mykeys's Avatar
    mykeys is offline URABUS



    Join Date
    Nov 2001
    Location
    South Prairie, Wa.
    Age
    41
    Posts
    1,057
    Post Thanks / Like
    Mentioned
    0 Post(s)
    If you have 8aeg wire or bigger you are good there.. So the only thing would be that your alternator isn't keeping up with teh current draw from your amp.

    Mike



    Your friendly neighborhood subaru freak!

  3. #3
    pioneer's Avatar
    pioneer is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Mar 2002
    Location
    Trinidad & Tobago
    Age
    31
    Posts
    741
    Post Thanks / Like
    Mentioned
    0 Post(s)
    hi yeh i am using 8 gauge cables...i guess its ym alternator...this morning the car shut down on me...and the charge light kept coming on..even though my amp was off



    why run with the crowd ?

    http://www.steveselectronics.biz - join the forum

  4. #4
    Join Date
    Mar 2002
    Location
    Warwick, RI
    Posts
    66
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Haha, my car had shut down on me once before too. I hadn't put a cap in yet and the current draw was so much that I practically melted the battery. The alternator wasn't supplying enough extra juice thus making the battery work to hard. When I tried to recharge the stupid thing, it just wouldn't. I think I melted the cells! Anyway, yeah, sounds like the alternator... could be something grounding out and causing a short in the system. Check all of your connections and go from there. Peace.




  5. #5
    pioneer's Avatar
    pioneer is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Mar 2002
    Location
    Trinidad & Tobago
    Age
    31
    Posts
    741
    Post Thanks / Like
    Mentioned
    0 Post(s)
    hey StallionAudio
    well the charge light comes on lets about 5 minutes after i put on my amp...even after i take it off...the light still comes on...i read about some people that get there alternator rewound....would that make a difference ?..would it help ?
    my battery is new but i think my alternator has a good few years on it
    thanks



    why run with the crowd ?

    http://www.steveselectronics.biz - join the forum

  6. #6
    Join Date
    Mar 2002
    Location
    Warwick, RI
    Posts
    66
    Post Thanks / Like
    Mentioned
    0 Post(s)
    The charge light is staying on even after you turn your amp off b/c the battery's power is still too low... it sounds like your alternator is really struggling... the battery is supplyin most of the power, so it gets drained quicker. Yeah I have heard of people rewinding their alternators, I had to have the brushes cleaned on an old one of mine. You can try this and it may work. I'm sure if the mechanic looks at it and thinks that it isnt even worth doin or it is gonna be as much as a new one then I would just get a new one. I dont know what kind of car you have, but for domestic cars they arent all that expensive. I dont think that you would need a high output one for just that amp. You may want to look into buying a capacitor as well after you get the new alternator. This will help prevent the situation from happening again. Plus you'll get better performance from the amp with a cap. So you have a couple of options here. Good luck with that stuff guy. Peace.




  7. #7
    pioneer's Avatar
    pioneer is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Mar 2002
    Location
    Trinidad & Tobago
    Age
    31
    Posts
    741
    Post Thanks / Like
    Mentioned
    0 Post(s)
    hi StallionAudio
    thanks again....i have a mazda 626....its pretty old....i think the alternator was serviced a few times..i'll have to check with my ole man...the charge light comes on for about 2 secs...then goes off...then starts to flicker....i plan later on when i get some cash to add another amp and a sub...so whats the best way i should go ?



    why run with the crowd ?

    http://www.steveselectronics.biz - join the forum

  8. #8
    mykeys's Avatar
    mykeys is offline URABUS



    Join Date
    Nov 2001
    Location
    South Prairie, Wa.
    Age
    41
    Posts
    1,057
    Post Thanks / Like
    Mentioned
    0 Post(s)
    I dont know how youd go about getting the car reset but if the charge light annoys you now wait till you put a bigger alt in there..It will come on for both over and under charging...
    A lot of SPL types end up disconnecting the light because of this.

    Mike



    Your friendly neighborhood subaru freak!

  9. #9
    Join Date
    Mar 2002
    Location
    Warwick, RI
    Posts
    66
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Like Mike said the light will come on for over and under powering, that is the whole point of an electrical indicator light... your problem sounds like underpowered. I would go with just a new alternator... especially if your gonna be expanding. Might as well do it right. Again like Mike said you may want to go with disconnecting the light if it still acts up... at least once you put in a new alternator it wont be the underpowering causing it... it'll be b/c you'll have enough juice. The little things can be the most annoying, haha . Take it easy.




Closed Thread

Similar Threads

  1. I Need Help With My Battery! Please Read!
    By MA$E in forum Car Performance and Repair
    Replies: 5
    Last Post: 08-21-2006, 06:12 PM
  2. Need Help With My Battery!!! Please Read!
    By MA$E in forum General Discussion
    Replies: 1
    Last Post: 08-21-2006, 09:13 AM
  3. Replies: 6
    Last Post: 02-26-2004, 08:27 PM
  4. Need help with amp choice.Please help?????!!!
    By bowtiefan in forum Wiring, Electrical and Installation Help
    Replies: 3
    Last Post: 09-28-2002, 02:08 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum