Closed Thread
Results 1 to 11 of 11

Reload Thread: Amplifier keeps shutting down on me!?

  1. #1
    fire919's Avatar
    fire919 is offline Member



    Join Date
    Jan 2010
    Location
    the bronx,NY
    Posts
    136
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Amplifier keeps shutting down on me!?

    i have an alpine mrv-f345, the music sounds crystal clear and i hate to toss it, but it keeps shutting off, i'm getting really annoyed...i can't turn my tunes up loud....the display show's 'CUR' which according to manual means (Amplifier shut down due to excessive current)' then shuts off immediately afterwards....Any Ideas?...can someone tell me y this keeps happening, and what are the reasons y an amplifier will draw excessive current.







  2. #2
    Supergumby5000's Avatar
    Supergumby5000 is offline Project: F350 begins...



    Join Date
    Sep 2005
    Location
    Pullman, WA
    Posts
    8,359
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amplifier keeps shutting down on me!?

    did you set your gains properly, or did you just turn the gain knob up?

    if you just cranked the gain knob, you probably cooked something interally.



    .
    Project: Avalanche V1... http://www.caraudio.com/forum/showthread.php?t=345189
    Project: Avalanche V2... http://www.caraudio.com/forum/showthread.php?t=432321
    Project: F350... Coming Soon!
    .
    Need a box or box design? -EMAIL- me for info/quotes, do NOT send a PM
    my username @ hotmail.com

  3. #3
    DarkScorpion's Avatar
    DarkScorpion is offline CarAudio.com Elite



    Join Date
    Dec 2009
    Location
    Austin, Texas
    Posts
    1,052
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amplifier keeps shutting down on me!?

    Quote Originally Posted by fire919 View Post
    i have an alpine mrv-f345, the music sounds crystal clear and i hate to toss it, but it keeps shutting off, i'm getting really annoyed...i can't turn my tunes up loud....the display show's 'CUR' which according to manual means (Amplifier shut down due to excessive current)' then shuts off immediately afterwards....Any Ideas?...can someone tell me y this keeps happening, and what are the reasons y an amplifier will draw excessive current.
    Are you running any speakers bridged?



    Bought from: BassAddictJ, TBH1, Whitedragon551, Parker G, Ciaonzo, James Bang, GetLikeMe, Here-I-Come
    Sold to: Slim2fattycake, Bigbangtheory, Safe_Cracker, Burton6431
    Traded: Bergend2

  4. #4
    kr15's Avatar
    kr15 is offline Polluting Residentials



    Join Date
    Feb 2010
    Location
    California
    Posts
    3,103
    Post Thanks / Like
    Mentioned
    1 Post(s)

    Re: Amplifier keeps shutting down on me!?

    3 common reasons an amp will shut down--

    1. gain on max and ****** electical that cant support it
    2. impedence load amp cant handle
    3.bad ground



    Team Flex Issues
    45s out the trunk..lowww

    REFS- Supergumby5000, Lastcall, 919motoring, hippishake, daboyfromdabx (great seller), beach22

  5. #5
    fire919's Avatar
    fire919 is offline Member

    Threadstarter


    Join Date
    Jan 2010
    Location
    the bronx,NY
    Posts
    136
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amplifier keeps shutting down on me!?

    No, speakers are not bridged.....gain's, well i have to check that out again...but why does amp allow for a higher gain setting if it gonna do Sh*t when u dial it up, that dosen't make no sense...anyway i will check ground's again, and again and again....O yeah, what if i am using 4gauge and recommended wiring is 8 gauge, would that contribute to an excessive draw(more power running through 4gauge as oppose to 8gauge) thats just ah guess on my end.....thanks so far for assistance!




  6. #6
    fire919's Avatar
    fire919 is offline Member

    Threadstarter


    Join Date
    Jan 2010
    Location
    the bronx,NY
    Posts
    136
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amplifier keeps shutting down on me!?

    change gain to 1.6, was able to play music without amp shuuting down, but what i noticed is the voltage reading on the amp fluctuates between 13.8v-12.4v. I know i suppose to move, but by that much. anyway if i set the gain any lower than 1.6 amp does that sh*t again. still kinda pissed because the output isn't really that loud to me, but atleast now i can hear vocals much better.thanks alot guys, really was getting tierd of swithing off/on my amp....in future should i decide to upgrade...any recommendations for 4 channel amp SQ & SPL.




  7. #7
    kr15's Avatar
    kr15 is offline Polluting Residentials



    Join Date
    Feb 2010
    Location
    California
    Posts
    3,103
    Post Thanks / Like
    Mentioned
    1 Post(s)

    Re: Amplifier keeps shutting down on me!?

    any recommendations for 4 channel amp SQ & SPL.
    well, are you trying to get spl out of your mids and highs?



    Team Flex Issues
    45s out the trunk..lowww

    REFS- Supergumby5000, Lastcall, 919motoring, hippishake, daboyfromdabx (great seller), beach22

  8. #8
    fire919's Avatar
    fire919 is offline Member

    Threadstarter


    Join Date
    Jan 2010
    Location
    the bronx,NY
    Posts
    136
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amplifier keeps shutting down on me!?

    yah




  9. #9
    Mattd0344's Avatar
    Mattd0344 is offline CarAudio.com Elite



    Join Date
    Apr 2008
    Location
    Colorado
    Posts
    1,136
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amplifier keeps shutting down on me!?

    does the amp have good ventilation? it could be heating up real bad if it doesn't



    REFS
    Sold to: krazykarl, power-fanatic07, Ellsworthz, jhughes, bornintothis, RetroAudioinc, tuck05, 813thumper, Kaaialii, 09Alti, kodak314/sostl, Worstenemy453, hrtbrk1, jjbeenken, Inferno333, jesuspunk25 and jamesw
    Bought from: sundownz, ls2poweredgoat, and blue200sx
    Traded with: dB-r, skateguy92 and 5.3bowtie

    Team Shok

  10. #10
    kr15's Avatar
    kr15 is offline Polluting Residentials



    Join Date
    Feb 2010
    Location
    California
    Posts
    3,103
    Post Thanks / Like
    Mentioned
    1 Post(s)

    Re: Amplifier keeps shutting down on me!?

    yah
    so you are trying to get spl out of your mids and highs? you know thats kind of impossible right?



    Team Flex Issues
    45s out the trunk..lowww

    REFS- Supergumby5000, Lastcall, 919motoring, hippishake, daboyfromdabx (great seller), beach22

  11. #11
    Paaco1981's Avatar
    Paaco1981 is offline CarAudio.com Elite



    Join Date
    Dec 2007
    Location
    Wilmington,NC
    Posts
    813
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)

    Re: Amplifier keeps shutting down on me!?

    Quote Originally Posted by fire919 View Post
    No, speakers are not bridged.....gain's, well i have to check that out again...but why does amp allow for a higher gain setting if it gonna do Sh*t when u dial it up, that dosen't make no sense...anyway i will check ground's again, and again and again....O yeah, what if i am using 4gauge and recommended wiring is 8 gauge, would that contribute to an excessive draw(more power running through 4gauge as oppose to 8gauge) thats just ah guess on my end.....thanks so far for assistance!
    The gain knob on your amp is not just a volume knob. If you had it turned all the way up theres an extremely high chance that your problem was with that. I would read over this thread, make sure your amp is set up correctly, then if you are still having problems come back and let us know whats going on.
    Car Audio Classifieds




Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum