Closed Thread
Results 1 to 2 of 2

Reload Thread: NEED Help Rockford Fosgate T20001db Amp Not Working PLEASE HELP

  1. #1
    Cal29's Avatar
    Cal29 is offline Junior Member



    Join Date
    Feb 2010
    Location
    Desert CA
    Posts
    2
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    NEED Help Rockford Fosgate T20001db Amp Not Working PLEASE HELP

    Ok hey new here, but i got a Rockford Fosgate T20001db amp, and it fell off my amp rack about 5in high only, and i hooked it back up and my subs were distorted, tried my subs on another amp and worked fine. Took the fosgate to a shop they said the GAIN knob broke on it and thats the reason it distorts my subs ?!?!?! They never said they can fix it. When they opened it all the boards were good, and it still powers on by the way. My question is is there a simple way I can fix myself? Like is there a place to buy the part and do it myself? Or any of you in Southern CA that can do it ill pay good! RF reps told me they can but i got to pay shipping and wait lol cant wait! Please help IF you can, and im new to car audio btw! Thanks in advance







  2. #2
    peterweiner's Avatar
    peterweiner is offline Banned



    Join Date
    Jan 2010
    Location
    ohio
    Posts
    920
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: NEED Help Rockford Fosgate T20001db Amp Not Working PLEASE HELP

    somethings broke




Closed Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum